Results 1 to 9 of 9

Thread: Can't get .htaccess to work on 10.10

  1. #1
    Join Date
    Jul 2009
    Beans
    12

    Can't get .htaccess to work on 10.10

    Like I said .htaccess won't work on 10.10

    All the guides seem out of date and I can't seem to find much recent stuff on it.

    When i try and change AllowOveride to All instead of None and I put something in the .htaccess folder (not something random a real... err whatever it's called) it gives me this:

    "Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Apache/2.2.16 (Ubuntu) Server at localhost Port 80"

    Thanks,
    h1ll37

  2. #2
    Join Date
    Apr 2010
    Beans
    36
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Can't get .htaccess to work on 10.10

    What exactly are you putting into .htaccess? Did you try using a blank .htaccess file to be sure it is your content that is causing the error?

    What version of php are you using?

  3. #3
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    8,096
    Distro
    Kubuntu Development Release

    Re: Can't get .htaccess to work on 10.10

    Quote Originally Posted by h1ll37 View Post
    When i try and change AllowOveride to All instead of None
    AllowOverride has two r's in it. Does yours?

    More information about this error may be available in the server error log.
    Did you check the logs? They're in /var/log/apache2. You'll need to use sudo to read them.

  4. #4
    Join Date
    Jul 2009
    Beans
    12

    Re: Can't get .htaccess to work on 10.10

    SeijiSensei:
    Yes mine does type-o ;p

    Here is my error log: http://paste.ubuntu.com/540101/

    Doulos1:
    I am using PHP5, and yes I tried making the htaccess folder blank, it works then.

  5. #5
    Join Date
    Jun 2007
    Location
    Porirua, New Zealand
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Can't get .htaccess to work on 10.10

    I'm not quite sure why, but your server seems to be tripping up on something in your .htaccess file that refers to 'RewriteEngine':
    /var/www/.htaccess: Invalid command 'RewriteEngine'
    Forum DOs and DON'Ts
    Never assume that information you find using a search engine is up-to-date.

  6. #6
    Join Date
    Jul 2009
    Beans
    12

    Re: Can't get .htaccess to work on 10.10

    Lisati:
    Yeah that's what a guy in the ubuntu IRC for "httpd" said but he's not much help, he's kinda being a d... yyeah lol.

  7. #7
    Join Date
    Apr 2010
    Beans
    36
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Can't get .htaccess to work on 10.10

    htaccess is working, otherwise you wouldn't be getting the error message. As I am sure you know, that means your server doesn't like something inside htaccess. Post the contents of your htaccess file. I have had issues with php5.3 and htaccess before, though not the same issue you are having.
    Last edited by Doulos1; December 5th, 2010 at 11:56 PM.

  8. #8
    Join Date
    Jul 2009
    Beans
    12

    Re: Can't get .htaccess to work on 10.10

    It ended up being i didn't have mod_rewrite enabled.

    I decided to just use the vhost file which I didn't know I could do before ;p

    On an off-note if you guys ever want to meet some real internet douche bags go ahead and go on freenode.net irc channel is #httpd

    They helped but in the douchiest ways they could think of. Thanks for trying to kindly help me to all you guys.

  9. #9
    Join Date
    Jun 2007
    Location
    Porirua, New Zealand
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Can't get .htaccess to work on 10.10

    Quote Originally Posted by h1ll37 View Post
    Lisati:
    Yeah that's what a guy in the ubuntu IRC for "httpd" said but he's not much help, he's kinda being a d... yyeah lol.
    Apologies for my reply not being more helpful: the best excuse I can come up with at the moment was that I was using a Windows (XP) machine at work, and didn't have chance to research more.
    Forum DOs and DON'Ts
    Never assume that information you find using a search engine is up-to-date.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •