Results 1 to 2 of 2

Thread: Enable compiz on a Core i5 (Arrandale) based laptop

  1. #1
    Join Date
    Sep 2009
    Location
    Pretoria, South Africa
    Beans
    42
    Distro
    Ubuntu 10.04 Lucid Lynx

    Enable compiz on a Core i5 (Arrandale) based laptop

    Hi,
    I am trying to enable compiz desktop effects on my laptop but it keeps saying effects could not be enabled. I am not sure what is the cause since other people on the forums have said effects work fine on the newer intel graphics chipsets. Is there an updated, method to enable them? Special xorg.conf, etc?

    I am not sure what i need to attach so for now I am going to start with <code>lspci</code> and <code>/var/log/Xorg.0.log</code>

    I am not sure if hybrid graphics causes this issue. Especially since in ubuntu only the intel graphics chip is active.

    I have also asked on askubuntu.com. tried searching google, but no conclusive guide

    http://askubuntu.com/questions/15471...aptop-on-lucid

    Please help me?
    Attached Files Attached Files

  2. #2
    Join Date
    Sep 2009
    Location
    Pretoria, South Africa
    Beans
    42
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Enable compiz on a Core i5 (Arrandale) based laptop

    Quote Originally Posted by eshwar_andhavarapu View Post
    Hi,
    I am trying to enable compiz desktop effects on my laptop but it keeps saying effects could not be enabled. I am not sure what is the cause since other people on the forums have said effects work fine on the newer intel graphics chipsets. Is there an updated, method to enable them? Special xorg.conf, etc?

    I am not sure what i need to attach so for now I am going to start with <code>lspci</code> and <code>/var/log/Xorg.0.log</code>

    I am not sure if hybrid graphics causes this issue. Especially since in ubuntu only the intel graphics chip is active.

    I have also asked on askubuntu.com. tried searching google, but no conclusive guide

    http://askubuntu.com/questions/15471...aptop-on-lucid

    Please help me?
    I managed to get compiz to work. i uninstalled nvidia's proprietary driver (nvidia-current). now with nouveau, glxinfo gives decent output and says direct rendering is enabled (turns out its talking about the intel chip). then i go to desktop effects, and when i select extra, it says install nvidia proprietary drivers, i click cancel, the screen blinks but compiz is now enabled.

    Also updated the askubuntu.com question to reflect the answer
    Last edited by eshwar_andhavarapu; December 7th, 2010 at 09:37 AM. Reason: added link to askubuntu question

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •