Results 1 to 4 of 4

Thread: automatic change of Resolution on Notebook

  1. #1
    Join Date
    Nov 2010
    Beans
    8

    automatic change of Resolution on Notebook

    Hello everbody.

    I have no idea where to place this question, but since im a complete Linux Beginner i write it down here


    Recently i installed Linux Mint (based on Ubuntu 10.10) on my Lenovo R61i (1.66 Core2Duo, 2GB Ram (soon 4GB) Nvidia NV140M).
    This is paralell to my Windows 7.

    I have 3 states of use for my Notebook. Mobile. In Dockingstation using my 24" Screen and in Dockingstation using the Notebook Screen while using the 24" for my other Computer (via KVM Switch)

    In mobile use everything is fine.

    For the Dockingstation use windows 7 automatically switches the Resolutions to the active Display and deactivates the Notebook Screen when the display is closed.

    Linux always uses the correct Display resolutions, but uses a Virtual Screen to emulate a 1920x1200 Screen even on my Desktop. And Linux doesnt recognize when i close my Notebook and its not possible to clone the Screens and just use the highest available resolution. (If i have the Notebook Screen AND the 24" in use at the same time Windows gives me a cloned view with a lower Resolution on my Notebook, and switched the 24" to its native resolution once i close the Notebooks screen.)

    What do i have to do to get to the desired result?

    And when someone already reads through this Wall of text: Is there a possibility to Sync the Windows and the Linux Version of Firefox?

  2. #2
    Join Date
    Nov 2010
    Beans
    8

    Re: automatic change of Resolution on Notebook

    Nobody has an Idea how to solve this? Or was my explanation garbadge?

  3. #3
    Join Date
    Nov 2007
    Location
    Edmonton, Alberta, Canada
    Beans
    87
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: automatic change of Resolution on Notebook

    Quote Originally Posted by Schwarzie View Post
    Nobody has an Idea how to solve this? Or was my explanation garbadge?
    Did you try installing the proprietary driver? I believe it's under System>Restricted Drivers. I'm not sure which video card you have, but I've found this to be the simplest, and most n00b friendly fix, depending on your card.

    If that doesn't work, you may need to experiment with /etc/X11/xorg.conf, which is definitely not n00b-proof. I'd recommend trying the easy fixes first before you mess about with xorg.conf.

    For your second question, I don't believe there is. I have my firefoxes synched amongst different computer running linux by using Dropbox, but since the profiles are stored in different paths under Windows and Linux, I expect you can't have one common profile for use by different platforms.
    01001001010011010d3str0y.th3.m4chin300010001001011 00

  4. #4
    Join Date
    Nov 2010
    Beans
    8

    Re: automatic change of Resolution on Notebook

    Quote Originally Posted by theluddite View Post
    Did you try installing the proprietary driver? I believe it's under System>Restricted Drivers. I'm not sure which video card you have, but I've found this to be the simplest, and most n00b friendly fix, depending on your card.

    If that doesn't work, you may need to experiment with /etc/X11/xorg.conf, which is definitely not n00b-proof. I'd recommend trying the easy fixes first before you mess about with xorg.conf.
    Yes, im using the proprietary Driver. This distribution asked my directly after the first start if i want to Download and install it.
    Im using a Nvidia NVS140M

    And the problem is more Linux not detecting that the big Screen is no longer active/connected OR that my Notebook is closed.

    EDITH:
    #######XORG.CONF################
    Section "Screen"
    Identifier "Default Screen"
    DefaultDepth 24
    EndSection

    Section "Module"
    Load "glx"
    EndSection

    Section "Device"
    Identifier "Default Device"
    Driver "nvidia"
    Option "NoLogo" "True"
    EndSection
    ###################################
    Last edited by Schwarzie; December 2nd, 2010 at 04:27 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •