Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Start up - black screen - different context - Toshiba Satellite L670D-11Q

  1. #1
    Join Date
    Nov 2010
    Location
    UK
    Beans
    10
    Distro
    Ubuntu Studio 10.10 Maverick Meerkat

    Cool Start up - black screen - different context - Toshiba Satellite L670D-11Q

    Hello friends,

    I googled for quite some time but nothing helped. So desperate here I am.

    The problem:after choosing to boot Ubuntu a black screen with a cursor appears. Unresponsive to any commands.
    The distro: Ubuntu 10.10 x64
    The machine: it is Toshiba Satellite L670D-11Q
    Some history:
    While installing ubuntu I had to choose the acpi=no option, only than I got the install screen and I was able to install the OS. After reboot I added to the grub the acpi=no, after crtl+x the system did not load. I succeeded in loading the system from the live CD only after I turned off the acpi. Clearly the problem is there. Anyway I could not succeed in starting the already installed OS.

    I am not that into computer architecture and OS design so clearly I miss something. If you have any ideas, or need additional information to help, please say it.

    A problem solved is a plus to the whole community
    Thank you in advance.
    Last edited by kris7; November 29th, 2010 at 03:32 AM.

  2. #2
    Join Date
    Nov 2010
    Location
    UK
    Beans
    10
    Distro
    Ubuntu Studio 10.10 Maverick Meerkat

    Re: Start up - black screen - different context - Toshiba Satellite L670D-11Q

    Up, anybody?

  3. #3
    Join Date
    Oct 2006
    Beans
    84

    Re: Start up - black screen - different context - Toshiba Satellite L670D-11Q

    do you know what video chipset it has in it?

  4. #4
    Join Date
    Nov 2010
    Location
    UK
    Beans
    10
    Distro
    Ubuntu Studio 10.10 Maverick Meerkat

    Re: Start up - black screen - different context - Toshiba Satellite L670D-11Q

    ATI Mobility Radeon™ HD 5145

    I will try the 32bit version of Ubuntu. I have the strange feeling that it might just work out.

  5. #5
    Join Date
    Oct 2009
    Beans
    4

    Re: Start up - black screen - different context - Toshiba Satellite L670D-11Q

    I have the same problem with a Toshiba L670D-11N laptop using U10.10-AMD64, probably an issue with the acpi hardware vs drivers. Please share your results

  6. #6
    Join Date
    Nov 2010
    Location
    UK
    Beans
    10
    Distro
    Ubuntu Studio 10.10 Maverick Meerkat

    Re: Start up - black screen - different context - Toshiba Satellite L670D-11Q

    So far only the netbook version works without any obvious problems.
    Anyway no change is observed after the installation of the 32bit version.

  7. #7
    Join Date
    Oct 2009
    Beans
    4

    Re: Start up - black screen - different context - Toshiba Satellite L670D-11Q

    Thanks for the update, I'll try the netbook version tonight.
    Did you perhaps try the 10.04 LTS? (64 or 32 bits)

    I will also update my findings here.

    I bought this laptop especially as an Ubuntu workhorse, and I was so pleased to wipe of that crappy Windows 7 (it already crashed when creating the recovery discs while playing solitaire), so I definitely want it running Linux.

    Any guru's out there that can share some tips I can try?
    Obviously the Toshy has some new chipset that doesn't work well with 10.10 at the moment.

  8. #8
    Join Date
    Nov 2010
    Location
    UK
    Beans
    10
    Distro
    Ubuntu Studio 10.10 Maverick Meerkat

    Re: Start up - black screen - different context - Toshiba Satellite L670D-11Q

    So far I only found that for some reason I can't boot up any windows cds... Tried windows 7 and windows vista.

  9. #9
    Join Date
    Nov 2010
    Location
    UK
    Beans
    10
    Distro
    Ubuntu Studio 10.10 Maverick Meerkat

    Re: Start up - black screen - different context - Toshiba Satellite L670D-11Q

    Quote Originally Posted by bovent View Post
    Thanks for the update, I'll try the netbook version tonight.
    Did you perhaps try the 10.04 LTS? (64 or 32 bits)

    I will also update my findings here.

    I bought this laptop especially as an Ubuntu workhorse, and I was so pleased to wipe of that crappy Windows 7 (it already crashed when creating the recovery discs while playing solitaire), so I definitely want it running Linux.

    Any guru's out there that can share some tips I can try?
    Obviously the Toshy has some new chipset that doesn't work well with 10.10 at the moment.
    I found a solution. For some reason the netbook version does not have any problems with the acpi. Probably because this "laptop" has netbook chipset.

    So basically, install the netbook version. Choose the gnome graphical environment and you will end up with ubuntu looking just like the desktop version but without some software which you can add later

  10. #10
    Join Date
    Oct 2009
    Beans
    4

    Re: Start up - black screen - different context - Toshiba Satellite L670D-11Q

    Hi Kris,
    Thanks for the update.

    I've seem to have fixed it. I've never had to get messy with Grub, but there lies the solution. (Google is your friend (is it?))

    From the start:
    - Boot your Ubuntu installation media
    - Press the 'Escape' button during the first graphical screen
    - Choose your preferred language
    - press 'F6 Other options' and choose acpi=off
    - Choose 'Install Ubuntu'
    - Do your normal installation wizary routine
    - Reboot and press 'Escape' right after your BIOS POST screen: This brings up Grub
    - Select the first line (it should already be selected), and press the e button
    - move your cursor to 'quiet splash' and after a leading space character you type acpi=off
    - now press ctrl-x
    - You are now booting your favorite OS! But are not finished yet..
    - After the succesfull boot, open up a terminal, and type: sudo gedit /boot/grub/grub.cfg
    - find your 'quiet splash' again, and type acpi=off
    - save this file, and reboot. You now have a working Ubuntu install on your Toshiba L670D! (at least on my 11N model)

    I did this install with U10.10-AMD64, and it seems that most hardware like video and sound is working.

    Please share your findings for the 11Q model for the community.

    good luck!

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •