Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Ctrl-c in virtualbox?

  1. #1
    Join Date
    Oct 2010
    Beans
    23

    Ctrl-c in virtualbox?

    I've changed my host key to not be control and I still can't get it to pass a ctrl-c to virtualbox. I searched and looked through some threads for answers, but came up with nothing. Surely I'm missing something simple?

  2. #2
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ctrl-c in virtualbox?

    What host are you using?

    I've been able to use Ctrl + C in VirtualBox for a while now (right ctrl key, as left ctrl is host key)
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  3. #3
    Join Date
    Oct 2010
    Beans
    23

    Re: Ctrl-c in virtualbox?

    I'm hosting an install of 10.10 server with 10.10 desktop. It simply puts a 'c' on the screen whenever I try to press ctrl-c.

  4. #4
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ctrl-c in virtualbox?

    Does it do that with either ctrl key?
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  5. #5
    Join Date
    Oct 2010
    Beans
    23

    Re: Ctrl-c in virtualbox?

    Yes, with either ctrl key. Quite vexing, and a little annoying to have to reboot every time a put to my crappy ftp server locks up.

  6. #6
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ctrl-c in virtualbox?

    Does anything using the Ctrl key work? Ctrl + Z?
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  7. #7
    Join Date
    Mar 2011
    Beans
    1

    Re: Ctrl-c in virtualbox?

    SOLUTION FOUND

    I had the same issue with Ctrl C key etc.

    I'm running Ubuntu host (10.4 / 32bit) and Virtual Box with Ubuntu OS for quick testing and the Ctrl-C wouldn't abort - all Ctrl keys were not being recognised.

    I found the solution is to disable the Ctrl-key "mouse" function on the Ubuntu host (10.4)

    System -> Preferences -> Mouse -> Show position of pointer when Ctrl key is pressed in the host

    Turn this off and the Terminal Ctrl-C returns!

  8. #8
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ctrl-c in virtualbox?

    Interesting. Thanks for posting a solution.
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  9. #9
    Join Date
    Sep 2007
    Beans
    5

    Re: Ctrl-c in virtualbox?

    This helped me solve the Ctrl-C/V within Virtual box not working.
    My guest is XP and my host is 11.04.
    I'm surprised that the Mouse settings "superseeds" the VirtualBox keyboard management.
    This doesn't happen with VMware Workstation 7.1x (never seen it even before 71x).

    Thank you.

  10. #10
    Join Date
    Sep 2011
    Beans
    1

    Re: Ctrl-c in virtualbox?

    it works!!!!!!
    Thank you davidjsmith67, i've been looking for a solution so long ago

    Ubuntu 11.04 with Windows XP virtual box

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •