Results 1 to 3 of 3

Thread: Cannot enable Compiz

  1. #1
    Join Date
    Oct 2007
    Beans
    62

    Question Cannot enable Compiz

    On my system compiz was working fine; until I did an update, It updated a few things like vlc and pidgin, but after I rebooted Compiz didn't want to start. I am not totally sure why.
    My Graphics card is a Nvidia GTX 470; and I have installed the latest driver from Nvidia. This is what I get when I try to run compiz from terminal.
    Code:
    kevin@kevin-desktop:~$ compiz
    compiz (core) - Fatal: No valid GL extensions string found.
    compiz (core) - Error: Failed to manage screen: 0
    compiz (core) - Fatal: No manageable screens found on display :0.0
    
    Launching fallback window manager
    and my Xorg.conf looks like this:

    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 260.19.06  (buildd@palmer)  Mon Oct  4 16:01:38 UTC 2010
    
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 260.19.12  (buildmeister@builder101)  Fri Oct  8 13:54:10 PDT 2010
    
    Section "ServerLayout"
    
    # Removed Option "Xinerama" "off"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "SONY TV"
        HorizSync       15.0 - 70.0
        VertRefresh     58.0 - 62.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce GTX 470"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "metamodes" "1920x1080 +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    Also It is running through an Hdmi cable (although I don't think this really matters).

  2. #2
    Join Date
    May 2010
    Location
    Where God goes to rest:AL
    Beans
    575
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Cannot enable Compiz

    I had the same issue, easily resolved.

    First, let me ask:

    If your car all of a sudden stopped moving because the engine quit, what is the first thing you look at? The gas gauge.

    So, if you have video issues, what should be the first thing you look at? The driver.

    Reinstall it.
    Running wine/WoW on a AMD Athlon 64 X2 5200+(2.6GHz)w/4GB DDRII(667) and a NV9600GSO w/768MB DDRIII.

  3. #3
    Join Date
    Oct 2007
    Beans
    62

    Re: Cannot enable Compiz

    Well thank you! It worked.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •