Page 4 of 4 FirstFirst ... 234
Results 31 to 36 of 36

Thread: rt2870sta / rt2800usb / ndiswrapper not working for: Sitecom 300N Wireless(WL-324)

  1. #31
    Join Date
    Sep 2005
    Beans
    30

    Re: rt2870sta / rt2800usb / ndiswrapper not working for: Sitecom 300N Wireless(WL-324

    2.6.35-25 + Ralink rt2870:

    rt2x00usb: doesn't work
    rt2800usb: doesn't work + system lock

    The wlan backport doesn't work for rt2870.




    The old solution still works:

    - Download the latest driver from ralink.
    - Patch the device id
    - patch the return codes
    - patch the system messages

    make; make install; remove the buggy driver from the kernel; restart

  2. #32
    Join Date
    Dec 2010
    Beans
    30

    Re: rt2870sta / rt2800usb / ndiswrapper not working for: Sitecom 300N Wireless(WL-324

    I want to try this too, but I have no idea how to modify modify RT2870STA.dat for my own country. Does anyone know how to do this for the Netherlands?

  3. #33
    Join Date
    Jul 2009
    Beans
    184
    Distro
    Kubuntu 10.10 Maverick Meerkat

    Re: rt2870sta / rt2800usb / ndiswrapper not working for: Sitecom 300N Wireless(WL-324

    Quote Originally Posted by Y_Ernst View Post
    Meanwhile I have patched the original Ralink driver (v2.4.0.1) to handle the new kernel device messages. Otherwise you get an endless list of error messages in your syslog.
    I have installed v.2.4.0.1. 'iwlist scan' does find my access point, but when I try (with wicd-gtk) to connect to the access point, I get "Bad password", and the system immediately halts. At such situation it is rather difficult to play with configuration to find needed config(s) variant. syslog contains info about wicd segfaulting.

    So I'm interested in this your patch - what do you mean exactly?

    Also, if somebody uses wicd, which WPA Supplicant driver must be selected? wext? ralink_legacy? nl80211?

  4. #34
    Join Date
    Sep 2005
    Beans
    30

    Re: rt2870sta / rt2800usb / ndiswrapper not working for: Sitecom 300N Wireless(WL-324

    A small update for the latest kernel: 2.6.35-27-generic

    There is a small improvement for the "rt2x00usb" module.
    It doesn't immediately crash your system any more. Now you have enough time to reboot your Ubuntu and install the original ralink module: RT2870_Linux_STA_v2.4.0.1

    To patch your device, for example:
    ID 0df6:003d Sitecom Europe B.V. WL-324 Wireless USB Adapter 300N
    add the id to the file: common/rtusb_dev_id.c

    The last few steps are discussed above.

  5. #35
    Join Date
    Sep 2005
    Beans
    30

    Re: rt2870sta / rt2800usb / ndiswrapper not working for: Sitecom 300N Wireless(WL-324

    Update for the latest 10.10 kernel: 2.6.35-28-generic

    Despite the fact that Ralink open-sourced and donated their driver to

    http://rt2x00.serialmonkey.com/wiki/index.php/Main_Page

    the "maintained" linux driver still won't work for the Sitecom 300N usb device.

    Nonetheless you can still use the old drivers mentioned above with the described patches.

  6. #36
    Join Date
    Sep 2005
    Beans
    30

    Re: rt2870sta / rt2800usb / ndiswrapper not working for: Sitecom 300N Wireless(WL-324

    Update for Ubuntu 10.10 2.6.35-28-generic #50-Ubuntu SMP x86_64

    The distro rt2870 and 28xxUSB drivers don't work with the the Sitecom 200N device.

    Follow the instructions above to use your device.

Page 4 of 4 FirstFirst ... 234

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •