Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Ubuntu 10.10 Sound issue / no headphone sound / Asus G50vt

  1. #1
    Join Date
    Jun 2008
    Location
    Long way from there..
    Beans
    44
    Distro
    Ubuntu 10.04 Lucid Lynx

    Ubuntu 10.10 Sound issue / no headphone sound / Asus G50vt

    I just installed Mint 10, which is base on 10.10.
    AND i also tried with Ubuntu 10.10 liveCD.

    Running on a ASUS G50vt-x2 laptop.
    The thing is that im having sound issues.
    Internal speakes work fine.

    But i cant get any sound on my headphones. At least not if i plug them all the way in.
    If i keep them not fully pluged, but a bit out, i get sound on my headphones and on the internal speakers.

    No clue where to start here..
    If its of any help, i also dont have working nor the internal microphones or the mic input, or the audio input. (this laptop has 3 spica plugs).

    Here is my lshw -c sound:
    *-multimedia
    description: Audio device
    product: 82801I (ICH9 Family) HD Audio Controller
    vendor: Intel Corporation
    physical id: 1b
    bus info: pci@0000:00:1b.0
    version: 03
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list
    configuration: driver=HDA Intel latency=0
    resources: irq:48 memory:f9ff8000-f9ffbfff

    Just ring if there's any other info i can provide to you guys in order to know whats going on.

    Thanks guys/grls
    AMD Phenon X6 1090T/8gb 1333/1tb/radeon 5670/ ubuntu 11.04
    ASUS UL30VT-A1 win7 / ubuntu 11.04 / Fedora 15
    Ubuntu Server 10.04 on old laptop (headless lol)
    Linux User #: 525691

  2. #2
    Join Date
    Jun 2008
    Location
    Long way from there..
    Beans
    44
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Ubuntu 10.10 Sound issue / no headphone sound / Asus G50vt

    Ok, finally, after a few days of frustrating search with no luck, i got the solution.
    My hardware is in the first post if you need it.

    SOLUTION:
    Modify the alsa-mixer conf file to recongise your hardware soundcard.
    file locaton: /etc/modprobe.d/alsa-base.conf

    how to edit it:
    sudo nano /etc/modprobe.d/alsa-base.conf (i use nano for text editing, you can use gedit, vi, or the one you please).

    At the last line, i added this one:

    options snd-hda-intel model=m51va position_fix=0

    So my alsa-base.conf looks like (note this are only the last lines.. ):
    # Keep snd-pcsp from being loaded as first soundcard
    options snd-pcsp index=-2
    # Keep snd-usb-audio from beeing loaded as first soundcard
    options snd-usb-audio index=-2
    options snd-hda-intel model=m51va position_fix=0

    That's it ! Just reboot and everything is workig as it should. Plug headphones, sound only on headphones, Unplug, sound on internal speakers !

    If you need to solve it for another laptop model/brand (these are for intel soundcards), here you have a full list of the alsa options to modify the alsa-base.conf file:

    http://doc.ubuntu-fr.org/audio_intel_hda#acer


    I have to thank WaroDaBeast, who gave this solution on this thread.
    Last edited by manco1911; November 20th, 2010 at 07:36 PM.
    AMD Phenon X6 1090T/8gb 1333/1tb/radeon 5670/ ubuntu 11.04
    ASUS UL30VT-A1 win7 / ubuntu 11.04 / Fedora 15
    Ubuntu Server 10.04 on old laptop (headless lol)
    Linux User #: 525691

  3. #3
    Join Date
    Jul 2010
    Location
    Thailand
    Beans
    5
    Distro
    Ubuntu

    Re: Ubuntu 10.10 Sound issue / no headphone sound / Asus G50vt

    Ah! Thank you man. I will try this.

  4. #4
    Join Date
    Dec 2007
    Location
    San Francisco, CA 94112
    Beans
    22

    Re: Ubuntu 10.10 Sound issue / no headphone sound / Asus G50vt

    This is awesome! It worked! Thank you!!!!

  5. #5
    Join Date
    Aug 2007
    Beans
    48

    Re: Ubuntu 10.10 Sound issue / no headphone sound / Asus G50vt

    Worked for me with my headphone issues! (using dell studio xps 1640).

    Thanks so much!

  6. #6
    Join Date
    Dec 2010
    Beans
    5

    Re: Ubuntu 10.10 Sound issue / no headphone sound / Asus G50vt

    Hello Manco1911

    Serious sound problem! please help me out.

    my sound card was fine when i installed ubuntu 10.10,

    but after i saw jsevi83 post, i got huge sound problem, there is no more sound!!! the sound device has gone!
    still thanks Jsevi83 a lot, because fixed my other problems.
    for example i fixed the wireless LED light, calculator, suspend problems.

    please please help me out,right now my world without any sound. my laptop no more sound.

    i checked the lib/modules/2.6.35-24-generic/kernel/sound
    there are no more pci file and others.

    please Help me!!!!!!!!!

    thank you very very much!

  7. #7
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,883
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu 10.10 Sound issue / no headphone sound / Asus G50vt

    Quote Originally Posted by tonyzhp1987 View Post
    my sound card was fine when i installed ubuntu 10.10,
    but after i saw jsevi83 post, i got huge sound problem, there is no more sound!!! the sound device has gone!
    You probably borked your alsa install. Can you do this please?
    Use the alsa-info-script to provide detailed information.
    Run this command in a terminal:
    Code:
    wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
    Choose the upload option and provide a link for the output.
    [Terminal="Applications->Accessories->Terminal"]

  8. #8
    Join Date
    Jan 2011
    Beans
    1

    Re: Ubuntu 10.10 Sound issue / no headphone sound / Asus G50vt

    Tried the code above and it worked perfectly.

    Thanks very much,

    Naes.

  9. #9
    Join Date
    Aug 2010
    Beans
    1

    Re: Ubuntu 10.10 Sound issue / no headphone sound / Asus G50vt

    Have had a problem with headphone sense, etc. with my Asus U50f. Upgraded from 10.04 to 10.10, added a similar line as stated above and in this link:

    http://doc.ubuntu-fr.org/audio_intel_hda#acer

    I chose the first in the table for Asus (A52F) and it worked fine. After the upgrade to 10.10 it shows that I have Intel IbexPeak HDMI (which is not what it said or read in 10.04). 10.10 seems to be easier at resolving this issue; upgrade if it's feasible.

    Now on to the touchpad problems!

  10. #10
    Join Date
    Mar 2010
    Beans
    17

    Cool Re: Ubuntu 10.10 Sound issue / no headphone sound / Asus G50vt

    Thanks! the head phone issue was resolved! however, did you find anything to fix the mic? mine still doesn't want to work. Thanks!

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •