Results 1 to 4 of 4

Thread: Tried the apparmor for Firefox, don't like it. How the heck do I turn it off

  1. #1
    Join Date
    Apr 2009
    Location
    Helena, Montana U.S.A.
    Beans
    312
    Distro
    Ubuntu 12.04 Precise Pangolin

    Tried the apparmor for Firefox, don't like it. How the heck do I turn it off

    Tried the apparmor profile for Firefox. I don't care for it. I can't fire out how to turn it off. No matter what I do, it still shows up as being on in apparmor status.
    Get fingerd, try this,
    Code:
    finger nate@homier.dyndns.org
    http://www.infodrom.org/projects/cfingerd/

  2. #2
    Join Date
    Oct 2006
    Beans
    4,619
    Distro
    Kubuntu 13.10 Saucy Salamander

    Re: Tried the apparmor for Firefox, don't like it. How the heck do I turn it off

    Code:
    sudo ln -s /etc/apparmor.d/usr.bin.firefox /etc/apparmor.d/disable/
    sudo apparmor_parser -R /etc/apparmor.d/usr.bin.firefox
    Blog | Ubuntu User #15350 | Zsh FTW | Ubuntu Security | Nothing to hide?
    AMD Phenom II X6 1075T @ 3GHz, Nvidia GTX 650, 8GB DDR3 RAM, 2 X 1TB HDD
    Please don't request support via PM


  3. #3
    Join Date
    Apr 2009
    Location
    Helena, Montana U.S.A.
    Beans
    312
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Tried the apparmor for Firefox, don't like it. How the heck do I turn it off

    Quote Originally Posted by FuturePilot View Post
    Code:
    sudo ln -s /etc/apparmor.d/usr.bin.firefox /etc/apparmor.d/disable/
    sudo apparmor_parser -R /etc/apparmor.d/usr.bin.firefox
    Thanks a bunch. All the Google results show how to turn it on but not to turn it off. Much obliged.
    Get fingerd, try this,
    Code:
    finger nate@homier.dyndns.org
    http://www.infodrom.org/projects/cfingerd/

  4. #4
    Join Date
    Aug 2007
    Location
    US
    Beans
    884
    Distro
    Ubuntu Development Release

    Re: Tried the apparmor for Firefox, don't like it. How the heck do I turn it off

    Why not just use...

    to enable:
    Code:
    sudo enforce firefox
    to disable:
    Code:
    sudo complain firefox
    Please mark completed threads as [SOLVED], which lets us find solutions faster!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •