Page 1 of 4 123 ... LastLast
Results 1 to 10 of 33

Thread: USB CDROM/DVD Device Problems on Ubuntu 10.10

  1. #1
    Join Date
    Nov 2010
    Beans
    1

    Exclamation USB CDROM/DVD Device Problems on Ubuntu 10.10

    Ubuntu 10.10 seems to have troubles with cdroms...I used Ubuntu 8.04 lts and 10.04 lts with no cdrom issues.
    10.10 does not show my CDROM/DVD USB device in 'Places' and I cannot get it's UUID number via ROOT terminal , yet I did Remastersys backup of entire system, opened the Remastersys folder, right clicked the custom.iso file and burnt it using Brasero, which proves it is working on 10.10 but just not showing an icon. Inserting media of any kind does not open the Nautilus folder, yet other USB devices show immediately (USB sticks and USB harddrive appear instantly).

    The CDROM/DVD USb device works in Windows on a different machine and I also attached a USB harddrive with Windows XP to my netbook which 10.10 is installed on, and the USB CDROM/DVD device shows up fine.
    I tried mounting the device in Ubuntu 10.10, but I'm not that great at understanding commands, and the hundreds of different commands other people tried across the web don't work.

    When I type 'dmesg' the USB CDROM shows up as this (is there an I/O error preventing the USB cdrom drive from displaying???):-

    [ 8284.535666] scsi 9:0:0:0: CD-ROM HL-DT-ST DVDRAM GSA-4084N KQ09 PQ: 0 ANSI: 0
    [ 8285.098044] sr0: scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
    [ 8285.098770] sr 9:0:0:0: Attached scsi CD-ROM sr0
    [ 8285.099262] sr 9:0:0:0: Attached scsi generic sg3 type 5
    [ 9001.878411] usb 1-8: USB disconnect, address 10
    [ 9001.957325] JBD2: I/O error detected when updating journal superblock for sdc1-8.


    Also typing this below showed my device:-
    'ls /dev/disk/by-id -lah'
    lrwxrwxrwx 1 root root 9 2010-11-10 09:42 usb-HL-DT-ST_DVDRAM_GSA-4084N-0:0 -> ../../sr0


    I also typed 'lsusb' and my device showed up on line 6 as 'Genesys Logic, Inc . USB 2.0 IDE Adapter'

    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 002: ID 0168:1998
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 009: ID 05e3:0701 Genesys Logic, Inc. USB 2.0 IDE Adapter
    Bus 001 Device 004: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader
    Bus 001 Device 003: ID 174f:1403 Syntek Integrated Webcam
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


    but typing this only displayed my internal HDD UUID number on line 4:-
    'ls /dev/disk/by-uuid -lah'

    drwxr-xr-x 2 root root 80 2010-11-10 09:15 .
    drwxr-xr-x 5 root root 100 2010-11-10 09:15 ..
    lrwxrwxrwx 1 root root 10 2010-11-10 09:15 420CDBE80CDBD54F -> ../../sda1
    lrwxrwxrwx 1 root root 10 2010-11-10 09:15 4c593da0-46c2-4dff-b389-a443d87792e5 -> ../../sda2

    My USB CDROM/DVD device installed Ubuntu 10.10 just perfect, but then it disappeared some time without me noticing. Reinstallation does not help, the device still won't appear...It doesn't show up in fstab or mtab.
    This has only been an issue since I installed 10.10 netbook edition. I am currently using GNOME because it uses less CPU power and is more configurable.

    What Ubuntu 10.10 needs is a CDROM detection and installation software program...in a .deb file, so it can be downloaded, installed and opened like a normal program, and would be able to detect a CDROM or DVD attached, and create it within fstab and other files requiring the info...
    If Windows has been able to detect CDROM's since the 1990's I can't see why Ubuntu suddenly has problems..
    People shouldn't have to be subjected to a crash course in programming to add basic standard devices.

    thanks for reading my whinge.
    Last edited by SebMack; November 10th, 2010 at 12:48 PM.

  2. #2
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: USB CDROM/DVD Device Problems on Ubuntu 10.10

    From my lsusb:

    Code:
    Bus 001 Device 006: ID 05e3:0701 Genesys Logic, Inc. USB 2.0 IDE Adapter
    From my dmesg:

    Code:
    [ 1853.720028] usb 1-6: new high speed USB device using ehci_hcd and address 6
    [ 1853.872707] usb-storage 1-6:1.0: Quirks match for vid 05e3 pid 0701: 520
    [ 1853.872776] scsi12 : usb-storage 1-6:1.0
    [ 1854.872121] scsi 12:0:0:0: CD-ROM            HL-DT-ST DVD-RAM GH22NP20 1.04 PQ: 0 ANSI: 0
    [ 1855.121964] sr1: scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray
    [ 1855.122153] sr 12:0:0:0: Attached scsi CD-ROM sr1
    [ 1855.122297] sr 12:0:0:0: Attached scsi generic sg5 type 5
    When I plug in and switch on the USB DVD drive, a second 'CD/DVD Drive' icon appears in Places > Computer (this is a Desktop system with an internal DVD drive running the standard desktop Ubuntu 10.10). But when I put a readable DVD in, the drive whirrs for a bit and then the second icon disappears. It would appear that you have uncovered a bug which I have probably reproduced, except that my dmesg shows no error after disconnecting the device.

    So....

    Quote Originally Posted by SebMack View Post
    What Ubuntu 10.10 needs is a CDROM detection and installation software program...in a .deb file, so it can be downloaded, installed and opened like a normal program, and would be able to detect a CDROM or DVD attached, and create it within fstab and other files requiring the info...
    If Windows has been able to detect CDROM's since the 1990's I can't see why Ubuntu suddenly has problems..
    People shouldn't have to be subjected to a crash course in programming to add basic standard devices.

    thanks for reading my whinge.
    ... instead of "whingeing" and making assumptions about what Ubuntu might or might not "need", why not pop over to...

    https://bugs.launchpad.net/ubuntu/

    ... and file a bug report?

    After you.

    Edit: The fact that I couldn't find a relevant bug on Launchpad means that this could be an obscure bug affecting only some types of USB hardware. This is quite possible. When you consider the variables of the kernel driver, the ACPI implementation in the BIOS and the USB device's firmware, the possible permutations are endless. I'll give you an example. I have a USB SATA docking station. Works just fine with every machine and OS I have except with my Sony Vaio running an earlier version of Ubuntu (can't remember which offhand). It worked fine with the same Ubuntu version on other machines, just not with the Sony. But it worked fine with Vista on the Sony. Why? Haven't a clue and life is too short for me to worry about it.

    Out of interest, what is your USB CD/DVD enclosure? I assume it was a bare enclosure when you bought it because it has the same ID '05e3:0701' as mine which is a 'Hiyatek'. But googling '05e3:0701' brought up a variety of makes all with the same ID. For example.
    Last edited by coffeecat; November 10th, 2010 at 02:09 PM.

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

  3. #3
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: USB CDROM/DVD Device Problems on Ubuntu 10.10

    Quote Originally Posted by coffeecat View Post
    Edit: The fact that I couldn't find a relevant bug on Launchpad means that this could be an obscure bug affecting only some types of USB hardware.
    I think I may be right. I've managed to get hold of one of those USB powered external DVD drives that use a slimline drive to try out. It is recognised and automounted in Ubuntu 10.10 just fine. Presumably then this problem must be a bug affecting...

    Code:
    Bus 001 Device 006: ID 05e3:0701 Genesys Logic, Inc. USB 2.0 IDE Adapter
    ... because I've tried this device with another machine running 10.10 and I get the same issue.

    Is this is bug? Almost certainly. Is it irritating/frustrating? Undoubtedly. Will it get fixed? Not unless someone files a bug report. Will it get fixed then? Depends on how many people do a 'me too' on the bug report. Seeing as how this seems to be hardware-specific to a fairly uncommon piece of hardware I would guess this affects only a small minority of Ubuntu users.

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

  4. #4
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: USB CDROM/DVD Device Problems on Ubuntu 10.10

    I'm posting this workaround for anyone with a similar problem who's found this thread from a search. I doubt the OP is interested since they have not logged in since posting their one and only post.

    Have a look in /dev. If you have a machine without an internal optical drive, your usb CD/DVD drive will probably appear as sr0. If you have an internal CD/DVD drive, your usb one will probably be sr1. If it doesn't automount when you insert a CD or DVD, simply open a terminal and:

    Code:
    udisks --mount /dev/sr0
    ... or ...

    Code:
    udisks --mount /dev/sr1
    ... depending on whether you have an internal optical drive or not. Your disc will be mounted and a clickable icon will appear on the desktop with a 'disk' label.

    It is not elegant but at least someone in the OP's situation will be able to read CDs and DVDs.

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

  5. #5
    Join Date
    Nov 2010
    Beans
    4

    Re: USB CDROM/DVD Device Problems on Ubuntu 10.10

    I have the exact same problem but it is limited to Audio CDs (haven't checked Media DVDs). Software DVDs work fine.

    I tried the workaround on an audio CD, but this didn't work:
    ml@computer:~$ udisks --mount /dev/sr1
    Mount failed: Error mounting: mount: block device /dev/sr1 is write-protected, mounting read-only
    mount: you must specify the filesystem type[/code]So then I tried this, but didn't work as well:
    Code:
     
    ml@computer:~$ udisks  --mount /dev/sr1  --mount-fstype cdda
    Mount failed: Not a mountable file system
    I am not sure about the cdda option tho...

    What am I missing ?

    Many thanks!

    edited for clarity
    Last edited by mikolune; November 16th, 2010 at 04:25 AM.

  6. #6
    Join Date
    Nov 2010
    Beans
    4

    Re: USB CDROM/DVD Device Problems on Ubuntu 10.10

    OK - after browsing along some more - I got to understand that Audio CD's are not to be "mounted", but rather accessed directly through the software.

    Anyhow - the problem remains that Ubuntu - or is it a problem with Gnome ? - cannot see the Audio CD's from the USB/IDE adaptor using the 05e3:0701 Genesys Logic, Inc. chip set.
    Last edited by mikolune; November 16th, 2010 at 06:17 AM. Reason: typo

  7. #7
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: USB CDROM/DVD Device Problems on Ubuntu 10.10

    Quote Originally Posted by mikolune View Post
    OK - after browsing along some more - I got to understand that Audio CD's are not to be "mounted", but rather accessed directly through the software.
    Tbh, I didn't check with an audio disc, so thanks for that. I'll try with a video DVD as well to see what happens.

    Quote Originally Posted by mikolune View Post
    Software DVDs work fine.
    Very interesting, since both the OP and myself are having this issue with data DVDs.

    Quote Originally Posted by mikolune View Post
    Anyhow - the problem remains that Ubuntu - or is it a problem with Gnome ? - cannot see the Audio CD's from the USB/IDE adaptor using the 05e3:0701 Genesys Logic, Inc. chip set.
    Good point. Or it could be related to the kernel driver. What I haven't done is to check this in Fedora 14 which, iirc, has the same version of gnome. It certainly runs Fedora's version of the 2.6.35 kernel, the same as Maverick. I'll post back when I've done some investigation. Thanks for posting. We can assume that there are at least three people in the world with this Genesys 05e3:0701 device who are running Ubuntu.

    By the way, what make of CD/DVD drive do you have in your enclosure? I'm using an LG which works fine in Maverick as an internal drive, but it's just conceivable that some obscure interaction between the firmware of the Genesys enclosure and the LG drive could be at the root of all this.

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

  8. #8
    Join Date
    Nov 2010
    Beans
    4

    Re: USB CDROM/DVD Device Problems on Ubuntu 10.10

    Thanks for your response!

    Quote Originally Posted by coffeecat View Post
    By the way, what make of CD/DVD drive do you have in your enclosure?
    Mine is a PHILIPS DVD+_RW SDV8820. It is now plugged into a USB adaptor called Owltech OWL-ESODIDE(B) ....

    In fact, the PHILIPS was the internal drive of an Ubuntu 10.04 box that just died on me. I bought a new machine (Acer Revo 3700 - 64 bit) that doesn't have an internal drive, so I recycled the old internal drive . I used the USB adapter to connect the old DVD drive to the new box, which is running 10.10.

    Note that the 05e3:0701 chip set is in the USB adapter, and not in the DVD drive.

    Thanks for the efforts!

  9. #9
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: USB CDROM/DVD Device Problems on Ubuntu 10.10

    Quote Originally Posted by mikolune View Post
    Note that the 05e3:0701 chip set is in the USB adapter, and not in the DVD drive.
    Agreed. The reason I thought it was worth seeing if a different make of CD/DVD drive would make a difference is that sometimes something weird can happen with certain combinations of enclosure and drive firmware. For example, I have a generic hard drive USB enclosure which behaves just perfectly with a Hitachi drive when plugged into my Mac Mini running OSX. But if I put a particular model of WD drive in it, the drive mounts OK (in MacOS) but spontaneously dismounts itself after a variable length of time. I discovered this when doing Carbon Copy Cloner backups of the system, which take several hours. Frustrating, to say the least.

    Anyway, I have done some investigation and I have some interesting results, all done on the same multibooting machine to reduce the number of variables.

    In Maverick, whether I put in a data DVD, Video DVD, Audio CD or blank recordable disc, the CD/DVD icon disappears from 'Computer'. I can mount a data DVD as before with the udisks command and, like you, I can use software to access an audio CD or video DVD. Except that VLC was the only media app (that I tried) that I could do this with, by going to Media > Open Disc and putting '/dev/sr1' in the Disc device field.

    However, all these discs would open/play in Maverick using the internal DVD drive or the USB-powered DVD drive I mentioned earlier.

    In Karmic, everything works as expected with this 05e3:0701 device, with prompts for appropriate apps when the disc is put in, and a suitable icon appearing on the desktop.

    Most interestingly, in Fedora 14, which uses the same version of gnome and kernel as Maverick, everything works just as well as in Karmic. I.e. everything works.

    Lucid is the weirdest. A data DVD is automounted just fine. Ditto a video DVD and I can play it easily. But it does the same as Maverick with an audio CD and a blank CDR, CDRW or DVD+R. Which is different from the OP who said:

    10.04 lts with no cdrom issues.
    Lastly, there's Natty. Everything worked with this device. Which is nice. But, of course, since it is still pre-alpha at the moment, there's plenty of time for things to get broken.

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

  10. #10
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: USB CDROM/DVD Device Problems on Ubuntu 10.10

    Quote Originally Posted by coffeecat View Post
    The fact that I couldn't find a relevant bug on Launchpad
    Wrong! My search-fu was playing up. Here it is:

    https://bugs.launchpad.net/ubuntu/+s...ev/+bug/646293

    @mikolune, do you want to add a comment to the Launchpad thread or at least do a 'me too'?

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •