Results 1 to 8 of 8

Thread: "automatically unlock this keyring whenever i'm logged in" doesn't work

  1. #1
    Join Date
    Oct 2008
    Beans
    17

    "automatically unlock this keyring whenever i'm logged in" doesn't work

    Hi All,

    I want to share a solution to a problem I had with my new install of ubuntu 10.10

    The problem was every time I logged into ubuntu, a dialog box would pop up asking me to enter my password for the default keyring, so that the network manager applet could connect to my encrypted wireless network. Despite checking the box "automatically unlock this keyring whenever i'm logged in", every time i did log in it would still ask me for the password! A quick google came up with no real solutions except for setting the password for the 'Default' keyring to blank.

    My solution was:
    uninstall network manager applet from Ubuntu Software Centre
    immediately reinstall network manager applet
    (^^^^^ not sure if these steps are really needed ^^^^^^)

    Open System -> Preferences -> Passwords and Encryption Keys
    In the Passwords tab, delete the 'passwords: Default' keyring
    Right-click the 'passwords: login' key and select 'Set as default'

    This fixed the problem for me. I think the cause was the login keyring was not set to be the default keyring. So even though logging in unlocked this keyring, the wifi keys were stored in another keyring that was the default, meaning I had to type the password again.

    Hope this helps someone!
    Ross

  2. #2
    Join Date
    Nov 2008
    Beans
    21

    Re: "automatically unlock this keyring whenever i'm logged in" doesn't work

    Hi geometrikal,

    I had a similar problem (pop-up to unlock default keyring), and I solved it with your trick. Thanks a lot.

  3. #3
    Join Date
    Jan 2011
    Beans
    24

    Re: "automatically unlock this keyring whenever i'm logged in" doesn't work

    Quote Originally Posted by jpfle View Post
    Hi geometrikal,

    I had a similar problem (pop-up to unlock default keyring), and I solved it with your trick. Thanks a lot.
    Hi, my system is 10.04. why can I not find what he said.
    In password tab of my dialog for the password and encryption there is just
    one option asking me to input password.

  4. #4
    Join Date
    Nov 2008
    Beans
    21

    Re: "automatically unlock this keyring whenever i'm logged in" doesn't work

    Quote Originally Posted by wxuyec View Post
    Hi, my system is 10.04. why can I not find what he said.
    In password tab of my dialog for the password and encryption there is just
    one option asking me to input password.
    Hi,

    In seahorse, I clicked right on my keyring "login" and chosen "default", and I removed my other keyring that was named "default".

    However, I don't remember when, (before or after changing default keyring, or before or after removing old default), but I also clicked right on my login keyring, chosen "Lock", and after chosen "Unlock". In the dialog appearing, there was option about unlocking it when I log in.

  5. #5
    Join Date
    May 2011
    Beans
    11

    Re: "automatically unlock this keyring whenever i'm logged in" doesn't work

    Thanks geometrikal !
    Much appreciated

  6. #6
    Join Date
    May 2009
    Beans
    133
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: "automatically unlock this keyring whenever i'm logged in" doesn't work

    I'm having the same problem, but when I go to system>preferences>passwords and encryption keys I get the message 'could not launch. So I can't even get past square one. I'd appreciate help.

  7. #7
    Join Date
    May 2009
    Beans
    Hidden!

    Re: "automatically unlock this keyring whenever i'm logged in" doesn't work

    I can confirm that this fix works, and that the uninstall/reinstall process of network-manager-gnome is indeed needed for it to work!

    Thanks and regards from 2011 ^^

  8. #8
    Join Date
    May 2009
    Beans
    133
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: "automatically unlock this keyring whenever i'm logged in" doesn't work

    I am glad the fix works for some, but I wish someone could help me with the problem I posted some time ago. When I go to password and encryption keys, I am told that it cannot be opened.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •