Results 1 to 5 of 5

Thread: Configure ufw to drop icmp echo requests?

  1. #1
    Join Date
    Jun 2010
    Location
    Winston Salem, NC
    Beans
    55
    Distro
    Ubuntu 10.04 Lucid Lynx

    Configure ufw to drop icmp echo requests?

    I've been trying to configure ufw to drop ping requests for a couple days now, and I can't figure it out. I've tried a couple different methods in some different guides, still nothing. Anyone know how to do this?

  2. #2
    Join Date
    Oct 2006
    Beans
    4,619
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Configure ufw to drop icmp echo requests?

    In /etc/ufw/before.rules change
    Code:
    -A ufw-before-input -p icmp --icmp-type echo-request -j ACCEPT
    to
    Code:
    -A ufw-before-input -p icmp --icmp-type echo-request -j DROP
    Then restart UFW.

    Code:
    sudo restart ufw
    Blog | Ubuntu User #15350 | Zsh FTW | Ubuntu Security | Nothing to hide?
    AMD Phenom II X6 1075T @ 3GHz, Nvidia GTX 650, 8GB DDR3 RAM, 2 X 1TB, 1 X 3TB HDD
    Please don't request support via PM


  3. #3
    Join Date
    Jun 2010
    Location
    Winston Salem, NC
    Beans
    55
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Configure ufw to drop icmp echo requests?

    Quote Originally Posted by FuturePilot View Post
    In /etc/ufw/before.rules change
    Code:
    -A ufw-before-input -p icmp --icmp-type echo-request -j ACCEPT
    to
    Code:
    -A ufw-before-input -p icmp --icmp-type echo-request -j DROP
    Then restart UFW.

    Code:
    sudo restart ufw
    I did this. The computer is still accepting ping requests.

  4. #4
    Join Date
    Apr 2006
    Location
    Montana
    Beans
    Hidden!
    Distro
    Kubuntu Development Release

    Re: Configure ufw to drop icmp echo requests?

    Quote Originally Posted by Seanlol View Post
    I did this. The computer is still accepting ping requests.
    Accepts ping requests from where ? localhost ? you LAN ?

    Do you have any additional rules that accept connections earlier in your rule set ?

    Post
    Code:
    sudo ufw status verbose
    sudo iptables -L -v -n
    There are two mistakes one can make along the road to truth...not going all the way, and not starting.
    --Prince Gautama Siddharta

    #ubuntuforums web interface

  5. #5
    Join Date
    Apr 2008
    Beans
    27

    Re: Configure ufw to drop icmp echo requests?

    Note that after modifying /etc/ufw/before.rules you have to do:
    ufw disable
    ufw enable

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •