Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: Increasing Screen Resolution

  1. #11
    Join Date
    Aug 2005
    Location
    Philadelphia, PA, USA
    Beans
    2,774
    Distro
    Lubuntu 12.10 Quantal Quetzal

    Re: Increasing Screen Resolution

    So what exactly did you try before concluding that xrandr did not work? Did you try anything at all?
    What happens if you run:
    Code:
    xrandr --newmode 1280x1024
    or
    Code:
    xrandr --addmode 1280x1024
    You may need to add
    Then run:
    Code:
    xrandr --output LVDS --mode 1280x1024
    Please read the tutorial on xrandr that I linked to, and try to use xrandr as per those examples in the tutorial.
    when you reply, try to provide as much info as possible instead of just "It didn't solve the problem". I have never hard to use xrandr myself, so I am not sure what the expected outputs would be from using it.
    Registered Linux User #422464 http://linuxcounter.net/
    Use the search engine that respects your privacy rights: https://startpage.com/

  2. #12
    Join Date
    May 2009
    Location
    London
    Beans
    245
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Increasing Screen Resolution

    I did try and enter "1280x1024", which is within the 'max' level, but it says 'not available.

  3. #13
    Join Date
    Aug 2005
    Location
    Philadelphia, PA, USA
    Beans
    2,774
    Distro
    Lubuntu 12.10 Quantal Quetzal

    Re: Increasing Screen Resolution

    Quote Originally Posted by chome4 View Post
    I did try and enter "1280x1024", which is within the 'max' level, but it says 'not available.
    As per the tutorial I linked to, first use gtf or cvt to create a modeline for 1280x1024 like this:
    Code:
    tom[data]$ cvt 1280 1024 60
    # 1280x1024 59.89 Hz (CVT 1.31M4) hsync: 63.67 kHz; pclk: 109.00 MHz
    Modeline "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
    Then try to add the mode with xrandr like this:
    Code:
    xrandr --newmode "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
    Note: Use the output that you get from cvt , not what I have posted here. Do not include the line that starts with the #.
    Then use the --addmode option to try to add the mode as discussed in the xrandr tutorial.
    Post the output of those commands here if you can.
    If this does not work then I am pretty much out of ideas here.
    Last edited by tommcd; November 22nd, 2010 at 08:34 PM.
    Registered Linux User #422464 http://linuxcounter.net/
    Use the search engine that respects your privacy rights: https://startpage.com/

  4. #14
    Join Date
    May 2009
    Location
    London
    Beans
    245
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Increasing Screen Resolution

    When I type 'xrandr' I get:

    Screen 0: minimum 320 x 200, current 1280 x 800, maximum 4096 x 4096
    VGA1 disconnected (normal left inverted right x axis y axis)
    LVDS1 connected 1280x800+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
    1280x800 60.0*+
    1024x768 60.0
    800x600 60.3 56.2
    640x480 59.9
    TV1 disconnected (normal left inverted right x axis y axis)
    1280x1024_60.00 (0x100) 109.0MHz
    h: width 1280 start 1368 end 1496 total 1712 skew 0 clock 63.7KHz
    v: height 1024 start 1027 end 1034 total 1063 clock 59.9Hz
    ================================================== =============================

    cvt 1280 1024 60 for me, gives:

    # 1280x1024 59.89 Hz (CVT 1.31M4) hsync: 63.67 kHz; pclk: 109.00 MHz
    Modeline "1280x1024_60.00" 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync
    ================================================== =============================
    I type:
    xrandr --newmode "1280x1024_60.00" 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync

    And get:

    xrandr --newmode "1280x1024_60.00" 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync
    X Error of failed request: BadName (named color or font does not exist)
    Major opcode of failed request: 150 (RANDR)
    Minor opcode of failed request: 16 (RRCreateMode)
    Serial number of failed request: 27

    Current serial number in output stream: 27

    What am I doing wrong?
    Last edited by chome4; November 29th, 2010 at 07:14 PM.

  5. #15
    Join Date
    Aug 2005
    Location
    Philadelphia, PA, USA
    Beans
    2,774
    Distro
    Lubuntu 12.10 Quantal Quetzal

    Re: Increasing Screen Resolution

    Quote Originally Posted by chome4 View Post
    What am I doing wrong?
    Well, I am not sure. I have never had to use xrandr myself. I have only read about it.
    What happens if you run:
    Code:
    xrandr --addmode 1280x1024
    or:
    Code:
    xrandr --newmode 1280x1024
    or:
    Code:
    xrandr --output LVDS1 --mode 1280x1024
    You will have to try different options with xrandr as per the tutorial I linked to earlier.

    What video card do you have?

    You could also try backing up your xorg.conf. Then add the horizontal sync and vertical refresh rates for your monitor, as well as the modeline generated by cvt or gtf to the Monitor section of your xorg.conf. Try something like this:
    Code:
    Section "Monitor"
    Identifier "Configured Monitor"
    VendorName     "Unknown"
        ModelName      "Unknown"
        HorizSync       28.0 - 33.0
        VertRefresh     43.0 - 72.0
        Option         "DPMS"
    # 1280x1024 59.89 Hz (CVT 1.31M4) hsync: 63.67 kHz; pclk: 109.00 MHz
    Modeline "1280x1024_60.00" 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync
    EndSection
    But replace those refresh rates with the refresh rates for your monitor. And use your output from cvt or gtf to generate the modeline.
    Registered Linux User #422464 http://linuxcounter.net/
    Use the search engine that respects your privacy rights: https://startpage.com/

  6. #16
    Join Date
    May 2009
    Location
    London
    Beans
    245
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Increasing Screen Resolution

    My problem is with adding a modeline.

    xrandr --newmode <Mode``Line> gives:

    bash: syntax error near unexpected token `newline'

    Another instruction says input: xrandr -newmode <Modeline> and I get:
    bash: syntax error near unexpected token `newline'

    According to the specs, the video is: Intel 943GML (up to 128MB shared)

    Advent Laptop T2080 8115
    Last edited by chome4; December 1st, 2010 at 10:50 PM.

  7. #17
    Join Date
    Aug 2005
    Location
    Philadelphia, PA, USA
    Beans
    2,774
    Distro
    Lubuntu 12.10 Quantal Quetzal

    Re: Increasing Screen Resolution

    Are you still using Jaunty 9.04? Ubuntu 9.04 reached end of life in October:
    https://help.ubuntu.com/community/CommonQuestions
    If so, then perhaps the best thing would be to do a clean install of Ubuntu 10.10. I don't know what else to suggest at this point.
    Registered Linux User #422464 http://linuxcounter.net/
    Use the search engine that respects your privacy rights: https://startpage.com/

  8. #18
    Join Date
    Jun 2007
    Beans
    10,984

    Re: Increasing Screen Resolution

    Can you pastebin your /var/log/Xorg.0.log ? Thanks.

  9. #19
    Join Date
    May 2009
    Location
    London
    Beans
    245
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Increasing Screen Resolution

    sudo gedit /etc/X11/xorg.conf I get an empty file!

    This is a new install of 10.10

  10. #20
    Join Date
    Jun 2007
    Beans
    10,984

    Re: Increasing Screen Resolution

    You should have no xorg.conf. Post /var/log/Xorg.0.log if you;re still having issues.

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •