Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: RR1740 driver module compilation error

  1. #1
    Join Date
    Nov 2010
    Beans
    102

    Red face RR1740 driver module compilation error

    running the latest ubuntu 10.10 desktop i386
    i followed this guide for reference when building the updated drivers
    https://help.ubuntu.com/community/RocketRaid

    all paths and references have been updated to reflect my version of the driver

    original error during compilation:

    DKMS make.log for rr174x-2.4 for kernel 2.6.35-22-generic (i686)
    Wed Nov 3 01:28:03 EDT 2010
    make: Entering directory `/usr/src/linux-headers-2.6.35-22-generic'
    scripts/Makefile.build:49: *** CFLAGS was changed in "/var/lib/dkms/rr174x/2.4/build/Makefile". Fix it to use EXTRA_CFLAGS. Stop.
    make: *** [_module_/var/lib/dkms/rr174x/2.4/build] Error 2
    make: Leaving directory `/usr/src/linux-headers-2.6.35-22-generic'



    to "force" it to work i used this work around:

    sudo KBUILD_NOPEDANTIC=1 make install

    [sudo] password for USER:
    make[1]: Entering directory `/usr/src/linux-headers-2.6.35-22-generic'
    CC [M] /usr/src/rr174x-2.4/.build/os_linux.o
    CC [M] /usr/src/rr174x-2.4/.build/osm_linux.o
    CC [M] /usr/src/rr174x-2.4/.build/div64.o
    CC [M] /usr/src/rr174x-2.4/.build/hptinfo.o
    CC [M] /usr/src/rr174x-2.4/.build/config.o
    LD [M] /usr/src/rr174x-2.4/.build/rr174x.o
    Building modules, stage 2.
    MODPOST 1 modules
    WARNING: could not find /usr/src/rr174x-2.4/.build/.him_rr1740pm.o.cmd for /usr/src/rr174x-2.4/.build/him_rr1740pm.o
    LD [M] /usr/src/rr174x-2.4/.build/rr174x.ko
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.35-22-generic'
    You made a module which is for current kernel 2.6.35-22-generic.
    Deleting previous installed driver module rr174x...
    Install the new driver module...
    Removing conflicted driver module...
    Updating module dependencies...Done.
    Checking for initrd images to be updated...
    backup /boot/initrd.img-2.6.35-22-generic to /boot/initrd.img-2.6.35-22-generic.rr174x.




    here it is mounted as NTFS with the original RAID volume from Win2K3
    it is working great, speedy and stable, but that compilation error message makes me worry.


    So, I'm here trying to figure out "How to add the EXTRA_CFLAGS or fix the WARNING?"

    and see if i can compile a proper driver module without throwing me a Warning, or having to force the Make to compile / install the module.

    I know my way around Linux/BSD/Solaris fairly decently, but i'm no way near good enough to be considerate your average user; I know Windows and Mac inside out which doesn't help me much when i'm on this field.
    Attached Images Attached Images
    Last edited by AllGamer; November 10th, 2010 at 02:28 PM. Reason: title update

  2. #2
    Join Date
    Nov 2010
    Beans
    102

    Re: RR1740 driver module compilation error

    if this is in the wrong forum could a Mod please move it to the proper sub forum?

    thank you

  3. #3
    Join Date
    Nov 2010
    Beans
    102

    Re: RR1740 driver module compilation error

    ^ bump ^

    10 char

  4. #4
    Join Date
    Nov 2010
    Beans
    0

    Re: RR1740 driver module compilation error

    Quote Originally Posted by AllGamer View Post
    if this is in the wrong forum could a Mod please move it to the proper sub forum?

    thank you
    might be the wrong place.

  5. #5
    Join Date
    Nov 2010
    Beans
    3

    Re: RR1740 driver module compilation error

    Seems this would be the right place to ask this question, but it might get more air time in the "general" area.

    I'm in the exact same boat as you. I installed a RR1742 on Sunday only to find out that no pre-compiled drivers exists for UBUNTU 10.10. I got the exact error as you did when attemting to build the driver using DKMS. Searched all the libraries that I could think of to no avail. Followed the Highpoint Tech instructions to use "make install" and got the same warning as you. The driver seems to load and if I connect an external drive to it AFTER the server is running, I can access the drive. If I have the drive connected on boot-up, it stalls.

    I emailed Highpoint Tech support on the error from the DKMS make.log and am awaiting a reply. Will post update on here if/when the reply.

  6. #6
    Join Date
    Nov 2010
    Beans
    102

    Re: RR1740 driver module compilation error

    Can a moderator please move this topic to the proper area?

    Thanks

  7. #7
    Join Date
    Jan 2006
    Location
    Not heaven... Iowa
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: RR1740 driver module compilation error

    Quote Originally Posted by AllGamer View Post
    Can a moderator please move this topic to the proper area?

    Thanks
    Just this once
    Moved to General Help.
    The "ReportaAbuse" button might get quicker response...
    Last edited by Iowan; November 11th, 2010 at 01:10 AM.
    Linux User #415691 Ubuntu User #8629
    Iowa Team (LoCo): [Wiki] [Launchpad]
    IRC channel: #ubuntu-us-ia on irc.freenode.net

  8. #8
    Join Date
    Nov 2010
    Beans
    3

    Re: RR1740 driver module compilation error

    Just got a reply back from Highpoint Technologies:

    "Hello,

    We will discuss this with engineering.
    The current release has not been tested with this kernel.

    Regards,

    Customer Support Department"

    The driver seems to be running fine even with the build warning. I was able to fix the problem with the system stalling during boot up with the drive connected by flashing the bios. Will update here when I get a reply from the vendor

  9. #9
    Join Date
    Nov 2010
    Beans
    102

    Re: RR1740 driver module compilation error

    I'm hesitant to upgrade my full time file server to 10.10 without a perfect driver.

    i didn't get that error on previous versions

    on my full time server i have another Rocket Raid 1740 + and 2 extra Rocket Raid 2460x1 for a triple layer redundancy

    1 Rocket Raid 1740 gets mirrored by another Rocket Raid 1740
    same setup for the RAIDs running on the 2460x1
    Last edited by AllGamer; November 19th, 2010 at 07:46 AM.

  10. #10
    Join Date
    Dec 2010
    Beans
    1

    Re: RR1740 driver module compilation error

    Thanks @AllGamer!

    Just incase anyones as bad at this as me, you're looking for the Open Source driver at the bottom of http://www.highpoint-tech.com/USA_new/series_rr1700.htm

    Download, unarchive in finder/my computer, and then delve into the products folder (there was only one option in each tree for me when I downloaded this which brought me to ~/rr174x-linux-src-v2.4/product/rr1740pm/linux ).

    And run
    Code:
    sudo KBUILD_NOPEDANTIC=1 make install
    A quick reboot, and it was showing up correctly. I'm copying over from my non-raid drive to this drive as we speak and it seems to be going well. Hopefully I have no problems getting Netatalk to work with this and my Macs.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •