Results 1 to 7 of 7

Thread: mencoder Japanese subs

  1. #1
    Join Date
    Oct 2007
    Location
    Japan
    Beans
    637
    Distro
    Ubuntu 12.04 Precise Pangolin

    mencoder Japanese subs

    I am trying to convert a MKV file to xvid and hard coding the Japanese subtitles. But when I do the subtitles don't display properly.

    When I use these setting in mplayer it works fine. I have attached the mplayer screenshot.
    Code:
    mencoder gp.mkv -sub gp.srt -subcp SHIFT-JIS 
    -font "Arial Black" -unicode -ovc xvid -oac mp3lame -xvidencopts pass=1 -o gp.avi
    When running the above command I get multiple
    "SUB: error recoding line."
    when converting.

    How can I get this to work
    Attached Images Attached Images
    "Don't Panic"

  2. #2
    Join Date
    Oct 2007
    Location
    Japan
    Beans
    637
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: mencoder Japanese subs

    I'll know in about an hour but I think I may have figured it out. I guess I needed to specify -utf8 and -slang ja

    Code:
    mencoder gp.mkv -ovc xvid -oac mp3lame -xvidencopts pass=1 -o -sub gp.srt -subfont-text-scale 4 -utf8 -slang ja -o OUTPUT.avi
    http://d.hatena.ne.jp/ykmbpp/20100907/1283866535
    http://yuji.noizumi.org/blog/2010/08...3%80%91ardour/
    "Don't Panic"

  3. #3
    Join Date
    Oct 2007
    Location
    Japan
    Beans
    637
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: mencoder Japanese subs

    that didn't work either I am now trying:

    mencoder gp.mkv -sub gp.srt -font "~/.mplayer/subfont.ttf" -utf8 -ovc xvid -oac mp3lame -xvidencopts pass=1 -o gp.avi
    "Don't Panic"

  4. #4
    Join Date
    Oct 2007
    Location
    Japan
    Beans
    637
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: mencoder Japanese subs

    with the -utf8 option I just get a "_________" where the subtitles should be. When I remove the -utf8 option I get garbled subtitles.

    Now I have downloaded a Japanese unicode font from
    http://cooltext.com/Fonts-Unicode+Japanese
    and am trying
    mencoder gp.mkv -sub gp.srt -font "~/.mplayer/epmgobld.ttf" -unicode -ovc xvid -oac mp3lame -xvidencopts pass=1 -o gp2.avi
    "Don't Panic"

  5. #5
    Join Date
    Oct 2007
    Location
    Japan
    Beans
    637
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: mencoder Japanese subs

    This is my latest try

    mencoder gp.mkv -sub gp.srt -font "~/.mplayer/ariblk.ttf" -utf8 -slang ja -subfont-text-scale 4 -ovc xvid -oac mp3lame -xvidencopts pass=1 -o gp2.avi

    I have copied the Arial Black font into ~/.mplayer
    I have uploaded my SRT file but I had to compress it to attach it.

    I have also uploaded a screenshot of what I got this try. It is just giving me a straight line where the subtitle should be.
    Attached Images Attached Images
    Attached Files Attached Files
    "Don't Panic"

  6. #6
    Join Date
    Oct 2007
    Location
    Japan
    Beans
    637
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: mencoder Japanese subs

    This seamed to work after I installed the "MS Gothic" font

    mencoder gp.mkv -sub gp.srt -subcp utf8 -subfont "MS Gothic" -subfont-text-scale 3 -subfont-outline 1 -ovc xvid -oac mp3lame -xvidencopts pass=1 -o out.avi
    "Don't Panic"

  7. #7
    Join Date
    Dec 2010
    Beans
    1

    Re: mencoder Japanese subs

    same as me. i am use chinese.
    http://www.mplayerhq.hu/DOCS/HTML/en/fonts-osd.html

    If MPlayer was compiled with fontconfig support,can not set font path on argument,only to set the font name.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •