Results 1 to 10 of 145

Thread: Rosewill RNX-N150PC PCI Ralink 3060 chip driver instructions

Threaded View

  1. #1
    Join Date
    Jul 2009
    Location
    Dayton Ohio USA
    Beans
    1,070
    Distro
    Ubuntu 13.04 Raring Ringtail

    Rosewill RNX-N150PC PCI Ralink 3060 chip driver instructions

    This is the procedure I used to install the driver for my new Rosewill Rosewill RNX-N150PC PCI 2.2 Wireless Adapter. It uses the Ralink 3060 chip. I'm using Lucid 10.04 and WICD as my network manager.(I have tested this driver and method on both 10.10 & currently 11.04 with success) I downloaded the drivers from Ralinks site
    http://www.ralinktech.com/license_us...V3TVRJeE53PT1D

    Make sure you have installed gcc build-essential
    Code:
    sudo apt-get install gcc build-essential
    I then followed the instuctions in the README file.
    Navigate to downloaded_driver_folder/os/linux and open config.mk in a text editor.
    Find and set so that it indicates ( y ) at the end of this text string
    Code:
    HAS_WPA_SUPPLICANT=y
    and also set
    Code:
    HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y
    Next, open a terminal in the driver folder and type
    Code:
    sudo make
    then
    Code:
    sudo make install

    Now you'll need to load the driver
    Code:
    sudo modprobe rt3562sta
    Code:
    sudo ifconfig ra0 inet up

    After I successfully connected I added the driver to /etc/modules so it it would load at startup. This is a copy of mine

    Code:
     # /etc/modules: kernel modules to load at boot time.
    #
    # This file contains the names of kernel modules that should be loaded
    # at boot time, one per line. Lines beginning with "#" are ignored.
    
    loop
    lp
    rt3562sta.ko
    Edit complete save file and reboot to test. I hope this helps anyone using Raklink 3060/3062/3562 chipset. Mine connects with a strong consistent signal.

    Looks as if an addition is necessary to complete the driver install. The need to blacklist a default driver to enable the new driver.
    From terminal
    Code:
    gksu gedit /etc/modprobe.d/blacklist.conf
    Add this to the end of that file
    Code:
    blacklist rt2800pci
    Last edited by MooPi; June 26th, 2011 at 04:35 PM.
    It's okay, I'm a limo driver

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •