Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24

Thread: How to set Gnome automount permissions?

  1. #11
    Join Date
    Mar 2007
    Location
    Helsinki, Finland, Earth
    Beans
    232
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: How to set Gnome automount permissions?

    Oh,
    I would like to run DF from my Linux partition, however, I couldn't find a driver for Windows 7 that would allow me to open ext4 partitions in Windows. The only one that works is called ext4explorer, and it only allows copying files and directories from the partition, not viewing it transparently. Therefore I would not be able to play DF in Windows from the Linux partition.
    Vermind

  2. #12
    Join Date
    Apr 2010
    Location
    England
    Beans
    3,286

    Re: How to set Gnome automount permissions?

    Ah. I suppose if you're often switching from Linux to Windows it'd be best to keep it on an NTFS partition anyway, I wouldn't trust Windows to access my Linux partitions in the first place. fsck could probably detect and fix any problems that might arise, but I'd rather not risk it.

    Anyway, it's nice to see a fellow Dwarfer on the forums. :D
    http://xkcd.com/293/
    There are 10 kinds of people in this world: Those who understand ternary, those who don't, and those who confuse it with binary.

  3. #13
    Join Date
    Nov 2008
    Location
    Old Europe
    Beans
    78
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: How to set Gnome automount permissions?

    Thank you SOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOO much to mc4man and Vermind for showing how to solve this problem.

  4. #14
    Join Date
    Jul 2005
    Beans
    36

    Re: How to set Gnome automount permissions?

    I mean yes it is quite simple to compile it yourself but it can't be that I am requried to re-compile udisks to get such a simple change.
    Especially, this could be problematic regarding possible future updates of udisks...

    Isn't there a way to do this over some configuration files (e.g. polkit-1 or ".rules" or whatever).

    But still thanks for the tutorial to compile it myself.
    Last edited by ghost_zero; December 2nd, 2010 at 01:47 AM.

  5. #15
    Join Date
    Mar 2006
    Beans
    77
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: How to set Gnome automount permissions?

    I like that there is a solution to this (I am having a similar problem), but hard coding something like this is totally absurd. Did nobody think that maybe this would need to be changed for some people?
    http://www.anessen.com
    "If you focus your mind on the freedom and community that you can build by staying firm, you will find the strength to do it."
    -Richard M Stallman

  6. #16
    Join Date
    Mar 2007
    Location
    Helsinki, Finland, Earth
    Beans
    232
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: How to set Gnome automount permissions?

    Quote Originally Posted by Anessen View Post
    I like that there is a solution to this (I am having a similar problem), but hard coding something like this is totally absurd. Did nobody think that maybe this would need to be changed for some people?
    My sentiments exactly.
    Vermind

  7. #17
    Join Date
    Oct 2009
    Beans
    8

    Re: How to set Gnome automount permissions?

    Hi everyone and excuse me in advance for my bad English.
    I need to resurrect this old thread because I have this problem:

    I need to automount through udisks a hfsplus formatted partition using non standard options and non standard driver.

    The file system driver is named ufsd and I need to mount the partition in this way:

    Code:
    udisks --mount /dev/sdXn --mount-fstype ufsd --mount-options uid=1000,gid=1000;nodev,nosuid,rw
    The answer is that uid and gid options are not allowed.

    I watched the /src/device.c file as you described in this thread, but it doesn't mention any rule for hfsplus mounting.

    Do you know how should I modify this file? ...or any other file?

    Thanks in advance
    Last edited by bingel; March 6th, 2011 at 12:23 PM.

  8. #18
    Join Date
    Apr 2010
    Location
    England
    Beans
    3,286

    Re: How to set Gnome automount permissions?

    http://www.mjmwired.net/kernel/Docum...ms/hfsplus.txt

    Those are the hfsplus options, and it should support uid/gid/umask options. As for ufsd, I'm not sure. There's ufs options here: http://www.mjmwired.net/kernel/Docum...ystems/ufs.txt I don't know if it's related or not, but it doesn't seem to offer any options either.

    You may be out of luck.
    http://xkcd.com/293/
    There are 10 kinds of people in this world: Those who understand ternary, those who don't, and those who confuse it with binary.

  9. #19
    Join Date
    Oct 2009
    Beans
    8

    Re: How to set Gnome automount permissions?

    Thanks, however UFS and UFSD are not the same thing.

    UFSD is a proprietary driver that is able to read and write HFS+ formatted partitions that have journaling enabled.

    As for HFS+, instead, my problem is figuring out how to make udisks able to mount this file-system using options that are disabled by default (and therefore not allowed) and that must be enabled (I assume) by changing and rebuilding udisks source code (in a similar way as described in this thread for NTFS file system).

    Moreover I have to clarify that I'm using Ubuntu 10.04 and my kernel version is 2.6.32-28-generic

  10. #20
    Join Date
    Mar 2007
    Location
    Helsinki, Finland, Earth
    Beans
    232
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: How to set Gnome automount permissions?

    In the Ubuntu 10.10 sources for udisks, I have this from line 5900 on:
    Code:
    static const char *any_allow[] = { "exec", "noexec", "nodev", "nosuid", "atime", "noatime", "nodiratime", "ro", "rw", "sync", "dirsync", NULL };
    
    static const FSMountOptions fs_mount_options[] =
      {
        { "vfat", vfat_defaults, vfat_allow, vfat_allow_uid_self, vfat_allow_gid_self },
        { "ntfs", ntfs_defaults, ntfs_allow, ntfs_allow_uid_self, ntfs_allow_gid_self },
        { "iso9660", iso9660_defaults, iso9660_allow, iso9660_allow_uid_self, iso9660_allow_gid_self },
        { "udf", udf_defaults, udf_allow, udf_allow_uid_self, udf_allow_gid_self },
      };
    Perhaps changing any_allow to include the options you need or adding something like { "ufs", option, option, option ... }, below would help?
    Vermind

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •