Page 3 of 7 FirstFirst 12345 ... LastLast
Results 21 to 30 of 67

Thread: Mic not working in skype, ekiga on Ubuntu 10.10

  1. #21
    Join Date
    Oct 2010
    Location
    Kolkata, India
    Beans
    1
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mic not working in skype, ekiga on Ubuntu 10.10

    Quote Originally Posted by smithintaiwan View Post
    Thanks Garvinrick,
    But for some reason I couldn't get the connector to change on mine. That field just didn't exist.
    However, I just found a page that helped me get my mic going. The directions are:
    In terminal:

    sudo apt-get install pavucontrol

    pavucontrol


    Then:

    * Click the "input devices" tab. Click the lock icon to unlock channels. Set the front right channel to silence.

    Once in pavucontrol I just silenced the right channel mic and it worked immediately. I tested in Skype and all seems fine. This seems to be the same as Steve's answer above. Cheers Steve.

    Skype does seem a bit choppy in both directions though -at least it is not as clear as it is in Windows- but I think that's a different issue.
    Hope this helps.

    Thank you very much. The above settings sorted out the issue of microphone on ASUS 1005 px.

    -Dinesh

  2. #22
    Join Date
    Apr 2007
    Beans
    6

    Re: Mic not working in skype, ekiga on Ubuntu 10.10

    pavucontrol works perfectly!!! THANKS! I was going back to windows for Skype, now I dont have too!!!

  3. #23
    Join Date
    Feb 2011
    Beans
    4

    Re: Mic not working in skype, ekiga on Ubuntu 10.10

    Unfortunately, it didn't work for me. I'm using Ubuntu 10.10 and have an ASUS 1005PX, but setting the right-front channel on input devices to silence doesn't do anything - I can still see the input level meter floating around zero and I'm not able to hear anything in Skype. I'm quite desperate by now, as I seem to be the only idiot on the Internet with this problem... Can anybody help?

  4. #24
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,904
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Mic not working in skype, ekiga on Ubuntu 10.10

    Quote Originally Posted by totoritko View Post
    Unfortunately, it didn't work for me. I'm using Ubuntu 10.10 and have an ASUS 1005PX, but setting the right-front channel on input devices to silence doesn't do anything - I can still see the input level meter floating around zero and I'm not able to hear anything in Skype. I'm quite desperate by now, as I seem to be the only idiot on the Internet with this problem... Can anybody help?
    OK, I won't make any jokes...
    There are more than one reason for mic issues in ubuntu - mainly hardware specific. Use the alsa-info-script to provide detailed information.
    Run this command in a terminal:
    Code:
    wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
    Choose the upload option and provide a link for the output.
    [Terminal="Applications->Accessories->Terminal"]

  5. #25
    Join Date
    Feb 2011
    Beans
    4

    Re: Mic not working in skype, ekiga on Ubuntu 10.10

    http://www.alsa-project.org/db/?f=30...a66f09941a1a8b

    Thank you for any pointers on how to resolve this. When I played around with the inputs in padevchooser I cranked the input volume level up to 400% and could clearly hear noise, so apparently the driver is able to communicate with the card, but it only records very quiet noise...

  6. #26
    Join Date
    Feb 2011
    Beans
    4

    Thumbs down Re: Mic not working in skype, ekiga on Ubuntu 10.10

    Using the output of alsa-info I found out that I have a HD-Intel codec model ALC259, which, according to http://www.kernel.org/doc/Documentat...dio-Models.txt ,isn't supported - does that mean I'm completely out of luck? Or is there still hope of getting it work? Short of writing a new driver, I can fiddle around with kernel parameters and/or recompile alsa with tuning the code/headers around a bit. Thanks.

  7. #27
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,904
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Mic not working in skype, ekiga on Ubuntu 10.10

    Try this using a Terminal="Applications->Accessories->Terminal"
    Code:
    echo "options snd-hda-intel model=auto" | sudo tee -a /etc/modprobe.d/alsa-base.conf
    Reboot

  8. #28
    Join Date
    Feb 2011
    Beans
    4

    Re: Mic not working in skype, ekiga on Ubuntu 10.10

    Tried, but without any luck, I still can see no improvement in either pavucontrol (input levels still near zero) or Skype (no audible input). I suspect that there might be a problem with the BIOS-provided ACPI tree, since the kernel prints in dmesg: hda_codec: ALC259: BIOS auto-probing. hda_codec: connection list not available for 0x24 and ASUS is quite an offender when it comes to messed up ACPI tables (once bitten by an older laptop model which wouldn't even boot Linux without turning ACPI off almost completely). I'll try to look for a newer BIOS version and flash it in.

  9. #29
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,904
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Mic not working in skype, ekiga on Ubuntu 10.10

    Sounds like a plan. For some reason the codec is not properly recognized. If that fails, you can try an upstream kernel:
    https://wiki.ubuntu.com/Kernel/MainlineBuilds

  10. #30
    Join Date
    Feb 2011
    Beans
    1

    Re: Mic not working in skype, ekiga on Ubuntu 10.10

    Quote Originally Posted by steve-o1983 View Post
    I had the same problem, especially with Skype. After searching some forums, someone recommended installing Pulse Audio (you can find it in the Software Center "PulseAudio Volume Control"). Once installed, go to the Input Devices tab and put the front left on "Max" and the front right on "Silence". That should solve the problem. You will also have to go into Skype options - Sound Devices and make sure that the box is unchecked for "Allow Skype to automatically adjust my mixer levels." That will throw it off every time.
    thank you this worked for my issue.

Page 3 of 7 FirstFirst 12345 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •