Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: How to change the idle time before screen lock?

  1. #1
    Join Date
    Oct 2010
    Beans
    2

    How to change the idle time before screen lock?

    I've tried System > Screensaver prefs and see
    "Regard the computer as idle after " 5 minutes.

    I'd like to change this to, say, 8 minutes...but it's greyed out for me.

    Do you know how to make this editable?
    Or is there a way to do this from the terminal?

    Thanks,
    Jeff

  2. #2
    Join Date
    Jan 2010
    Location
    opposing reality (VIC AU)
    Beans
    990
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How to change the idle time before screen lock?

    Welcome to UF.

    That makes it sound like you are not the primary user of the machine, that is to say that you don't have admin privileges.

    Please try
    Code:
    sudo nano /etc/xdg/autostart/gnome-screensaver.desktop
    System will prompt you for a password, enter your regular login password - if it is rejected then you don't have admin privileges for this system and you need to talk to the person that does.

    If it opens a text editor with content then look for
    Code:
    X-GNOME-Autostart-Delay=5
    and change the 5 to an 8, press [CTRL]+[X] and type [Y], [Enter] - log out and log back into your desktop and open the 'screensaver' item off 'System'->'Preferences' again to check that it is changed to 8.

    How's that?
    Last edited by robsoles; October 20th, 2010 at 01:46 AM. Reason: sudo doesn't do/need quotes for nano like that.
    NEED HELP? | [SOLVED] | MS hide
    A little nonsense now and then...
    .
    If this is a game thread and you are going to post I hope you have read the Original Post.

  3. #3
    Join Date
    Sep 2009
    Location
    Canada, Montreal QC
    Beans
    1,809
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: How to change the idle time before screen lock?

    You need root right just to change a screen saver delay time?
    I know not with what weapons World War III will be fought, but World War IV will be fought with sticks and stones.
    Freedom is measured in Stallmans.
    Projects: gEcrit

  4. #4
    Join Date
    Jan 2010
    Location
    opposing reality (VIC AU)
    Beans
    990
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How to change the idle time before screen lock?

    Quote Originally Posted by cgroza View Post
    You need root right just to change a screen saver delay time?
    Entirely not sure but inclined to try something for OP - the file (I think) influenced in /etc/xdg/autostart belongs to root so it seems logical enough to think that a 'guest' (or at least non-wheel/admin user) won't be allowed to change it.
    NEED HELP? | [SOLVED] | MS hide
    A little nonsense now and then...
    .
    If this is a game thread and you are going to post I hope you have read the Original Post.

  5. #5
    Join Date
    Oct 2010
    Beans
    2

    Re: How to change the idle time before screen lock?

    Thanks so much, that worked!

    I appreciate the speedy, helpful reply.

  6. #6
    Join Date
    Jan 2010
    Location
    opposing reality (VIC AU)
    Beans
    990
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How to change the idle time before screen lock?

    Very welcome jfry, please consider using 'thread tools' (in red, above to right hand side) to mark your thread as solved.
    NEED HELP? | [SOLVED] | MS hide
    A little nonsense now and then...
    .
    If this is a game thread and you are going to post I hope you have read the Original Post.

  7. #7
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: How to change the idle time before screen lock?

    Have you gone to System->Preferences->Screensaver, and moved the slider to change the idle time? See screenshot
    Attached Images Attached Images

  8. #8
    Join Date
    Jan 2010
    Location
    opposing reality (VIC AU)
    Beans
    990
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How to change the idle time before screen lock?

    Quote Originally Posted by cariboo907 View Post
    Have you gone to System->Preferences->Screensaver, and moved the slider to change the idle time? See screenshot
    OP seemed competent enough to me to get into the right place to set their inactivity timeout and they said it was greyed out for them, like they were not a primary/admin user of their own machine (circumstance of greyed out options) so I pursued it and they've acknowledged that my crap worked out for them.

    I'd love to know for sure that it's grayed out in their dialog box that opens when we follow your instructions and look at your attachment because it doesn't entirely make sense that it was grayed out for them but worked for sudo <themself>, obviously this is a bug, albeit a much less obvious one.

    Sorry, I been drinking.

    I still hope jfry marks their post as solved, been a lot of 'interesting problems' with 10.10, what I always wait to see before taking any 'major upgrade' indeed
    NEED HELP? | [SOLVED] | MS hide
    A little nonsense now and then...
    .
    If this is a game thread and you are going to post I hope you have read the Original Post.

  9. #9
    Join Date
    Oct 2010
    Beans
    71

    Re: How to change the idle time before screen lock?

    This is quite an interesting result. On my machine I don't need sudo authentication to change that setting (tried both after sudo -k and on a no privs account) and it worked fine. It is also a preference, not an administrative setting so it should be applied on a per account basis and therefore not require root. I assume your solution changed the default, since files specific to a single user should never be in a system folder.
    Very puzzling...
    Angus

  10. #10
    Join Date
    Jan 2010
    Location
    opposing reality (VIC AU)
    Beans
    990
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How to change the idle time before screen lock?

    Quote Originally Posted by AngusH View Post
    This is quite an interesting result. On my machine I don't need sudo authentication to change that setting (tried both after sudo -k and on a no privs account) and it worked fine. It is also a preference, not an administrative setting so it should be applied on a per account basis and therefore not require root. I assume your solution changed the default, since files specific to a single user should never be in a system folder.
    Very puzzling...
    Angus
    Hoping you are subscribed, would you mind telling us your current version of Ubuntu and how you got there?

    Could you answer the same question please, jfry?
    Last edited by robsoles; October 21st, 2010 at 12:42 PM. Reason: ask jfry, in red.
    NEED HELP? | [SOLVED] | MS hide
    A little nonsense now and then...
    .
    If this is a game thread and you are going to post I hope you have read the Original Post.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •