Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: samsung mobile modem not detecting when connecting new mobile broadband connection

  1. #1
    Join Date
    Dec 2009
    Location
    Bangalore/india
    Beans
    26
    Distro
    Ubuntu 10.04 Lucid Lynx

    samsung mobile modem not detecting when connecting new mobile broadband connection

    Hello every one i am using samsung S3310 with aircel when i am connecting new mobile broadband connection my device is not identifying ,so that i cant connect Internet.but everything okay i mean settings in mobile and pc.

    for same connection i used Nokia mobile its identified and Internet was connected

    but samsung mobile is not identifying
    in terminal i typed LSUSB
    my device is shown in that,
    i don't know what is the problem
    could anyone help me please

  2. #2
    Join Date
    Jul 2010
    Location
    Dhaka , Bangladesh
    Beans
    116
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: samsung mobile modem not detecting when connecting new mobile broadband connectio

    can you paste the result of lsusb command? Is usb-mideswitch is installed? if no, install that & try again. Even doesn't successful then you may have to use wvdial.

  3. #3
    Join Date
    Dec 2009
    Location
    Bangalore/india
    Beans
    26
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: samsung mobile modem not detecting when connecting new mobile broadband connectio

    administrator@ubuntu:~$ lsusb
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 002: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 004: ID 04e8:6795 Samsung Electronics Co., Ltd
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


    what is that wvdial please help me

  4. #4
    Join Date
    Dec 2009
    Location
    Bangalore/india
    Beans
    26
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: samsung mobile modem not detecting when connecting new mobile broadband connectio

    p { margin-bottom: 0.08in; } administrator@ubuntu:~$ wvdialconf
    Editing `/etc/wvdial.conf'.


    Scanning your serial ports for a modem.


    ttyS0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
    ttyS0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
    ttyS0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
    Modem Port Scan<*1>: S1 S2 S3 ACM0




    Sorry, no modem was detected! Is it in use by another program?
    Did you configure it properly with setserial?


    Please read the FAQ at http://open.nit.ca/wiki/?WvDial


    If you still have problems, send mail to <wvdial-list@lists.nit.ca>.
    administrator@ubuntu:~$ lsusb
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 007: ID 04e8:6795 Samsung Electronics Co., Ltd
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    administrator@ubuntu:~$







    my device is not identifying

  5. #5
    Join Date
    Oct 2010
    Location
    Glasgow
    Beans
    10
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: samsung mobile modem not detecting when connecting new mobile broadband connectio

    Hi I'm very new to Ubuntu so what I did may not apply to your position. I'm using a Mobile Broadband dongle ZTE MF112 so nothing to do with Sumsung but it might be the same issue which is that the device is recognized as a CD rather than a modem. Installing mode-switch alone didn't work for me. I ended up going to /lib/udev/rules.d/61-mobile-action.rules and at the bottom changed the ENV{ID_VENDOR_ID}== "19d2" and
    ENV MODEL etc "2000" to the ones that show after running lsusb. In your case 04e8 and 6795. I kept the original entry by commenting out using #. Then copied and pasted and changed to my own modem IDs. I'm not sure if I've explained it very well or if it's completely safe to do but it worked for me when I restarted my computer.

  6. #6
    Join Date
    Dec 2009
    Location
    Bangalore/india
    Beans
    26
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: samsung mobile modem not detecting when connecting new mobile broadband connectio

    i couldn't understand please explain................

  7. #7
    Join Date
    Jul 2008
    Location
    UK
    Beans
    150
    Distro
    Ubuntu

    Re: samsung mobile modem not detecting when connecting new mobile broadband connectio

    Quote Originally Posted by Vtwin View Post
    Hi I'm very new to Ubuntu so what I did may not apply to your position. I'm using a Mobile Broadband dongle ZTE MF112 so nothing to do with Sumsung but it might be the same issue which is that the device is recognized as a CD rather than a modem. Installing mode-switch alone didn't work for me. I ended up going to /lib/udev/rules.d/61-mobile-action.rules and at the bottom changed the ENV{ID_VENDOR_ID}== "19d2" and
    ENV MODEL etc "2000" to the ones that show after running lsusb. In your case 04e8 and 6795. I kept the original entry by commenting out using #. Then copied and pasted and changed to my own modem IDs. I'm not sure if I've explained it very well or if it's completely safe to do but it worked for me when I restarted my computer.
    he/she is saying you may need to install usb-mode-switch
    try installing it with Synaptic Package Manager

    goodluck

  8. #8
    Join Date
    Dec 2009
    Location
    Bangalore/india
    Beans
    26
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: samsung mobile modem not detecting when connecting new mobile broadband connectio

    i did every thing but not identifying modem by network manger

  9. #9
    Join Date
    Oct 2010
    Location
    Glasgow
    Beans
    10
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: samsung mobile modem not detecting when connecting new mobile broadband connectio

    Hi I'll try and explain more clearly what worked for me although your Samsung might be completely different and I'm too inexperienced to offer any other advice.

    Start the terminal and enter sudo gedit
    I used Open to navigate to /lib/udev/rules.d/61-mobile-action.rules
    At the bottom there's an entry for ZTE MFxxx.
    I copied and pasted this entry below the original
    In your case you would then change "19d2" to "04e8" and "2000" to "6795" and then click on save.
    Reboot and see if your modem shows up in Network Manager.
    If it doesn't work it would probably be a good idea to remove the changes made in the 61-mobile file.
    Hope this helps

  10. #10
    Join Date
    Dec 2009
    Location
    Bangalore/india
    Beans
    26
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: samsung mobile modem not detecting when connecting new mobile broadband connectio

    i did below mentioned

    Start the terminal and enter sudo gedit
    I used Open to navigate to /lib/udev/rules.d/61-mobile-action.rules
    At the bottom there's an entry for ZTE MFxxx.
    I copied and pasted this entry below the original
    In your case you would then change "19d2" to "04e8" and "2000" to "6795" and then click on save.
    Reboot and see if your modem shows up in Network Manager.
    If it doesn't work it would probably be a good idea to remove the changes made in the 61-mobile file.
    Hope this helps

    and one more thing i did
    sudo gedit
    i used to open to navigate to /usr/share/hal/fdi/information/10freedesktop/10-modem.fdi
    i edited samsung vendor not identifying

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •