Thanks for the update. I received the same messages about not having the hardware to support Unity. In my case, it simply meant that I had to install the proprietary drivers for my video card (Nvidia).

I'm running Unity and I can't remember what the panel looked like when I first installed Natty Alpha - so I don't remember what the non-Unity menu looked like. In earlier releases you would get to the Additional Drivers page via System, Administration, Additional Drivers. In my case (with an older Nvidia GS 7600) Natty found it without problem. As soon as I installed and rebooted Unity worked fine.

Best of luck.