Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Wireless suddenly disconnecting

  1. #11
    Join Date
    Nov 2010
    Beans
    4

    Re: Wireless suddenly disconnecting

    I'm getting issues as well.

    This seems to be a big problem for people at the moment. It's a real shame as I normally rate Ubuntu highly for people looking for a Windoze alternative. But I can't recommend it to the 'infirm' if they are going to have constant battles to get their internet working.

    Hope to see a fix soon.

    --------------------------------------------------------------------------------

    Has anyone tried this solution with any success? http://edtake.wordpress.com/2010/05/...keep-dropping/

    ubuntu] Lucid Lynx Wireless Keep Dropping (updated)

    10 05 2010 After enduring the endless wireless disconnection after upgrading to Ubuntu 10.04 (Lucid Lynx) I have finally found the solution!
    The symptoms I was seeing is as such:

    1. connected
    2. after using for 5 minutes to 10 minutes, the wireless network manager get disconnected
    3. only wireless connection selectable is the last network you connect to
    4. unable to re-connect, even after 10 minutes
    5. you must disable the wireless and enable it before you can try to reconnect…
    6. then back to step 1

    The steps below worked for me

    • sudo gedit /etc/NetworkManager/nm-system-settings.conf
    • set the “[ifupdown] managed=false” to true.

    Although the above changes reduced the frequency of the wireless drop, but I am still facing it. After thinking it around a bit more, it’s more stable now. Below are what I have done:

    • sudo gedit /etc/NetworkManager/nm-system-settings.conf


    • Changed the file to:

    [main]
    plugins=ifupdown,keyfile
    [ifupdown]
    managed=true
    [ifdown]
    managed=true
    [ifup]
    managed=true
    Good luck to you! And have fun with Lucid Lynx. Let me know if this works or if there are other better fix!
    Added on June 28, 2010:
    With with the fixes above, it has only lessen the problem on my machine and not totally eliminate it. Thanks for the comments on trying out wicd, which i did give it a try. BUT although the wireless connection didn’t drop at all for the 2 days which i have been using it, i see a cap on the wireless transmission rate of 60KB/s (even after trying “sudo iwconfig wlan0 rate 54M”, which is not the problem). This is not acceptable to me, which is why i sent back to using gnome network manager, but for those of you who want to try out wicd, below are the commands:

    sudo apt-get install wicd
    sudo apt-get remove network-manager
    Drop me a message if you have a solution to the transmission rate cap!
    ---

    Good luck and hopefully we'll all find a solution eventually.
    Last edited by .dave; November 23rd, 2010 at 09:11 PM.

  2. #12
    Join Date
    Feb 2006
    Location
    Hatboro, PA
    Beans
    2,551
    Distro
    Ubuntu Development Release

    Re: Wireless suddenly disconnecting

    I've taken to downloading/installing the bleeding-edge compat-wireless, which makes things better for me.
    Asus EeePC 1005HA: ElementaryOS Luna | Asus X501A: Windows 8.1 & Ubuntu GNOME 14.10 Utopic Unicorn | Apple iMac G4: Ubuntu 12.04 Precise Pangolin | LG Optimus F3: Stock v7 | Nexus 10 Cyanogenmod 11

  3. #13
    Join Date
    Dec 2008
    Beans
    1

    Re: Wireless suddenly disconnecting

    Thanks to this thread I tried installing the package linux-backports-modules-compat-wireless-2.6.36-2.6.35-23-generic and so far the disconnection, low speed connection and packet loss nonsense I was having with my ath9k seems to have gone. It's now 54Mbit and hasn't presented a reconnection message or asked for a password in the last 24 hours. Hopefully it'll stay this way. I am using Kubuntu 10.10.
    Last edited by Dankstar; December 7th, 2010 at 12:07 AM.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •