Page 1 of 6 123 ... LastLast
Results 1 to 10 of 52

Thread: Grub timeout not working after upgrade from 10.04 to 10.10

  1. #1
    Join Date
    Feb 2006
    Location
    EU
    Beans
    133
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Question Grub timeout not working after upgrade from 10.04 to 10.10

    Yesterday I upgraded from 10.04 to 10.10 (x86_64). The upgrade itself succeeded, but now after booting I have to press enter in the grub OS list.
    grub.cfg looks like this:
    Code:
    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    
    GRUB_DEFAULT=0
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""
    
    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"
    
    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480
    GRUB_GFXMODE=1920x1200
    
    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true
    
    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_LINUX_RECOVERY="true"
    
    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"
    Why do I have to press enter to have grub boot the default entry?
    How can I get grub to start the default entry automatically, without showing the menu?

    BTW: entries in the list are default:
    Code:
    Ubuntu, with Linux 2.6.35-22-generic
    Ubuntu, with Linux 2.6.35-22-generic (recovery mode)
    Memory test (memtest86+)
    Memory test (memtest86+, serial console 115200)

  2. #2
    Join Date
    Oct 2009
    Beans
    4

    Re: Grub timeout not working after upgrade from 10.04 to 10.10

    I experience exactly the same issue and I am not able to find a solution

  3. #3
    Join Date
    Feb 2006
    Location
    EU
    Beans
    133
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Grub timeout not working after upgrade from 10.04 to 10.10

    Funny thing is: on another system (x86) I have 10.10 with an identical grub config, which starts automatically. Just like the x86_64 system did with 10.04.

  4. #4
    Join Date
    Apr 2009
    Location
    Rawalpindi, Pakistan
    Beans
    5,666
    Distro
    Ubuntu Gnome Development Release

    Re: Grub timeout not working after upgrade from 10.04 to 10.10

    Your /etc/default/grub looks fine to me.

    Please run

    Code:
    sudo update-grub
    Reboot and see if it works now.

  5. #5
    Join Date
    Apr 2007
    Beans
    Hidden!
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Grub timeout not working after upgrade from 10.04 to 10.10

    This is what I did... and now it's FIXED!!!

    Go to Synaptic Package Manager

    1- Completely remove
    grub-pc and grub-commom, if you have startupmanager, do it too.

    You will be asked if you want to keep the config files... say NO

    2- Reinstall

    grub-pc, grub-common and startupmanager

    upon reinstall... select the maintainers version... if prompted at all. (I had a blank window in the prompt so I clicked 'Forward').

    3- After install

    open startup manager in your Administrations Mmnu

    Select the desired timeout
    Select a Resolution that's good for you.. for me it was 1024x768
    Select your color depth .. for me it was 24 bits

    Select the Advanced Tab and choose a Bootloader menu Resolution.. for me it was 1280x1024

    I have a 24" monitor and those resolutions worked best for me.

    Good Luck

  6. #6
    Join Date
    Feb 2006
    Location
    EU
    Beans
    133
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Grub timeout not working after upgrade from 10.04 to 10.10

    I already ran update-grub several times, trying different timeout settings for grub.

    Your steps for me did:
    1. mess up the splash screen (wrong resolution, instead of an Ubuntu logo the text "ubuntu 10.10" in a Courier-like font);
    2. mess up the tty resolution;
    3. NOT fix the original problem, I still have to press Enter to boot the default menu entry.

    Startupmanager is pretty useless. I does not contain the native resolution of my 24" display (1920x1200). And it looks like it messes directly with /etc/grub.d/00_header, instead of using /etc/default/grub. The line
    Code:
    set gfxmode=${GRUB_GFXMODE}
    was replaced with
    Code:
    set gfxmode=1600x1200
    (the closest to my preferred resolution I could select in startupmanager).

    So the original question still stands: why doesn't grub boot the default menu entry?

    (BTW: Using 1280x1024 on a 24" display... I used that resolution on a 17" CRT. If you have an LCD screen I think there is only one right resolution, and that is the native one, and I can't think of a 24" LCD with native 1280x1024.)
    Last edited by gwi; October 19th, 2010 at 06:36 PM. Reason: layout

  7. #7
    Join Date
    Oct 2010
    Beans
    41
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Grub timeout not working after upgrade from 10.04 to 10.10

    Hello folks.
    I am first time at this forum and i am quite new to linux at all, but hope i can participate sometime.

    Meanwhile i have same problems. Likewise i have x86_64 and upgraded to 10.10 recently. On demand i can provide my /etc/default/grub (which is quite simple as in first post) or "bootscript" output, etc.

    I hope this problem will be solved.

    UPD:
    So i just tried to reinstall it (grub) through synaptic (as been proposed early in this thread) and for first reboot countdown was shown again but for next it disappeared. It looks very strange.
    Last edited by Elline; October 31st, 2010 at 08:27 PM.

  8. #8
    Join Date
    Aug 2006
    Beans
    252

    Re: Grub timeout not working after upgrade from 10.04 to 10.10

    I am having this problem as well - though i didn't upgrade, i am still running 10.04.
    what i did was - install a new harddrive - booted a live cd, copied most of the partitions from old drive to new one, then fixed the new drives fstab. mounted the new drive's / and then the boot partition to /media/root/boot and installed grub to the mbr of the new drive.

    it all booted fine after i swapped the drives. but now my /etc/default/grub seems not to honor my timeout settings.
    what i have read is that osprober will override any hidden timeout. i have a windows partition so i commented the hidden options out and set GRUB_TIMEOUT=4
    updating grub is not doing it for me though ---- i still have to select manually

  9. #9
    Join Date
    Nov 2010
    Beans
    3

    Re: Grub timeout not working after upgrade from 10.04 to 10.10

    Ditto, same problem. Installed 10.10 and timeout worked at first, then stopped working. editing and updating grub.cfg doesn't make a difference. annoying.

  10. #10
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Grub timeout not working after upgrade from 10.04 to 10.10

    Edit: Solved in post # 32.

    @ gwi,

    I just noticed this thread with the recent additions. One thing that could cause Grub not to boot is the screen resolution you have set. You can check the available resolutions from the grub prompt (press "c" from the Grub menu) by typing "vbeinfo". If the resolution isn't supported, Grub will await input.

    I don't know if either your original or the new one you tried is supported, but I'd just comment out all resolutions and let Grub use the default (which is 640x480 even when that line is commented out). At least you will find out whether or not it's a resolution problem.

    Note: there have been several posts lately about the counter not working. Most likely a 'recordfail' is being generated for some reason. To see if it's a recordfail issue, you can temporarily edit grub.cfg and force 'recordfail' to be ignored:
    Code:
    gksu gedit /boot/grub/grub.cfg
    Add the line in dark red, save the file, do NOT run update-grub and reboot.
    insmod gettext
    recordfail=0
    if [ "${recordfail}" = 1 ]; then
    set timeout=-1
    else
    set timeout=10
    fi
    The line will be removed once you run "sudo update-grub" the next time.
    Last edited by drs305; December 30th, 2010 at 05:26 AM.
    GRUB2

    Retired.

Page 1 of 6 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •