Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Installer failed to install grub boot loader. I'm trying to finish the install NOW

  1. #1
    Join Date
    Jan 2008
    Location
    A place with no mountains
    Beans
    1,608
    Distro
    Kubuntu

    Installer failed to install grub boot loader. I'm trying to finish the install NOW

    Toward the end of installing Ubuntu 10.10 32bit (Alt CD) on my iMac 11,1, the installer asked me to type in the location for installing the grub boot loader.

    I told it to use /dev/sda3 and it immediately failed. I'm still in the installer. Can anyone suggest a solution?

    Here are my partitions on sda:

    3.1 kb free space
    #1 209.7 MB B EFIboot
    #2 961.3 GB hfs+
    1.0 MB free space
    #3 1.0 MB biosgrub
    #4 46.6 GB etc4 for Ubuntu
    #5 2.0 GB swap

    ...from the shell in the installer, there is no grub.cfg in /target/boot/grub.

    What next?
    Last edited by MountainX; October 17th, 2010 at 02:31 AM.
    Desktop: KX Studio (Kubuntu 12.04)
    Laptop & Netbook: Kubuntu 12.04
    Tablet: Samsung Galaxy Tab 10.1
    Phone: Nexus 4 Cyanogenmod

  2. #2
    Join Date
    Jan 2008
    Location
    A place with no mountains
    Beans
    1,608
    Distro
    Kubuntu

    Re: Installer failed to install grub boot loader. I'm trying to finish the install NO

    I went into the rEFIt partitioning tool. According to the GPT partition table, everything appears OK.
    But there is a message:
    Status MBR partition table is invalid. Partitions overlap.
    ERROR: Not Found reported from gptsync.efi.

    I do not see an overlap by looking at the table. Suggestions?
    Desktop: KX Studio (Kubuntu 12.04)
    Laptop & Netbook: Kubuntu 12.04
    Tablet: Samsung Galaxy Tab 10.1
    Phone: Nexus 4 Cyanogenmod

  3. #3
    Join Date
    Jan 2008
    Location
    A place with no mountains
    Beans
    1,608
    Distro
    Kubuntu

    Re: Installer failed to install grub boot loader. I'm trying to finish the install NO

    I found this page:
    http://ubuntuforums.org/showthread.p...23#post9984223

    After reading that whole thread, all I can say is that this looks hopeless.

    This thread is not solved. I'm not sure how it got marked solved.
    Desktop: KX Studio (Kubuntu 12.04)
    Laptop & Netbook: Kubuntu 12.04
    Tablet: Samsung Galaxy Tab 10.1
    Phone: Nexus 4 Cyanogenmod

  4. #4
    Join Date
    Jul 2007
    Beans
    29
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Installer failed to install grub boot loader. I'm trying to finish the install NO

    I think you'll need much more than a megabyte for /dev/sda3 if it's your /boot mount point. I gave that partition 100MB and grub is currently using about 50MB of that (but that can grow).

    Try resizing and then reinstalling grub, then if you still have problems with overlapping partitions, this post worked for me with gptsync.

  5. #5
    Join Date
    Jan 2008
    Location
    A place with no mountains
    Beans
    1,608
    Distro
    Kubuntu

    Re: Installer failed to install grub boot loader. I'm trying to finish the install NO

    Quote Originally Posted by pc_michael View Post
    I think you'll need much more than a megabyte for /dev/sda3 if it's your /boot mount point. I gave that partition 100MB and grub is currently using about 50MB of that (but that can grow).

    Try resizing and then reinstalling grub, then if you still have problems with overlapping partitions, this post worked for me with gptsync.
    Thanks for the link. That looks helpful -- but it also looks like a challenging task.

    BTW, as far as what I had intended, sda3 was not for /boot. It's just for grub. And I was just following a set of instructions that have supposed worked for other iMac owners who want to install Ubuntu. On my PC I usually use 200 MB to 1 GB for /boot when I give it it's own partition.
    Desktop: KX Studio (Kubuntu 12.04)
    Laptop & Netbook: Kubuntu 12.04
    Tablet: Samsung Galaxy Tab 10.1
    Phone: Nexus 4 Cyanogenmod

  6. #6
    Join Date
    Mar 2010
    Location
    Woonsocket, RI USA
    Beans
    3,195

    Re: Installer failed to install grub boot loader. I'm trying to finish the install NO

    Quote Originally Posted by MountainX View Post
    I went into the rEFIt partitioning tool. According to the GPT partition table, everything appears OK.
    But there is a message:
    Status MBR partition table is invalid. Partitions overlap.
    ERROR: Not Found reported from gptsync.efi.

    I do not see an overlap by looking at the table. Suggestions?
    The GPT and MBR partition tables are separate. You said your GPT partitions look fine, but the message says that the MBR partitions overlap. In fact, this is a very common problem; the software that the Web pages say to use is buggy and creates this invalid hybrid MBR.

    The easiest solution is to use Linux fdisk to delete the overlapping 0xEE partition (it's probably /dev/sda3 in the MBR). Alternatively, you could rebuild the hybrid MBR with a tool that doesn't have this bug, such as GPT fdisk (gdisk).

  7. #7
    Join Date
    Jan 2008
    Location
    A place with no mountains
    Beans
    1,608
    Distro
    Kubuntu

    Re: Installer failed to install grub boot loader. I'm trying to finish the install NO

    Quote Originally Posted by srs5694 View Post
    The easiest solution is to use Linux fdisk to delete the overlapping 0xEE partition (it's probably /dev/sda3 in the MBR). Alternatively, you could rebuild the hybrid MBR with a tool that doesn't have this bug, such as GPT fdisk (gdisk).
    Thank you. So, if I do the easy thing and delete /dev/sda3 (which is indeed the offending partition), will I then install grub to sda4?

    I have not been able to boot my iMac with the Ubuntu LiveCD (or install from that disk) so that complicates things a little.

    I was just reading about GPT fdisk at rodsbooks.com... lots of stuff to read... (and not enough time)
    Desktop: KX Studio (Kubuntu 12.04)
    Laptop & Netbook: Kubuntu 12.04
    Tablet: Samsung Galaxy Tab 10.1
    Phone: Nexus 4 Cyanogenmod

  8. #8
    Join Date
    Jan 2008
    Location
    A place with no mountains
    Beans
    1,608
    Distro
    Kubuntu

    Re: Installer failed to install grub boot loader. I'm trying to finish the install NO

    Quote Originally Posted by MountainX View Post
    Thank you. So, if I do the easy thing and delete /dev/sda3 (which is indeed the offending partition), will I then install grub to sda4?
    I did delete sda3 and I used the rEFIt partition tool and it reported success in syncing the partition tables and told me everything was OK. I installed grub via:
    Code:
    #grub-install /dev/sda4
    It was successful.

    But now, when I (attempt to) boot into Ubuntu, rEFIt tells me the operating system is missing.
    Desktop: KX Studio (Kubuntu 12.04)
    Laptop & Netbook: Kubuntu 12.04
    Tablet: Samsung Galaxy Tab 10.1
    Phone: Nexus 4 Cyanogenmod

  9. #9
    Join Date
    Nov 2010
    Beans
    17
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Installer failed to install grub boot loader. I'm trying to finish the install NO

    Hi. Any more news on the missing OS issue? I suppose you figured it out by now.

  10. #10
    Join Date
    Jan 2008
    Location
    Netherlands
    Beans
    2,930
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Installer failed to install grub boot loader. I'm trying to finish the install NO

    I installed Grub on /dev/sda with a --force
    It runs fine.
    Linux on your Apple Mac │ iLinux
    http://mac.linux.be
    http://www.mintppc.org

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •