Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Need to disable/enable networking each boot

  1. #1
    Join Date
    Oct 2007
    Beans
    60

    Need to disable/enable networking each boot

    Hiya.

    I have a strange problem with my networking under Ubuntu. When I first log in to Gnome both my network adapters are listed as "disconnected" in the network manager applet. If I right click on the notification icon and disable networking, then wait a few seconds and re enable it, it works fine.

    It's happening consistently with Maverick although it seemed only temperamental with Lucid. I did a fresh Maverick install to see if it would help but it hasn't.

    It's the onboard network sockets on a Gigabyte GA-X58A-UD7. I have two ports but I only use one, it doesn't seem to matter which I use. It's connected via gigabit ethernet to a Netgear router. It works fine in Windows 7 (dual boot).

    It looks as though something's not quite "ready" when gnome first launches. The light on the router for the cable is off at first, and only comes on after a few seconds. It's DHCP. Same thing happened on the live USB stick (just before the isntaller) and disable/reenable made it work.

    Thanks for any help.

    Wlo.

  2. #2
    Join Date
    Oct 2009
    Location
    Springfield, IL
    Beans
    796

    Re: Need to disable/enable networking each boot

    Right click the Network Icon in the panel and choose "Edit Connections" Click the Wireless Tab and Edit your Connection. You may be asked for your password. Make sure that "Connect Automatically" is checked. Then "Apply."
    HP s5710f, 2x AMD Athlon II 250 @ 3.2Ghz 3GB RAM 640GB HD
    Saline OS 1.6 2.6.32 AMD64 Xfce
    SolusOS Beta-1 3.0.0 solus kernel i686 Gnome 2.3
    Xubuntu 12.04 Precise Pangolin 3.2.0-15-generic

  3. #3
    Join Date
    Oct 2007
    Beans
    60

    Re: Need to disable/enable networking each boot

    Quote Originally Posted by bobcollard View Post
    Right click the Network Icon in the panel and choose "Edit Connections" Click the Wireless Tab and Edit your Connection. You may be asked for your password. Make sure that "Connect Automatically" is checked. Then "Apply."
    Hi, thanks for your response. I'm connected via wired ethernet cable, so the "Wireless" tab is empty, but following your steps for the "Wired" tab, both adapters have the "Connect automatically" ticked.

    Any other ideas?

  4. #4
    Join Date
    Oct 2009
    Location
    Springfield, IL
    Beans
    796

    Re: Need to disable/enable networking each boot

    Quote Originally Posted by Wlo View Post
    Hi, thanks for your response. I'm connected via wired ethernet cable, so the "Wireless" tab is empty, but following your steps for the "Wired" tab, both adapters have the "Connect automatically" ticked.

    Any other ideas?
    Sorry, no. If you don't hear anything from another user, Bump your Thread to bring it back to someone's attention. BTW is your modem on before you startup the computer, or, are they both started at the same time? The modem itself may be disconnecting when you shut it down.
    Last edited by bobcollard; October 13th, 2010 at 05:17 PM.
    HP s5710f, 2x AMD Athlon II 250 @ 3.2Ghz 3GB RAM 640GB HD
    Saline OS 1.6 2.6.32 AMD64 Xfce
    SolusOS Beta-1 3.0.0 solus kernel i686 Gnome 2.3
    Xubuntu 12.04 Precise Pangolin 3.2.0-15-generic

  5. #5
    Join Date
    Oct 2007
    Beans
    60

    Re: Need to disable/enable networking each boot

    Quote Originally Posted by bobcollard View Post
    BTW is your modem on before you startup the computer, or, are they both started at the same time? The modem itself may be disconnecting when you shut it down.
    Hi. No the router remains connected to the ADSL line. There's other devices (NAS drive, printer, PS3, laptop) using it fine whether or not Linux is booted.

    Cheers.

  6. #6
    Join Date
    Oct 2009
    Location
    Springfield, IL
    Beans
    796

    Re: Need to disable/enable networking each boot

    My question is: Is the power on to the router and modem all the time? If you turn it off with the computer, then, it may need to be reset.
    HP s5710f, 2x AMD Athlon II 250 @ 3.2Ghz 3GB RAM 640GB HD
    Saline OS 1.6 2.6.32 AMD64 Xfce
    SolusOS Beta-1 3.0.0 solus kernel i686 Gnome 2.3
    Xubuntu 12.04 Precise Pangolin 3.2.0-15-generic

  7. #7
    Join Date
    Oct 2007
    Beans
    60

    Re: Need to disable/enable networking each boot

    Quote Originally Posted by bobcollard View Post
    My question is: Is the power on to the router and modem all the time? If you turn it off with the computer, then, it may need to be reset.
    The router and ADSL router both remain on, and, as I said, all other devices on my network can continue to use them fine, as can Windows on the same machine.

  8. #8
    Join Date
    Oct 2007
    Beans
    60

    Re: Need to disable/enable networking each boot

    Not sure if it's related, but when I do enable my network via disable/enable, it's slow, ethtool reports the speed as 10mb/s when I have a gigabit network, card is the onboard for my Gigabyte GA-X58A-UD7.

    Full output of ethtool below. I'm happy to buy a new network card if that may solve it. Any ideas which one would be likely to work out of the box?

    Thanks.

    --->
    :~$ sudo ethtool eth1
    Settings for eth1:
    Supported ports: [ TP MII ]
    Supported link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Half 1000baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Half 1000baseT/Full
    Advertised pause frame use: No
    Advertised auto-negotiation: Yes
    Link partner advertised link modes: 10baseT/Half 10baseT/Full
    Link partner advertised pause frame use: No
    Link partner advertised auto-negotiation: Yes
    Speed: 10Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: pumbg
    Wake-on: g
    Current message level: 0x00000033 (51)
    Link detected: yes

  9. #9
    Join Date
    Oct 2007
    Beans
    60

    Re: Need to disable/enable networking each boot

    Fixed it from the instructions in this thread, http://ubuntuforums.org/showthread.php?t=1480328&page=2 .

    Had to disconnect the power completely and wait as apparently network cards sometimes get themselves in a tiz and they retain their power even whilst PC is off.

    Cheers.

  10. #10
    Join Date
    Apr 2006
    Location
    UK
    Beans
    555
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Need to disable/enable networking each boot

    I got this when I upgraded my mother board from a 10/100 to a gigabyte onboard network card. I finished up plugging in an old network card. What causes it then? and Wont this happen again?
    Steve
    Intel Pentium Dual Core 2.6 Ghz 2 Gb ram, Asus P5KPL motherboard, 2.5 TB Storage running Hardy.
    HP Pentium 4 2.8 Ghz 756 mb ram running Intrepid.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •