Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: D key (alone) shows desktop over Xrdp

  1. #1
    Join Date
    Dec 2006
    Beans
    5
    Distro
    Ubuntu 10.10 Maverick Meerkat

    D key (alone) shows desktop over Xrdp

    PROBLEM
    While connecting over Xrdp, hitting the "D" key alone hides all my windows and shows the desktop. This is problematic since I often wish to type words containing at least one "D" in it. In case anyone else is having this problem, I've wrestled through it and offer this help.

    I'm using Ubuntu 10.10 Maverick Meercat and connecting via Xrdp. I only have this problem when connecting remotely.

    APPARENT CAUSE
    I don't pretend to know for sure, but the problem appears to be that the remote connection is flubbing Metacity's "<Super>d" binding for the "show desktop" command. More precisely, the string "<Super>" doesn't appear to be functioning for me. If I change <Super> to <Ctrl>, I can use Ctrl + D to show desktop, and I can then type the letter D without it hiding every window from me.

    Further evidence <Super> isn't working for me, if I change Metacity's "panel_run_dialog" global key binding from "<Alt>F2" to "<Super>F2" I bring up the run dialog by hitting F2 alone.

    WORKAROUND
    Change the system's "show desktop" keystroke. Here are the steps.

    1) Alt+F2
    2) gconf-editor
    3) /->app->metacity->global_keybindings
    4) Change the assigned keystroke for show_desktop from "<Super>d" to "<Ctrl>d" or "<Ctrl><Alt>d" or "disabled"

    If someone finds this worthy of submitting a bug ticket, please let me know so I can follow it. Thanks.

    Ed

  2. #2
    Join Date
    May 2008
    Beans
    14

    Re: D key (alone) shows desktop over Xrdp

    I also have this problem on a vanilla install, which to me means that either xrdp or the terminal server client is broken, I would wager it's xrdp. Bummer too because this is the best way to work with VM's in my book.

  3. #3
    Join Date
    Apr 2009
    Location
    Canada
    Beans
    26
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: D key (alone) shows desktop over Xrdp

    I got the exact same problem when upgraded to maverick recently, after resolving a host of other problems with xrdp. It seems xrdp is not getting a lot of attention in the regression process, since there was a problem with demonic short cuts in xrdp in 10.04 as well (http://ubuntuforums.org/showthread.php?t=1471770).

    Thanks for posting your work around, it works perfectly (though I elected to disable the show desktop shortcut). I'd like to raise a bug report but I don't know how the Ubuntu bug report system work, yet.

  4. #4
    Join Date
    Nov 2010
    Beans
    1

    Re: D key (alone) shows desktop over Xrdp

    Astonished that not many more people have hit the problem.

    As I understand, it is a keyboard mapping issue when connecting to a Ubuntu machine (which has xrdp installed) with RDP.

    Once connected, hitting the key <d> (note lower case) minimizes all active windows and shows the desktop. Hitting the key again restores the windows, but you will not be able to enter the letter "d" in any application. Slightly limiting...

    I found that going to System->Preferences->Keyboard Shortcuts lists the mappings, although using a somewhat obscure "key language" which I am not familiar with. However, if you scroll to the bottom, you will find this entry:

    <hide all normal windows and show the desktop -> D>

    (note here the uppercase "D"). This is the culprit. Change the mapping to, say, <Alt><d> (lower case), close and the problem should be solved!

    Now what this has done is to create a file under your home directory (I will represent that by the usual ~):

    ~/.gconf/apps/metacity/global_keybindings/%gconf.xml

    and the new mapping is stored in that XML file.

    It appears to be an error in the default keyboard mappings. They might be in the X11 configuration, but I could not devote more time to look into this further.

    Cheers to all. HTH.

  5. #5
    Join Date
    Dec 2006
    Beans
    11

    Re: D key (alone) shows desktop over Xrdp

    Thanks laperouse, this issue was driving me crazy. Your solution worked perfectly.

  6. #6
    Join Date
    May 2007
    Beans
    1

    Re: D key (alone) shows desktop over Xrdp

    Thank you for the workaround!

  7. #7
    Join Date
    Sep 2009
    Beans
    19
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: D key (alone) shows desktop over Xrdp

    I had the same problem; the strange thing is that it's like the "Windows" key was always considered pressed, but it happens only with the d key. Since I had just changed my .xmodmap file (which worked correctly on Ubuntu 9.10) I checked it but it was correct.
    Anyway, I've adopted this workaround...

  8. #8
    Join Date
    Nov 2009
    Beans
    10

    Re: D key (alone) shows desktop over Xrdp

    Also being plagued by the inane and obtuse use of the "d" key via remote login, I troweled upon the black earth a little deeper.

    Using "gconftool-2", I traveled down the structured tree to light upon the branch "/apps/metacity/global_keybindings" and found the "show_desktop" item. Lo, the value appears as "<Super>d". With apparent resolve, the poorly designed program is left bewildered as to the use of "<Super>" and randomly decide for itself to apparently ignore "<Super>" and select the "d" key. Unbeknownst to the astute end-user, the lowly "d" key has suddenly become his bane forevermore.

    I protest! An error I say! I banish thee to the deepest pit of hell!
    Changing this does not one any good fortune, sudo or not!

    To correct heinous error, edit the swine of a file "/var/lib/gconf/debian.defaults/%gconf-tree.xml" and set the "show_desktop"s stringvalue to "Disabled" or whatever your humble preference. A trick upon this treat is to actually make entry of the word "Disabled" as it contains a "d". The astute reader shall quickly note the use of the "delete" key on "&lt;Super&gt", enter "isable", and use the existing "d". No longer shall each user need concern themselves with prior given solutions henceforth.

    My given solution requires a logout/login.

    Live well hence forth for all user logins thereafter. I fare thee anon.
    Last edited by AtesComp; March 3rd, 2011 at 04:09 AM. Reason: UPDATE

  9. #9
    Join Date
    Mar 2011
    Beans
    1

    Re: D key (alone) shows desktop over Xrdp

    Quote Originally Posted by ecadman View Post
    PROBLEM
    While connecting over Xrdp, hitting the "D" key alone hides all my windows and shows the desktop. This is problematic since I often wish to type words containing at least one "D" in it. In case anyone else is having this problem, I've wrestled through it and offer this help.

    I'm using Ubuntu 10.10 Maverick Meercat and connecting via Xrdp. I only have this problem when connecting remotely.

    APPARENT CAUSE
    I don't pretend to know for sure, but the problem appears to be that the remote connection is flubbing Metacity's "<Super>d" binding for the "show desktop" command. More precisely, the string "<Super>" doesn't appear to be functioning for me. If I change <Super> to <Ctrl>, I can use Ctrl + D to show desktop, and I can then type the letter D without it hiding every window from me.

    Further evidence <Super> isn't working for me, if I change Metacity's "panel_run_dialog" global key binding from "<Alt>F2" to "<Super>F2" I bring up the run dialog by hitting F2 alone.

    WORKAROUND
    Change the system's "show desktop" keystroke. Here are the steps.

    1) Alt+F2
    2) gconf-editor
    3) /->app->metacity->global_keybindings
    4) Change the assigned keystroke for show_desktop from "<Super>d" to "<Ctrl>d" or "<Ctrl><Alt>d" or "disabled"

    If someone finds this worthy of submitting a bug ticket, please let me know so I can follow it. Thanks.

    Ed

    I have to say, that although the solution is not obvious, it worked perfectly for me. I am on a Windows 7 laptop and remoting into a desktop running Ubuntu 10.10 standard desktop install.

    thank-you for the solution.

  10. #10
    Join Date
    Mar 2011
    Beans
    1

    Re: D key (alone) shows desktop over Xrdp

    I was having the same problem with the pressing the 'd' key and it minimizing my windows. I fixed it by using the work around that ecadman posted.

    I am still having some other issues which I think are related to the Super issue. When I am in the file browser and double click on something it closes all of my file windows. If I ctrl+left click to select multiple items it closes all of my file browser windows. If shift+left click I am fine but if use shift+up arrow or shift+down arrow it closes all of my file browser windows. It is very annoying when trying to copy files around or even trying to open a file.

    Has anyone else had this issue as well?

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •