Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Updating linux-image-2.6.35-22-generic (2.6.35-22.34)

  1. #1
    Join Date
    Mar 2008
    Beans
    37
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Updating linux-image-2.6.35-22-generic (2.6.35-22.34)

    I've looked everywhere for help with this error in the console whenever I upgrade packages. This doesn't affect anything I do in Ubuntu, but it is just a little annoying.

    Here is what I get when I execute sudo apt-get upgrade
    Code:
    Setting up linux-image-2.6.35-22-generic (2.6.35-22.34) ...
    Running depmod.
    update-initramfs: Generating /boot/initrd.img-2.6.35-22-generic
    Failed to symbolic-link boot/initrd.img-2.6.35-22-generic to initrd.img: File exists
    dpkg: error processing linux-image-2.6.35-22-generic (--configure):
     subprocess installed post-installation script returned error exit status 17
    Errors were encountered while processing:
     linux-image-2.6.35-22-generic
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    I think there was a simple command I could run to fix this, but I have a terrible memory. Any hints?

    Thanks!

  2. #2
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Updating linux-image-2.6.35-22-generic (2.6.35-22.34)

    try:

    sudo apt-get clean
    sudo apt-get autoclean
    sudo apt-get autoremove

    sudo apt-get update
    sudo apt-get install -f

    sudo dpkg-reconfigure linux-image-2.6.35-22-generic

  3. #3
    Join Date
    Nov 2007
    Beans
    1

    Re: Updating linux-image-2.6.35-22-generic (2.6.35-22.34)

    Code:
    Running depmod.
    update-initramfs: Generating /boot/initrd.img-2.6.35-22-generic
    Not updating initrd symbolic links since we are being updated/reinstalled 
    (2.6.35-22.33 was configured last, according to dpkg)
    Not updating image symbolic links since we are being updated/reinstalled 
    (2.6.35-22.33 was configured last, according to dpkg)
    Examining /etc/kernel/postinst.d.
    run-parts: executing /etc/kernel/postinst.d/dkms 2.6.35-22-generic /boot/vmlinuz-2.6.35-22-generic
     * dkms: running auto installation service for kernel 2.6.35-22-generic         
     *       nvidia-current (260.19.06)...                                   [ OK ] 
    run-parts: executing /etc/kernel/postinst.d/initramfs-tools 2.6.35-22-generic /boot/vmlinuz-2.6.35-22-generic
    run-parts: executing /etc/kernel/postinst.d/nvidia-common 2.6.35-22-generic /boot/vmlinuz-2.6.35-22-generic
    run-parts: executing /etc/kernel/postinst.d/pm-utils 2.6.35-22-generic /boot/vmlinuz-2.6.35-22-generic
    run-parts: executing /etc/kernel/postinst.d/update-notifier 2.6.35-22-generic /boot/vmlinuz-2.6.35-22-generic
    run-parts: executing /etc/kernel/postinst.d/zz-update-grub 2.6.35-22-generic /boot/vmlinuz-2.6.35-22-generic
    /etc/default/grub: 9: splash: not found
    run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 127
    Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-2.6.35-22-generic.postinst line 1010.
    dpkg: error al procesar linux-image-2.6.35-22-generic (--configure):
     el subproceso script post-installation instalado devolvió el código de salida de error 2
    Se encontraron errores al procesar:
     linux-image-2.6.35-22-generic
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Ok, this is my problem seems to be the same as yours ...
    And seeing the full log you can see that the error which refers to the grub
    Code:
    /etc/default/grub: 9: splash: not found
    The problem is that you have not installed either the patch for the pymount look good with nvidia
    Escuchar
    Leer fonéticamente
    You can follow the detailed how to solve the problem
    http://news.softpedia.com/news/How-to-Fix-the-Big-and-Ugly-Plymouth-Logo-in-Ubuntu-10-04-140810.shtml
    after that you can run
    sudo apt-get install -f

  4. #4
    Join Date
    Sep 2008
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Updating linux-image-2.6.35-22-generic (2.6.35-22.34)

    same here even reconfigure do not work and autoremove killed Ubuntu, something is really wrong with update currently.
    tox.im - Future open source Skype alternative.
    n2n VPN - Hamachi alternative for Linux, Win, Mac
    System Imaging - Remastersys fork

  5. #5
    Join Date
    Sep 2010
    Location
    Hungary
    Beans
    65
    Distro
    Ubuntu Development Release

    Re: Updating linux-image-2.6.35-22-generic (2.6.35-22.34)

    Ran into the same error code today, and System -> Administration -> Computer Janitor solved the problem for me. Give it a try
    The truth is out there

  6. #6
    Join Date
    Mar 2008
    Beans
    37
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Updating linux-image-2.6.35-22-generic (2.6.35-22.34)

    Alright. Tried all the command dino99 suggested, same error. Gave the Computer Janitor a try already, but tried again to be extra sure. It just has a lot of libre office debs that it can't remove because another package manager is in use... (When it isn't in use...) Gtuxyco, I followed that guide and tried apt-get install -f, same message...

    So far no answer. Thanks for the suggestions though.
    Last edited by otoris; October 13th, 2010 at 11:43 PM.

  7. #7
    Join Date
    Feb 2005
    Location
    Spain
    Beans
    149
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: Updating linux-image-2.6.35-22-generic (2.6.35-22.34)

    Hi, same problem here:

    [quote]

    ██ link @ ~
    ██ 23:21:09 $ sudo apt-get -f install
    Leyendo lista de paquetes... Hecho
    Creando árbol de dependencias
    Leyendo la información de estado... Hecho
    0 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.
    1 no instalados del todo o eliminados.
    Se utilizarán 0B de espacio de disco adicional después de esta operación.
    Configurando linux-image-2.6.35-22-generic (2.6.35-22.35) ...
    Running depmod.
    update-initramfs: Generating /boot/initrd.img-2.6.35-22-generic
    Failed to symbolic-link boot/initrd.img-2.6.35-22-generic to initrd.img: El archivo ya existe
    dpkg: error al procesar linux-image-2.6.35-22-generic (--configure):
    el subproceso script post-installation instalado devolvió el código de salida de error 17
    Se encontraron errores al procesar:
    linux-image-2.6.35-22-generic
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    [/quote ]

    BR.
    AMD Athlon 64 3000+ Core Venice
    Abit KN8-Ultra
    2x512 DDR400 Dual Channel (Geil kit)
    MSI NX6600GT-TD128
    SB X-FI XM

    ASUS A4K Laptop
    AMD Athlon 64 mobile 3200+
    2*256 DDR 400
    Mobo ASUS Nforce3-150
    Ati Radeon Mobility 9700

  8. #8
    Join Date
    Nov 2008
    Beans
    20
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Updating linux-image-2.6.35-22-generic (2.6.35-22.34)

    Same here!


    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    1 not fully installed or removed.
    After this operation, 0B of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Setting up linux-image-2.6.35-22-generic (2.6.35-22.35) ...
    Running depmod.
    update-initramfs: Generating /boot/initrd.img-2.6.35-22-generic
    Not updating initrd symbolic links since we are being updated/reinstalled 
    (2.6.35-22.34 was configured last, according to dpkg)
    Not updating image symbolic links since we are being updated/reinstalled 
    (2.6.35-22.34 was configured last, according to dpkg)
    Examining /etc/kernel/postinst.d.
    run-parts: executing /etc/kernel/postinst.d/dkms 2.6.35-22-generic /boot/vmlinuz-2.6.35-22-generic
    run-parts: executing /etc/kernel/postinst.d/initramfs-tools 2.6.35-22-generic /boot/vmlinuz-2.6.35-22-generic
    run-parts: executing /etc/kernel/postinst.d/pm-utils 2.6.35-22-generic /boot/vmlinuz-2.6.35-22-generic
    run-parts: executing /etc/kernel/postinst.d/update-notifier 2.6.35-22-generic /boot/vmlinuz-2.6.35-22-generic
    run-parts: executing /etc/kernel/postinst.d/zz-update-grub 2.6.35-22-generic /boot/vmlinuz-2.6.35-22-generic
    /etc/default/grub: 23: Syntax error: newline unexpected
    run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 2
    Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-2.6.35-22-generic.postinst line 1010.
    dpkg: error processing linux-image-2.6.35-22-generic (--configure):
     subprocess installed post-installation script returned error exit status 2
    Errors were encountered while processing:
     linux-image-2.6.35-22-generic
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  9. #9
    Join Date
    Nov 2008
    Beans
    20
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Updating linux-image-2.6.35-22-generic (2.6.35-22.34)


  10. #10
    Join Date
    Feb 2005
    Location
    Spain
    Beans
    149
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: Updating linux-image-2.6.35-22-generic (2.6.35-22.34)

    Thank you but that didn't fix the problem
    AMD Athlon 64 3000+ Core Venice
    Abit KN8-Ultra
    2x512 DDR400 Dual Channel (Geil kit)
    MSI NX6600GT-TD128
    SB X-FI XM

    ASUS A4K Laptop
    AMD Athlon 64 mobile 3200+
    2*256 DDR 400
    Mobo ASUS Nforce3-150
    Ati Radeon Mobility 9700

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •