Results 1 to 10 of 482

Thread: Making Ubuntu Fast using RAM (updated and simplified)

Threaded View

  1. #8
    Join Date
    May 2008
    Location
    Edmonton, Canada
    Beans
    Hidden!

    Re: Making Ubuntu Insanely Fast using RAM (updated and simplified)

    Quote Originally Posted by yesrno View Post
    Hmmm so I tried your script out, but at some point it was asking me to choose between 3 options - where to store the home folder. So I entered a 2, which would be for choosing a disk manually, but when I entered 2 the scripts started doing all kinds of things and at one point I saw it copying my home folder to somewhere (?) and then I saw it was trying to copy all my VM disks and I canceled the script . I ran the un-installer and it says it's un-installed but when I run the script again, it says the only option is to un-uninstall !
    Thanks for your feedback. I'll take a look. A few things could help me out though, if you don't mind:

    1. What OS did you run this script on? 10.04? 10.10?
    2. What is the layout of your filesystems on the OS you ran it on? Is your /home on the same partition as your '/'?
    3. How far did the script get in asking you questions before it started to copy your /home after you chose to enter the device manually? Normally, after you choose 2, it will ask which device you want to use for /home. It will then verify that the device is valid, make sure it's empty (or ask you to empty it if it finds files on it), it will format it, and it will copy your current /home to that device. So copying the files you have in your old /home to the new device is done by design in order for you to have access to your old /home in the RAM Session. There would be a problem with the script if it somehow jumped the gun and as soon as you hit option 2, it started to copy your /home to a device you haven't chosen yet. Are you saying this is what happened? If so, where did the files get copied to?


    As for the uninstall not working, that is incredibly strange. The way the script determines if it ran before is a file called /Original_OS. When the script runs normally, it makes sure the file doesn't exist before it continues. If it doesn't, the script keeps running and this file is created. When the script is launched again, it checks for the file again, but this time when it finds it, it tells you that the script ran before, and asks if you want to uninstall. The uninstall function removes the /Original_OS file (along with anything else the script may have done). The uninstall function is one of the simplest functions within the entire script, and looking at it now, I don't see where I could have messed it up. Does the /Original_OS file exist on your original OS? If it does, run "RAM_booster.sh --uninstall" and check again. Is it not being removed? The line within the uninstall function that removes that file is "sudo rm -f /Original_OS", which means it's removing it as root. That means it should pretty much never fail. Are you sure you didn't just run the script as "RAM_booster.sh --uninstall" again?
    Last edited by terminator14; December 7th, 2010 at 09:45 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •