Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: kslowd causing periodic system lag

  1. #1
    Join Date
    Feb 2007
    Location
    Aberystwyth, UK
    Beans
    44
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    kslowd causing periodic system lag

    I just upgraded to 10.10 and am finding that the processes kslowd00* seem to be generating a great deal of lag when they run about every 15-20 seconds. It is affecting mouse movement, which stutters, and typing, which causes errors in the document - primarily missing letters.

    Is there any known fix to this problem?

  2. #2
    Join Date
    Oct 2010
    Beans
    1

    Re: kslowd causing periodic system lag

    Same problem here since updating to 10.10.

    Maybe those with the problem should say something about their hardware.

    I have a Dell Latitude D505 which runs a 1.5 GHz Pentium M processor. /proc/cpuinfo says it's CPU family 6, model 9.
    My graphics card is an 855GM from intel which already caused lots of problems, maybe it is involved here, too.

    Please post any news if you something on this topic.

  3. #3
    Join Date
    Jun 2009
    Beans
    2
    Distro
    Kubuntu 10.10 Maverick Meerkat

    Re: kslowd causing periodic system lag

    Hi!
    I also had this problem. Accordning to:
    https://bbs.archlinux.org/viewtopic.php?id=105113
    it is kernel related. I downgraded to kernelversion 2.6.32-25, and the problem disappeared.

    /Tomas Persson

  4. #4
    Join Date
    Jan 2010
    Beans
    1

    Re: kslowd causing periodic system lag

    I experience the same problem anf filed a bug report:

    https://bugs.launchpad.net/ubuntu/+s...ux/+bug/661012

    May I suggest you confirm info about your problem and your hardware over there? Please note that you can easily do that with the command:

    apport-collect 661012

  5. #5
    Join Date
    Jun 2009
    Beans
    2
    Distro
    Kubuntu 10.10 Maverick Meerkat

    Re: kslowd causing periodic system lag

    "apport-collect 661012" does not seem to work:

    ''You are not the reporter or subscriber of this problem report, or the report is a duplicate or already closed.

    Please create a new report using "apport-bug".''

  6. #6
    Join Date
    Jan 2007
    Location
    Ridgeland WI US
    Beans
    462
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: kslowd causing periodic system lag

    I just installed Ubuntu 10.10 on a Gateway 4024 Laptop. lshw shows it has:
    display: VGA compatible, product: 82582/855GM Integrated Graphics Device

    With the fresh install of Ubuntu 10.10 I get kernel 2.6.35-22 This gives me the kslowd00x problem.

    So I downloaded and tried a 2.6.34 and a 2.6.36 kernel.
    Here is my comparison using top. I booted each kernel, opened a terminal window ran top and left it running for 15 minutes. Here are the loads:
    2.6.35-22 - - - - uptime 15 min - load average 0.66 0.60 0.46
    2.6.34-02063401 - uptime 15 min - load average 0.00 0.02 0.04
    2.6.36-020636 - - uptime 15 min - load average 0.14 0.25 0.18

    So I'm sticking with the "34" kernel.

    Here is how I installed the kernels:
    http://kernel.ubuntu.com/~kernel-ppa/mainline/
    then I chose v2.6.34.1-maverick/
    then download three kernel packages
    linux-headers-2.6.34-02063401-generic_2.6.34-02063401_i386.deb
    linux-headers-2.6.34-02063401_2.6.34-02063401_all.deb
    linux-image-2.6.34-02063401-generic_2.6.34-02063401_i386.deb
    to somewhere/ (somewhere where there are no other linux* files)
    I followed
    http://thanhsiang.org/faqing/node/129
    Then open a terminal window
    $ sudo su
    # cd somewhere/
    # dpkg -i linux-*
    I'm still working on the hold part...
    reboot
    GRUB will list highest kernel first so arrow down to get to "34".
    I get a side effect. Now when it boots it complains of a low memory error. It didn't before and doesn't with kernel 35.
    Gigabyte GA-MA790GPT-UD3H - AMD Phenom II x3 720 - 8 GB RAM - 2009 - My first PC from parts!

  7. #7
    Join Date
    Sep 2008
    Beans
    Hidden!

    Re: kslowd causing periodic system lag

    So this is what's causing my system slow down and stuttery mouse! Ugh!

  8. #8
    Join Date
    Jan 2007
    Location
    Ridgeland WI US
    Beans
    462
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: kslowd causing periodic system lag

    OK so here's how I locked the version
    In Synaptic Package Manager, search for the software that you don't want to be upgraded, select it & go to Package & then check the box Lock Version
    The color scheme was yuck so I changed it with Settings -> Preferences -> "Colors" tab then to a lighter red so I could read it.
    Thank you to
    http://ubuntuforums.org/showthread.php?t=1321582
    Post #4 - scouser73

    I'm hoping that locking the version also stops the auto overwrite of /boot/grub/grub.cfg. I edit it like I want it.
    Gigabyte GA-MA790GPT-UD3H - AMD Phenom II x3 720 - 8 GB RAM - 2009 - My first PC from parts!

  9. #9
    Join Date
    Jan 2007
    Location
    Ridgeland WI US
    Beans
    462
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: kslowd causing periodic system lag

    This is interesting.
    http://linux.derkeiler.com/Mailing-L.../msg05199.html
    Theodore Ts'o was asking why kslowd was eating 16% of his CPU.
    He started asking in June when he updated to Ubuntu Lucid - kernel 2.6.35-rc2
    Gigabyte GA-MA790GPT-UD3H - AMD Phenom II x3 720 - 8 GB RAM - 2009 - My first PC from parts!

  10. #10
    Join Date
    Mar 2006
    Beans
    45

    Re: kslowd causing periodic system lag

    We have a squid server running maverick. Slow ssh logins and top showing kslowd001 interrupting work. I believe the server is a IBM X306m but i may be wrong. Our other IBM squid server works fine.

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •