Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24

Thread: Pommed and brightness control not working

  1. #11
    Join Date
    Sep 2010
    Beans
    22

    Re: Pommed and brightness control not working

    @_mario_:
    My driver must not be loaded correctly. Terminal tells me there is no such file or directory as "/sys/class/mbp_backlight/brightness"

    Maybe thats the root of my problem. Any advice on checking if my driver is loaded correctly?]

    Edit:
    after looking through some older forum posts (From late 08/early 09) I saw a tip to try running
    sudo rmmod mbp_nvidia_bl
    sudo modprobe mbp_nvidia_bl

    cat /sys/class/backlight/mbp_backlight/brightness

    in the terminal. Problem occurred when terminal returned ERROR: Module mbp_nvidia_bl does not exist in /proc/modulesupdated it back to the latest version, and am about to restart and see if I still get said errors
    I just

    Edit 2:
    Still nothing. Same error occurs both with echo and rmmod
    Last edited by khronoslynx; October 12th, 2010 at 10:45 PM. Reason: updated progress

  2. #12
    Join Date
    Jan 2007
    Beans
    17

    Re: Pommed and brightness control not working

    Same issue here. I am about to re-install Maverick (now that it's in official release) and try again. After updating the RC I was unable to regain brightness control; I hadn't tried the previously-mentioned steps yet, but I will if it's still broken.

  3. #13
    Join Date
    Sep 2010
    Beans
    22

    Re: Pommed and brightness control not working

    I now have the brightness keys to change the brightness "bar" but not the actual LCD brightness. Echoing values to /sys/class/mbp_backlight/brightness still produces the same error
    Last edited by khronoslynx; October 14th, 2010 at 07:17 AM.

  4. #14
    Join Date
    Jul 2008
    Beans
    2

    Re: Pommed and brightness control not working


  5. #15
    Join Date
    Oct 2010
    Beans
    2

    Re: Pommed and brightness control not working

    Hello,

    I have maverick (2.6.35-23-generic) installed on my alu iMac 9,1, with a nVidia graphic card: GeForce 9400.

    I am struggling for 2 weeks now because I can't decrease the brightness of my screen...
    I installed mbp-nvivia-bl-dkms from mactel ppa, but I am not able to load the mbp_nvidia_bl module...

    Code:
    sudo modprobe mbp_nvidia_bl
    FATAL: Error inserting mbp_nvidia_bl (/lib/modules/2.6.35-23-generic/updates/dkms/mbp_nvidia_bl.ko): No such device
    Although, my /sys/class/backlight/ directory is empty...

    What should I try next?

    Thank you very much guys for any help you can provide...

  6. #16
    Join Date
    Jul 2008
    Beans
    245
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Pommed and brightness control not working

    Quote Originally Posted by kokoklems View Post
    I have maverick (2.6.35-23-generic) installed on my alu iMac 9,1, with a nVidia graphic card: GeForce 9400.
    the driver doesn't support iMac models and, hence, doesn't load. in fact, we don't know whether the driver works on this machine at all. i can provide a patched version, if you like to try.

    ciao,
    Mario

  7. #17
    Join Date
    Oct 2010
    Beans
    2

    Re: Pommed and brightness control not working

    Indeed, I would like to give it a try if possible. Thank you for your help. Hope it will work...

  8. #18
    Join Date
    Jul 2008
    Beans
    245
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Pommed and brightness control not working

    Quote Originally Posted by kokoklems View Post
    Indeed, I would like to give it a try if possible. Thank you for your help. Hope it will work...
    sorry, i almost forgot this thread. but if you still like to test, i attached a small program, that implements the same interfaces the driver uses. you can compile it like this:
    Code:
    $ gunzip apple-backlight.cpp.gz
    $ c++ apple-backlight.cpp -o apple-backlight
    then run:
    Code:
    $ sudo ./apple-backlight <OPTIONS>
    where <OPTIONS> contains which interface to test (--nvidia should work) as well as --get or --set <VALUE>.

    also, did you try to use the nvidia_bl driver? please note: installing both drivers is no problem, but mbp_nvidia_bl will not auto-load anymore (which doesn't matter since it doesn't support your machine anyway).

    ciao,
    Mario
    Attached Files Attached Files

  9. #19
    Join Date
    Jul 2007
    Beans
    8

    Re: Pommed and brightness control not working

    Hi Mario, I have exactly the same problem as described in te current thread after 10.10 install on macbook pro 6.2:
    sudo modprobe mbp_nvidia_bl
    FATAL: Error inserting mbp_nvidia_bl (/lib/modules/2.6.35-24-generic/kernel/drivers/video/backlight/mbp_nvidia_bl.ko): No such device
    and also with
    nvclock -Sf 10
    Unable to shadow the video bios
    It seems your card isn't officialy supported in NVClock yet.
    The reason can be that your card is too new.
    If you want to try it anyhow [DANGEROUS], use the option -f to force the setting(s).
    NVClock will then assume your card is a 'normal', it might be dangerous on other cards.
    Also please email the author the pci_id of the card for further investigation.
    [Get that value using the -i option].

    your tool does the job correctly. Is it integrated into ubuntu already, so the keyboard brightness control works? How do I merge it into my installation (everything is up to date now)?
    Thanks!

  10. #20
    Join Date
    Dec 2010
    Beans
    15

    Re: Pommed and brightness control not working

    Thanks for the link provided, I found it quite helpful for me as It carries few similar solutions that I required for myself.

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •