Page 1 of 6 123 ... LastLast
Results 1 to 10 of 59

Thread: GeForce4 MX 440 Not Supported in Maverick Meerkat 10.10 Upgrade?

  1. #1
    Join Date
    May 2009
    Beans
    127

    GeForce4 MX 440 Not Supported in Maverick Meerkat 10.10 Upgrade?

    Hi,

    I updated my Dell Dimension 8300 from 10.04 this morning. I tried to boot up after the restart, and got pages and pages of text. So I did a bunch of research here and elsewhere all day long..

    I tried Startx command at the prompt
    [username]@username-desktop:~$

    And got the typical error messages I have seen posted...
    Basically:
    (EE) Failed to load /usr/lib/xorg/extra~modules/nVidia-drv.so
    (EE) Failed to load module "nvidia" (loader failed, 7)
    (EE) No drivers available
    Fatal server error: no screens found
    Please consult the The X.Org FOundation support at http://wiki.x.org for help
    Please also check the log file at "/var/log/Xorg.0.log" for additional information

    ddxSigGiveUp: Closing log
    Xinit: No such file or directory (errno2): unable to connect to X server
    X init: no such process (error 3): server error

    So I used grub and a lower version to log in after rebooting.
    I used the lower graphics and got the screen. I uninstalled and re-installed
    nvidia-current
    Then rebooted.
    Same problems.
    I searched the Nvidia site and according to their site
    http://www.nvidia.com/object/IO_32667.html
    "The following GPUs are no longer supported in the regular NVIDIA Unified UNIX Graphics Driver. Instead, these GPUs will continue to be supported through special "Legacy GPU" drivers that will be updated periodically to add support for new versions of Linux system components (e.g., new Linux kernels, new versions of the X server, etc)."

    The version apparently that will support my card is The 96.43.xx driver
    They also recommend using the open source version supplied in the distribution.

    So my question is...

    1. Is there such a driver existing or coming for Maverick Meerkat 10.10
    Or...
    2. If not, is there a good work around anyone can suggest.

    Thanks for your help and advice... I have been at this since 9am and it is now 8:18 pm
    It's kind of frustrating if you know what I mean.

  2. #2
    Join Date
    Oct 2009
    Location
    Elgin, IL USA
    Beans
    2,534
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: GeForce4 MX 440 Not Supported in Maverick Meerkat 10.10 Upgrade?

    Apparently nvidia 96 and 173 did not work with the new 1.9 X server earlier. Not sure if the 173 version that now works is in the repos yet, but I they are still working on the 96 version. So it should be available eventually.

    Until then you will have to use whatever works nouveau or nv.

  3. #3
    Join Date
    May 2009
    Beans
    127

    Re: GeForce4 MX 440 Not Supported in Maverick Meerkat 10.10 Upgrade?

    Hi efflandt,

    Thank you for your reply.

    How would I use nouveau or nv
    I know some things, but am not familiar with these terms.

    Right now I am able to log in and getting a really sucky resolution.
    I had a look at NVIDIA X Server settings in
    System > Preferences and got the following message:

    "ubuntu maverick You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server."

    I am totally confused at this point. And if there is an update coming, and I modify settings now then when the update comes will I be in bad shape and have to change all sorts of settings manually?

    Thanks in advance for any advice and/or insight.

  4. #4
    Join Date
    Sep 2010
    Location
    Metro Detroit
    Beans
    2
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: GeForce4 MX 440 Not Supported in Maverick Meerkat 10.10 Upgrade?

    I'm seeing the same error message -- I'm also running the GeForce4MX440 on an older Dell. I rolled back to 10.04, and the -96 driver loads and runs OK again. I guess I'll hold off on upgrading back to 10.10 until I hear that the legacy GPU drivers are running OK.

    Or, I break down and buy a new graphics card for my ancient PC... nah.

  5. #5
    Join Date
    May 2010
    Location
    Harderwijk, Netherlands
    Beans
    3
    Distro
    Kubuntu 10.10 Maverick Meerkat

    Re: GeForce4 MX 440 Not Supported in Maverick Meerkat 10.10 Upgrade?

    I'm experiencing the same problem here.
    The guy at Nvidia said he's working (or gonna, can't really tell) on the 96-drivers. http://www.nvnews.net/vbulletin/show...33&postcount=5
    Last edited by dreamCatalyst; October 11th, 2010 at 04:11 PM. Reason: i learned something about downgrading today

  6. #6
    Join Date
    Oct 2010
    Beans
    1

    Re: GeForce4 MX 440 Not Supported in Maverick Meerkat 10.10 Upgrade?

    Might not be perfect but good enough for me:

    sudo su to become root
    run nvidia-xconfig (this was in: /usr/lib/nvidia-96/bin/nvidia-xconfig)
    go into /etc/X11/xorg.conf - I used vi
    modify driver from nvidia to nv - in my case this was on line 94
    save file
    run startx
    when ok - reboot machine - should go straight into your x-windows session

    Resolution either 1600X1200 or 1400X1050
    Screendept 16

    Machine is a Dell Latitiude 840C

  7. #7
    Join Date
    May 2008
    Location
    Sheffield. UK
    Beans
    22
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: GeForce4 MX 440 Not Supported in Maverick Meerkat 10.10 Upgrade?

    Quote Originally Posted by dreamCatalyst View Post
    I'm experiencing the same problem here.
    The guy at Nvidia said he's working (or gonna, can't really tell) on the 96-drivers. http://www.nvnews.net/vbulletin/show...33&postcount=5
    This is the wrong way around, it's not Nvidia's problem.
    The drivers are ok, they worked fine, it's Maverick that's the problem, or more accurately, Xorg.

  8. #8
    Join Date
    Feb 2005
    Location
    Arizona
    Beans
    1

    Re: GeForce4 MX 440 Not Supported in Maverick Meerkat 10.10 Upgrade?

    Quote Originally Posted by antoinem01 View Post
    ...
    run nvidia-xconfig (this was in: /usr/lib/nvidia-96/bin/nvidia-xconfig)
    go into /etc/X11/xorg.conf - I used vi
    modify driver from nvidia to nv - in my case this was on line 94
    save file
    ...
    This worked out great for me. I have an old MX 440 and just a little change to the driver name is all it took.

    THANK YOU

  9. #9
    Join Date
    May 2010
    Beans
    19

    Re: GeForce4 MX 440 Not Supported in Maverick Meerkat 10.10 Upgrade?

    Quote Originally Posted by antoinem01 View Post
    Might not be perfect but good enough for me:

    sudo su to become root
    run nvidia-xconfig (this was in: /usr/lib/nvidia-96/bin/nvidia-xconfig)
    go into /etc/X11/xorg.conf - I used vi
    modify driver from nvidia to nv - in my case this was on line 94
    save file
    run startx
    when ok - reboot machine - should go straight into your x-windows session

    Resolution either 1600X1200 or 1400X1050
    Screendept 16

    Machine is a Dell Latitiude 840C

    Not working for me GeForce 3 Ti 200
    When I run startx I see this:*


    Fatal server error:
    Server is already active for display 0
    If this server is no longer running, remove /tmp/.X0-lock
    and start again.


    Please consult the The X.Org Foundation support
    at http://wiki.x.org
    for help.

    *ddxSigGiveUp: Closing log



    Reboot, and I still haven't desktop effects.

  10. #10
    Join Date
    Apr 2007
    Location
    Winnipeg, Manitoba
    Beans
    55
    Distro
    Kubuntu 10.10 Maverick Meerkat

    Re: GeForce4 MX 440 Not Supported in Maverick Meerkat 10.10 Upgrade?

    Quote Originally Posted by spcagigas View Post
    I'm seeing the same error message -- I'm also running the GeForce4MX440 on an older Dell. I rolled back to 10.04, and the -96 driver loads and runs OK again. I guess I'll hold off on upgrading back to 10.10 until I hear that the legacy GPU drivers are running OK.
    I knew there was a reason I was holding off on Maverick for a while. I ran into the same issue on Maverick beta and although I would really like to get my hands on Lubuntu-core for my Medion 2900 (rebadged Gateway m500) I'm not willing to sacrifice stability and a decent resolution for new hotness.

    I kinda got tired of the upgrade breakages. Can you tell?
    Desktop - AMD Sempron 1.6 Ghz, 1 GB RAM, 1 TB HD, Kubuntu 11.04
    Laptop - Intel Celeron 1.3 GHz, 512 MB RAM, 30 GB HD, Lubuntu 11.04 + Lubuntu PPA

Page 1 of 6 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •