I updated my Dell Dimension 8300 from 10.04 this morning. I tried to boot up after the restart, and got pages and pages of text. So I did a bunch of research here and elsewhere all day long..

I tried Startx command at the prompt

And got the typical error messages I have seen posted...
(EE) Failed to load /usr/lib/xorg/extra~modules/nVidia-drv.so
(EE) Failed to load module "nvidia" (loader failed, 7)
(EE) No drivers available
Fatal server error: no screens found
Please consult the The X.Org FOundation support at http://wiki.x.org for help
Please also check the log file at "/var/log/Xorg.0.log" for additional information

ddxSigGiveUp: Closing log
Xinit: No such file or directory (errno2): unable to connect to X server
X init: no such process (error 3): server error

So I used grub and a lower version to log in after rebooting.
I used the lower graphics and got the screen. I uninstalled and re-installed
Then rebooted.
Same problems.
I searched the Nvidia site and according to their site
"The following GPUs are no longer supported in the regular NVIDIA Unified UNIX Graphics Driver. Instead, these GPUs will continue to be supported through special "Legacy GPU" drivers that will be updated periodically to add support for new versions of Linux system components (e.g., new Linux kernels, new versions of the X server, etc)."

The version apparently that will support my card is The 96.43.xx driver
They also recommend using the open source version supplied in the distribution.

So my question is...

1. Is there such a driver existing or coming for Maverick Meerkat 10.10
2. If not, is there a good work around anyone can suggest.

Thanks for your help and advice... I have been at this since 9am and it is now 8:18 pm
It's kind of frustrating if you know what I mean.