Results 1 to 10 of 12

Thread: language switcher in Lubuntu

Hybrid View

  1. #1
    Join Date
    Aug 2007
    Location
    Cairo
    Beans
    582
    Distro
    Xubuntu 12.04 Precise Pangolin

    language switcher in Lubuntu

    I'm forced to run

    setxkbmap -option grp:switch,grp:alt_shift_toggle,grp_led:scroll us,ar

    every time I need to switch to writing in Arabic. After entering this command, I can use the language switcher in the taskbar (I'm in LUBUNTU).

    If I re-boot, the language switcher no longer works - the alternative would be to hit ALT+SHIFT, but that's gone too.

    Is there any way I can fix this? For some reason, in Lubuntu the Preferences>Keyboard options are very limited.

  2. #2
    Join Date
    Feb 2008
    Beans
    5,636

    Re: language switcher in Lubuntu

    Well, put the
    Code:
    setxkbmap -option grp:switch,grp:alt_shift_toggle,grp_led:scroll us,ar
    command in your autostart script.

  3. #3
    Join Date
    Aug 2007
    Location
    Cairo
    Beans
    582
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: language switcher in Lubuntu

    er...how do I do that?

  4. #4
    Join Date
    Feb 2008
    Beans
    5,636

    Re: language switcher in Lubuntu

    Code:
    ~/.config/openbox/autostart.sh

  5. #5
    Join Date
    Aug 2007
    Location
    Cairo
    Beans
    582
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: language switcher in Lubuntu

    afraid, it didn't work

    (in Lubuntu) if I type sudo leafpad ~/.config/openbox/autostart.sh

    I get an empty file...

    any idea?

  6. #6
    Join Date
    Feb 2008
    Beans
    5,636

    Re: language switcher in Lubuntu

    Obviously it didn't exist.
    Put
    Code:
    setxkbmap -option grp:switch,grp:alt_shift_toggle,grp_led:scroll us,ar
    in it, save and exit.
    Log out, log in and see if it works.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •