Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Video Processing -> Audio Out of Sync

  1. #1
    Join Date
    Jun 2010
    Beans
    13

    Video Processing -> Audio Out of Sync

    Whether I am ripping a dvd with k3b, or converting a .wmv file to .avi with mencoder, or messing with a file in kdenlive, the resulting video always has audio out of sync with the video! The original plays just fine (in mplayer, vlc, or in flash once I've uploaded it). The converted file is out of sync whether its in mplayer, vlc, or flash once uploaded. The only common thread is:

    Original (Source: DVD, Windows Laptop, Camcorder) -> Process on Linux -> Out of Sync.

    I'm running Ubuntu 10.04. What can I do? Thanks for your help!

    (Bonus! Also kdenlive won't let me convert to h264 for some reason, it did fine when I was running 9.x, what changed?)

  2. #2
    Join Date
    Sep 2006
    Location
    California
    Beans
    1,321
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Video Processing -> Audio Out of Sync

    I've had quite a problem making DVDs either with all of my home videos, or compiling various TV shows onto one disc. Audio slides in and out of sync on almost every video or episode.

    Anyhow, I'm looking at tovid right now to see if it indeed does a better job encoding. I just have one question: Which engine should I use, ffmpeg or mpeg2enc? Thanks.
    “Men are born ignorant, not stupid. They are made stupid by education.” -- Bertrand Russell

  3. #3
    Join Date
    Sep 2006
    Location
    California
    Beans
    1,321
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Video Processing -> Audio Out of Sync

    bumpalicious.
    “Men are born ignorant, not stupid. They are made stupid by education.” -- Bertrand Russell

  4. #4
    Join Date
    Sep 2006
    Location
    California
    Beans
    1,321
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Video Processing -> Audio Out of Sync

    I think I've discovered a curious little detail about the sync issue: The audio will be in perfect sync until a fade-to-black comes up (like a commercial for a TV show) and then the problem starts, and it takes a few minutes for the audio to slowly correct itself.

    What would black scenes have to do with the audio and video lining up properly? Bizarre, no?
    “Men are born ignorant, not stupid. They are made stupid by education.” -- Bertrand Russell

  5. #5
    Join Date
    Sep 2006
    Location
    California
    Beans
    1,321
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Video Processing -> Audio Out of Sync

    No ideas?
    “Men are born ignorant, not stupid. They are made stupid by education.” -- Bertrand Russell

  6. #6
    Join Date
    Sep 2006
    Location
    California
    Beans
    1,321
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Video Processing -> Audio Out of Sync

    I keep checking discs I've made with devede, QDVDAuthor and DVD Styler, and the same issue is always there: a loss of sync right after black scenes. No one has experienced this? No one can tell me why it's happening or what to do about it? Thanks in advance.
    “Men are born ignorant, not stupid. They are made stupid by education.” -- Bertrand Russell

  7. #7
    Join Date
    Sep 2006
    Location
    California
    Beans
    1,321
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Video Processing -> Audio Out of Sync

    I'm going to try re-encoding all of my vids to DVD-suitable mpeg files with WinFF before making my DVDs with (probably) devede. I'll post back to say if this worked. Seems like a lot of extra work, but if the results are good...
    “Men are born ignorant, not stupid. They are made stupid by education.” -- Bertrand Russell

  8. #8
    Join Date
    Aug 2009
    Beans
    824

    Re: Video Processing -> Audio Out of Sync

    I had a big problem trying to burn DVD/SVCD but got it working now.
    http://ubuntuforums.org/showthread.php?t=1620426

    use devede but make sure when adding the files you check "This is already a DVD/xCD suitable MPEG-PS file" under the file properties "advanced options" -> misc tab
    Now I re-encode most of my stuff as XVID because most DVD players can play that anyway and it's a lot smaller:

    Use this for the preset in winff:

    Code:
    -f avi -r 25 -vcodec libxvid -vtag DX50 -s 352x288 -aspect 4:3 -maxrate 1800k -b 1500k -qmin 3 -qmax 5 -bufsize 4096 -mbd 2 -bf 2 -flags +4mv -trellis -aic -cmp 2 -subcmp 2 -g 300 -acodec libmp3lame -ar 48000 -ab 128k -ac 2
    or for 16:9
    Code:
    -f avi -r 25 -vcodec libxvid -vtag DX50 -s 352x288 -aspect 16:9  -maxrate 1800k -b 1500k -qmin 3 -qmax 5 -bufsize 4096 -mbd 2 -bf 2  -flags +4mv -trellis -aic -cmp 2 -subcmp 2 -g 300 -acodec libmp3lame -ar  48000 -ab 128k -ac 2

  9. #9
    Join Date
    Sep 2006
    Location
    California
    Beans
    1,321
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Video Processing -> Audio Out of Sync

    Wow. I cannot tell you the difference that using WinFF ahead of time makes. Amazing. Now, if only there were some way to automate the process...

    The defaults on WinFF seem pretty good. Is there any particular reason I would want to use the settings you have posted here, amsterdamharu?
    “Men are born ignorant, not stupid. They are made stupid by education.” -- Bertrand Russell

  10. #10
    Join Date
    Aug 2009
    Beans
    824

    Re: Video Processing -> Audio Out of Sync

    Is there any particular reason I would want to use the settings you have posted here, amsterdamharu?
    I use 352x288 because I can't see the difference on my TV or small laptop screen anyway, the file size is smaller. The rest is the same.

    As for automation; in winff you can select options -> check display cmd line. When choosing convert it will show you the script, copy and paste that in a textfile called convert.sh. Comment out all the echo statements (replace echo with # echo). Then I convert the lot before going to bed or something where the last statement in the file is:
    Code:
    sudo shutdown now
    It will not ask me for a password because the last line in sudoers is:
    Code:
    myuser ALL=NOPASSWD: /sbin/shutdown
    You can only edit sudoers with the command:
    Code:
    sudo visudo
    Then exit with
    control + o
    enter
    control + x

    To start the script I log out of the gui, press control + alt + F1, stop gdm and start the script:
    Code:
    sudo service gdm stop
    bash convert.sh
    The next morning I can use devede to create a VCD or like I do now just leave it because my DVD player will play the AVI files from usb.
    Last edited by amsterdamharu; December 9th, 2010 at 06:15 AM.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •