Page 1 of 4 123 ... LastLast
Results 1 to 10 of 39

Thread: HOWTO: VLC + VAAPI in Maverick

  1. #1
    Join Date
    Jun 2005
    Beans
    55
    Distro
    Ubuntu 9.10 Karmic Koala

    HOWTO: VLC + VAAPI in Maverick

    I thought I would go over some of the basics. In a nutshell, most graphics chips made in the past couple of years now have the ability to accelerate h.264 and wmv3 at the very least through va-api and VLC in Maverick.

    Now, when you ask for VLC to be installed, va-api, which is called "libva", will be installed with it. That library then needs one of three possible video drivers to be present to work. Two of the three driver packages are already in Maverick too. They are vdpau-va-driver (for Nvidia chips) and i965-va-driver (for Intel chips). The third package, for ATI/AMD chips, is called xvba-video. You will have to go here:
    http://www.splitted-desktop.com/~gbe...ne/xvba-video/
    grab the latest package for your arch. Download and double-click it and it will offer to install itself.

    Now, to be clear, the proprietary nvidia and AMD drivers must be activated and in use for this to work on those platforms. The open-source drivers do not support video acceleration on Nvidia/AMD at this point in time. Only very new Intel hardware is supported, from the GMA4500 onwards.

    So to summarize -- If you have an nvidia graphics platform:

    Code:
    $sudo apt-get install vlc vdpau-va-driver
    VLC must be told to use va-api. Open VLC, click Tools>Preferences>Video, and check "Accelerated Video Output". Furthermore, video filters/effects and deinterlacing will be done by the CPU, so turn these off for maximum effect.

  2. #2
    Join Date
    Jun 2007
    Beans
    13,441

    Re: HOWTO: VLC + VAAPI in Maverick

    Tools>Preferences>Video, and check "Accelerated Video Output"
    That should be on vaapi or not, for vaapi it's enabled in 'Input and Codecs' - 'Use GPU acceleration'

    (I'd suggest d. checking in htop if it is providing any benefit, certainly possible w/ some sources & hardware compo's that cpu use will increase w/ vaapi

  3. #3
    Join Date
    Jun 2008
    Beans
    30

    Re: HOWTO: VLC + VAAPI in Maverick

    im having issues for some reason.. vlc is seg faulting..

    i installed vainfo

    getting this

    Code:
    libva: libva version 0.31.1
    Xlib:  extension "XFree86-DRI" missing on display ":0.0".
    libva: va_getDriverName() returns 0
    libva: Trying to open /usr/lib/dri/nvidia_drv_video.so
    Segmentation fault
    maverick 64bit
    nvidia 8600 GTS

  4. #4
    Join Date
    Jun 2008
    Beans
    30

    Re: HOWTO: VLC + VAAPI in Maverick

    seems like libva in the xorg edgers ppa isnt updated yet.. had to purge the ppa.. works now

  5. #5
    Join Date
    Oct 2010
    Beans
    5

    Re: HOWTO: VLC + VAAPI in Maverick

    I keep getting issues related to libva-glx being missing but I can't for the life of me find it anywhere. It doesn't seem to be in the repo when I apt-cache search it. Any ideas?

  6. #6
    Join Date
    Apr 2006
    Beans
    479
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: VLC + VAAPI in Maverick

    Quote Originally Posted by AdrianVeidt View Post
    Two of the three driver packages are already in Maverick too. They are vdpau-va-driver (for Nvidia chips) and i965-va-driver (for Intel chips). The third package, for ATI/AMD chips, is called xvba-video. You will have to go here:
    http://www.splitted-desktop.com/~gbe...ne/xvba-video/
    Thank you! This is exactly the information I needed. Now, off to try it...

    UPDATE: it doesn't work. When I run 'vainfo' it reports,
    Code:
    libva: libva version 0.31.0
    Xlib:  extension "XFree86-DRI" missing on display ":0.0".
    libva: va_getDriverName() returns -1
    vaInitialize failed with error code -1 (unknown libva error),exit
    Any suggestions? This is on Ubuntu 10.10 (AMD64) with an ATI 4200 and the latest Catalyst 10.10 (as provided automatically by the Ubuntu 'Hardware Drivers' installer)
    Last edited by bsmith1051; November 5th, 2010 at 01:52 AM.

  7. #7
    Join Date
    Oct 2010
    Beans
    317

    Re: HOWTO: VLC + VAAPI in Maverick

    Quote Originally Posted by sizeak View Post
    I keep getting issues related to libva-glx being missing but I can't for the life of me find it anywhere. It doesn't seem to be in the repo when I apt-cache search it. Any ideas?
    It's a little tougher with ATI/XvBA. You have to extract a couple files (libva-glx) out of the ATI Catalyst installer and use the libva from splitted-desktop. Even then, it's not perfect.

  8. #8
    Join Date
    Nov 2010
    Beans
    1

    Re: HOWTO: VLC + VAAPI in Maverick

    I also am attempting to get VA-API working in VLC on a Radeon 3200 integrated graphics chip. I also got the error :

    Code:
    libva: libva version 0.31.0
    Xlib:  extension "XFree86-DRI" missing on display ":0.0".
    libva: va_getDriverName() returns -1
    vaInitialize failed with error code -1 (unknown libva error),exit
    I was able to fix that error from vainfo by installing libva1 from http://www.splitted-desktop.com/~gbeauchesne/libva/pkgs/amd64/ over top of the ubuntu package, but when I run vlc from Termial, I get the same "libva: va_getDriverName() returns -1" what could still be causing that?


  9. #9
    Join Date
    May 2007
    Location
    Vermont
    Beans
    869
    Distro
    Ubuntu

    Re: HOWTO: VLC + VAAPI in Maverick

    bump, I get the same error as the post above trying to get this working with an ati card using fglrx 10.11, ubuntu 10.10 64 bit, radeon hd2600.
    Desktop: Windows 8 x64 | Intel Core i5-2500 | 16 GB DDR3 1333 | ATI 6950 2gb | 64gb Vertex 2/320gb/750gb/1tb hdd
    Laptop: System76 Lemur Ultra | Xubuntu 13.04 x64 | 2.5Ghz Intel Core i5-3210m | 8GB DDR31600 | Intel HD4000 | 500GB 7200rpm hybrid hdd

  10. #10
    Join Date
    Apr 2006
    Beans
    479
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: VLC + VAAPI in Maverick

    Quote Originally Posted by screaminj3sus View Post
    bump, I get the same error as the post above trying to get this working with an ati card using fglrx 10.11, ubuntu 10.10 64 bit, radeon hd2600.
    I don't think you can do it with your hardware? I thought that only the HD3x00 series (on up) were supported for h.264 acceleration. I might be wrong, though, so check around.

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •