Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Problem with ati amd proprietary fglrx graphics driver

  1. #1

    Problem with ati amd proprietary fglrx graphics driver

    I installed Ubuntu 10.10 via wubi, installed the ati amd proprietary fglrx graphics driver as prompted, and lost GUI.

    Under command line, I tried to do startx, however I got fatal server error: no screens found

    Now I reinstalled Ubuntu, and I'm not sure if I should install that again.

    Also I have a switchable graphics (ati hd5650 and intel 4500, not too sure about the intel one's model number), can i activate that?

    Also I'm having problems with CPU temperatures. CPU temperature is almost always at 77C. Under windows that number is usually only around 50, if not 40 when idling or browsing.
    Last edited by ultimatebuster; October 3rd, 2010 at 11:15 PM.

  2. #2
    Join Date
    Feb 2010
    Beans
    20

    Re: Problem with ati amd proprietary fglrx graphics driver

    Do you by any chance have a hp dv6?? I do, and it has the 5650, and the intel. I have the same problem as you. Just don't install the drivers, it is using the intel by default and for some reason asking you to install drivers for the ati... Just leave it, its not important for web browsing, watching movies etc.

  3. #3
    Join Date
    Sep 2008
    Beans
    8

    Re: Problem with ati amd proprietary fglrx graphics driver

    I've had the exact same problem, but I found out that you can simply write

    Code:
    sudo apt-get remove fglrx
    This worked for me. If it doesn't work, then try

    Code:
    sudo apt-get remove xorg-driver-fglrx
    and restart.

    There's (fortunately) no need to do a complete Ubuntu reinstall

  4. #4

    Re: Problem with ati amd proprietary fglrx graphics driver

    Mine is a Lenovo Y460. Also another problem is the two finger scrolling. Doesn't work for me even with gsynapics.

    and does that mean there's no driver for ati? Only intel?
    Last edited by ultimatebuster; October 10th, 2010 at 07:30 PM.

  5. #5

    Re: Problem with ati amd proprietary fglrx graphics driver

    *sigh*
    This probably means i have to go back to win again.

  6. #6
    Join Date
    Aug 2008
    Beans
    1,835
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Problem with ati amd proprietary fglrx graphics driver

    Quote Originally Posted by ultimatebuster View Post
    *sigh*
    This probably means i have to go back to win again.

    After installing the ATI blob always do this as a matter of course before restarting:


    Code:
    sudo aticonfig --initial -f

  7. #7
    Join Date
    Oct 2010
    Beans
    2

    Re: Problem with ati amd proprietary fglrx graphics driver

    I know this does not solve the problem with switchable graphics but to get the proprietary drivers working, change bios setting "Graphic Mode" from "Switchable" to "Discreet".

    I have verified that the proprietary AT drivers to work (instead of getting a black screen) in Ubuntu 10.10 on a Acer TimelineX 3820TG.

    Eagerly awaiting a solution to the problem with switchable graphics.

  8. #8

    Re: Problem with ati amd proprietary fglrx graphics driver

    Yeah I don't want to set to discrete as I want that switchable capability under windows when I do use it.

  9. #9
    Join Date
    Dec 2009
    Location
    Southern Maryland
    Beans
    1,575
    Distro
    Ubuntu

    Re: Problem with ati amd proprietary fglrx graphics driver

    Why go back to Windows when you can just go back to 10.04? Or did fglrx not work there for you either?

  10. #10
    Join Date
    Aug 2008
    Location
    Guaynabo, PR
    Beans
    593
    Distro
    Kubuntu 11.04 Natty Narwhal

    Re: Problem with ati amd proprietary fglrx graphics driver

    Quote Originally Posted by ultimatebuster View Post
    Yeah I don't want to set to discrete as I want that switchable capability under windows when I do use it.
    Why would you switch on windows to Intel GFX? Isn't that ATI way better than it?
    Desktop Build mobo: MSI 790FX-GD70 | cpu: Phenom ii x4 965BE C3 @ 4.02Ghz | gfx: Sapphire + XFX 5770 CrossfireX + EVGA 9800GTX+
    ram: 8gb DDR3-1333Mhz | hd: 1TB (Windows 7 Ultimate x64) + 500gb (Snow Leopard 10.6.7) + 400gb (Kubuntu 11.04 x64)

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •