Page 5 of 6 FirstFirst ... 3456 LastLast
Results 41 to 50 of 51

Thread: reboot instead of resume from suspend

  1. #41
    Join Date
    Nov 2007
    Location
    UK
    Beans
    32
    Distro
    Ubuntu Development Release

    Re: reboot instead of resume from suspend

    Nicely done, but that's too much hackery for me. I guess it's time to change distros. Too many regressions in Ubuntu these days for me, and it's taking far too much time to resolve issues. I guess I'm no longer the target for Ubuntu. Thanks.

  2. #42
    Join Date
    Oct 2010
    Beans
    2

    Re: reboot instead of resume from suspend

    I have a Sony Vaio VPCEB1Z1E and passing the option acpi_sleep=nonvs to the kernel solved the issue of rebooting instead of resuming from suspend. As you can read here problems started when was introduced (in 2.6.35-rc4) saving NVS area during suspend:
    http://www.spinics.net/lists/linux-acpi/msg29521.html

    So you need to modify /boot/grub/grub.cfg to pass that option to the kernel, like this:
    Code:
    menuentry 'Ubuntu, with Linux 2.6.35-22-generic' --class ubuntu --class gnu-linux --class gnu --class os {
            recordfail
            insmod part_msdos
            insmod ext2
            set root='(hd1,msdos5)'
            search --no-floppy --fs-uuid --set 5ae3fe0b-ef15-4af0-a452-71b09868467f
            linux   /boot/vmlinuz-2.6.35-22-generic root=UUID=5ae3fe0b-ef15-4af0-a452-71b09868467f ro   quiet splash acpi_sleep=nonvs
            initrd  /boot/initrd.img-2.6.35-22-generic
    }

  3. #43
    Join Date
    Mar 2010
    Beans
    9

    Re: reboot instead of resume from suspend

    Quote Originally Posted by auxbuss View Post
    Nicely done, but that's too much hackery for me. I guess it's time to change distros. Too many regressions in Ubuntu these days for me, and it's taking far too much time to resolve issues. I guess I'm no longer the target for Ubuntu. Thanks.
    Yeah, while trying to fix the suspend issue I managed to screw my Ubuntu installation. Had to add vmalloc option to grub config to get it to boot and now that I tried with NVIDIA 260.19.04 everything broke again. I hate this so much and the logs tell me absolutely nothing. Spent the last 12h trying to solve everything.

    Quote Originally Posted by pulmro View Post
    I have a Sony Vaio VPCEB1Z1E and passing the option acpi_sleep=nonvs to the kernel solved the issue of rebooting instead of resuming from suspend. As you can read here problems started when was introduced (in 2.6.35-rc4) saving NVS area during suspend:
    http://www.spinics.net/lists/linux-acpi/msg29521.html

    So you need to modify /boot/grub/grub.cfg to pass that option to the kernel, like this:
    Code:
    menuentry 'Ubuntu, with Linux 2.6.35-22-generic' --class ubuntu --class gnu-linux --class gnu --class os {
            recordfail
            insmod part_msdos
            insmod ext2
            set root='(hd1,msdos5)'
            search --no-floppy --fs-uuid --set 5ae3fe0b-ef15-4af0-a452-71b09868467f
            linux   /boot/vmlinuz-2.6.35-22-generic root=UUID=5ae3fe0b-ef15-4af0-a452-71b09868467f ro   quiet splash acpi_sleep=nonvs
            initrd  /boot/initrd.img-2.6.35-22-generic
    }
    Thanks for the find! Will try it ASAP

  4. #44
    Join Date
    Nov 2007
    Location
    UK
    Beans
    32
    Distro
    Ubuntu Development Release

    Re: reboot instead of resume from suspend

    acpi_sleep=nonvs is working for me, so far. Thanks.

    Interesting bug thread. I don't know anything about NVS, so many blanks in it, but I got the gist of it.

  5. #45
    Join Date
    Oct 2010
    Beans
    1

    Re: reboot instead of resume from suspend

    First, be sure your anti-virus software has the latest definitions and run a
    virus scan. If your system is clear of viruses, open Control Panel, open System, go to
    the Advanced tab, click Settings under Start-up and Recovery, remove the
    check from "Automatically Restart" under System Failure.

  6. #46
    Join Date
    Nov 2007
    Location
    UK
    Beans
    32
    Distro
    Ubuntu Development Release

    Re: reboot instead of resume from suspend

    Meant to say that the right place to add this, I believe, is /etc/default/grub rather than /boot/grub/grub.cfg, because the latter will be silently overwritten periodically.

  7. #47
    psusi is offline Ubuntu addict and loving it
    Join Date
    Sep 2005
    Location
    Orlando, FL
    Beans
    3,980
    Distro
    Ubuntu Development Release

    Re: reboot instead of resume from suspend

    Weird... NVS means non volatile storage, as in doesn't get lost during hibernate or suspend. The ACPI standard REQUIRES the kernel to save and restore it during suspend/hibernate.

  8. #48
    Join Date
    Feb 2007
    Beans
    20

    Re: reboot instead of resume from suspend

    The NVS hack works for me as well. I hope future kernel upgrades don't need this. I don't want to alter grub every time I pull a new kernel.

  9. #49
    psusi is offline Ubuntu addict and loving it
    Join Date
    Sep 2005
    Location
    Orlando, FL
    Beans
    3,980
    Distro
    Ubuntu Development Release

    Re: reboot instead of resume from suspend

    Quote Originally Posted by tgui View Post
    The NVS hack works for me as well. I hope future kernel upgrades don't need this. I don't want to alter grub every time I pull a new kernel.
    You won't have to if you added it to /etc/default/grub.

  10. #50
    Join Date
    Oct 2010
    Beans
    2

    Re: reboot instead of resume from suspend

    Quoting this kernel patch:
    To keep track of the systems that require
    this workaround and to make the life of their users slightly easier
    blacklist them in acpisleep_dmi_table[].
    So if we could get DMI_SYS_VENDOR & DMI_PRODUCT_NAME of our laptops and send them to kernel developers we could help building that list for next kernel versions.

Page 5 of 6 FirstFirst ... 3456 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •