Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Do ISO's really work with storage groups in .24?

  1. #1
    Join Date
    Apr 2008
    Beans
    21

    Do ISO's really work with storage groups in .24?

    I've been running 0.24 trunk for a while now with the hopes of using storage groups with ISO images. According to the current release notes it's in, and looking at the patch - it's been in for a while.

    But it still doesn't work for me... it seems to be looking at the correct path at first, but then fails.

    Does anyone have this working in 0.24 trunk? Any more info?

    Thanks.

  2. #2
    Join Date
    Jul 2007
    Beans
    77

    Re: Do ISO's really work with storage groups in .24?

    Quote Originally Posted by Slacker3k View Post
    Does anyone have this working in 0.24 trunk? Any more info?
    Works fine for me. But sounds like you are trying to play back encrypted DVDs. Myth supports ISOs via Storage Group just fine in trunk-- but libdvdcss (which is not a part of myth) has no knowledge of Myth's protocol. If your ISOs are all still encrypted, then then won't work via storage group. If you decrypt the content while you rip it, it'll play fine.

  3. #3
    Join Date
    Feb 2007
    Beans
    871
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Do ISO's really work with storage groups in .24?

    Quote Originally Posted by iamlindoro View Post
    Works fine for me. But sounds like you are trying to play back encrypted DVDs. Myth supports ISOs via Storage Group just fine in trunk-- but libdvdcss (which is not a part of myth) has no knowledge of Myth's protocol. If your ISOs are all still encrypted, then then won't work via storage group. If you decrypt the content while you rip it, it'll play fine.
    So does the decryption happen during the rip in mythtv when creating the ISO?

  4. #4
    Join Date
    Jul 2007
    Beans
    77

    Re: Do ISO's really work with storage groups in .24?

    Quote Originally Posted by williammanda View Post
    So does the decryption happen during the rip in mythtv when creating the ISO?
    No.

  5. #5
    Join Date
    Apr 2008
    Beans
    21

    Re: Do ISO's really work with storage groups in .24?

    I wish it were that easy. They are definitely not encrypted DVDs and I even checked again.

    It also has a problem with a DVD folder structure - so something is messed up.

    It's nice to know that at least someone has it working so it's worth my time to try.

    Thanks.

  6. #6
    Join Date
    Apr 2008
    Beans
    21

    Re: Do ISO's really work with storage groups in .24?

    Taking another pass at this since I really would like to get this working. I've now tested with a DVD that I created from home movies. Works fine outside of storage groups, when I use it in a storage group the screen goes blank for a minute, then I'm taken back to the MythVideo gallery.

    Any suggestions on what I could have wrong or how to troubleshoot? I'm running 0.24 fixes now...

  7. #7
    Join Date
    Mar 2007
    Location
    Christchurch, NZ
    Beans
    3,239

    Re: Do ISO's really work with storage groups in .24?

    Quote Originally Posted by Slacker3k View Post
    Taking another pass at this since I really would like to get this working. I've now tested with a DVD that I created from home movies. Works fine outside of storage groups, when I use it in a storage group the screen goes blank for a minute, then I'm taken back to the MythVideo gallery.

    Any suggestions on what I could have wrong or how to troubleshoot? I'm running 0.24 fixes now...
    *sigh* what do your frontend logs say?

  8. #8
    Join Date
    Apr 2008
    Beans
    21

    Re: Do ISO's really work with storage groups in .24?

    The frontend log - while attempting to play an ISO:

    libdvdnav: Using dvdnav version svnR1215
    libdvdread: Encrypted DVD support unavailable.
    libdvdread: Could not open input: No such file or directory
    libdvdread: Can't open myth://Videos@192.168.0.11:6543/Football-2007-08-27.iso for reading
    libdvdnav: vm: failed to open/read the DVD
    2010-11-16 17:51:18.321 Failed to open DVD device at myth://Videos@192.168.0.11:6543/Football-2007-08-27.iso
    2010-11-16 17:51:18.364 TV: Attempting to change from None to WatchingDVD
    libdvdnav: Using dvdnav version svnR1215
    libdvdread: Encrypted DVD support unavailable.
    libdvdread: Could not open input: No such file or directory
    libdvdread: Can't open myth://Videos@192.168.0.11:6543/Football-2007-08-27.iso for reading
    libdvdnav: vm: failed to open/read the DVD
    2010-11-16 17:51:18.380 Failed to open DVD device at myth://Videos@192.168.0.11:6543/Football-2007-08-27.iso

  9. #9
    Join Date
    Apr 2008
    Beans
    21

    Re: Do ISO's really work with storage groups in .24?

    Thought I'd check in one more time and see if anyone else is having this issue. I've tried many different ISO files including some that I made myself, and they all present the same symptoms.

  10. #10
    Join Date
    Apr 2006
    Beans
    Hidden!

    Re: Do ISO's really work with storage groups in .24?

    I have the same issue that ISOs in the Videos storage group will not play. My frontend log shows a different problem that it is trying to use VDPAU when I don't have an Nvidia chipset that supports it. The thing that crashes the frontend is some kind of audio problem:

    2010-12-18 20:13:29.786 [mp1 @ 0x7feb13c745e0]Header missing
    2010-12-18 20:13:29.786 AFD Error: Unknown audio decoding error

    I'm guessing that myth can't figure out the audio codec and the video rendering library to use.

    ISOs in an NFS mount directory play just fine.

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •