Results 1 to 7 of 7

Thread: Easy fix for gtk-RecordMyDesktop sound

  1. #1
    Join Date
    Jul 2007
    Beans
    98
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Wink Easy fix for gtk-RecordMyDesktop sound

    • Fixing the Gtk-RecordMyDesktop 'No Sound' issue.


    Since I was breaking my head figuring out how to fix the "Sound Issue" with the gtk-RecordMyDesktop, I should share with you guys this easy workaround.


    1. From here, you will install the 'PulseAudio Volume Control', so open you Terminal and let's get started.

    2. Once your Terminal is opened, do the following...
    3. Code:
      sudo apt-get install pavucontrol
    4. Once it's installed.. you may close your Terminal.
    5. Now open your gtk-recordmydesktop, and click Advanced to open the configuration window.
    6. Once it's opened click on the 'Sound' tab, and where it says Device change the value to: pulse, just like the screenshot below.


    Now you're done..

    Note: If it doesn't work, you may have to turn up the 'Capture' option in your Sound Mixer.

    Thanks
    Attached Images Attached Images

  2. #2
    Join Date
    Apr 2006
    Beans
    184

    Re: Easy fix for gtk-RecordMyDesktop sound

    Did not work for me in Kubuntu 10.10.

    The streams are all enabled, but the only audio that gtk-RecordMyDesktop gets is my microphone at a very faint, near-silent level. The same mic and settings works fine when I'm playing games like L4D2 under Wine, and the input looks great in the PA volume control.

    I get no application sounds in the output video at all, though they are all enabled in the mixer and play fine.

  3. #3
    Join Date
    Jul 2007
    Beans
    98
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Easy fix for gtk-RecordMyDesktop sound

    Quote Originally Posted by 3vi1 View Post
    Did not work for me in Kubuntu 10.10.

    The streams are all enabled, but the only audio that gtk-RecordMyDesktop gets is my microphone at a very faint, near-silent level. The same mic and settings works fine when I'm playing games like L4D2 under Wine, and the input looks great in the PA volume control.

    I get no application sounds in the output video at all, though they are all enabled in the mixer and play fine.
    Try to change the hardware in the PulseAudio volume Control by going in the Sound & Video.

  4. #4
    Join Date
    Apr 2006
    Beans
    184

    Re: Easy fix for gtk-RecordMyDesktop sound

    Quote Originally Posted by raafaell View Post
    Try to change the hardware in the PulseAudio volume Control by going in the Sound & Video.
    I don't follow... The hardware in the PulseAudio volume Control is already correct; everything looks fine there. Why would I want to change it and to what would I change it?

  5. #5
    Join Date
    Apr 2006
    Beans
    184

    Re: Easy fix for gtk-RecordMyDesktop sound

    Ohhh.... I get what you're saying now.... You mean to change the hardware in the recording stream.... [testing...]

  6. #6
    Join Date
    Jul 2007
    Beans
    98
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Easy fix for gtk-RecordMyDesktop sound

    Quote Originally Posted by 3vi1 View Post
    I don't follow... The hardware in the PulseAudio volume Control is already correct; everything looks fine there. Why would I want to change it and to what would I change it?
    There's the Recording section, and then there's the Output and Input section, start recording with you gtk-recordmydesktop, and try to change the hardware that show in it. That fixed for me.
    Last edited by raafaell; October 3rd, 2010 at 03:23 PM.

  7. #7
    Join Date
    Apr 2006
    Beans
    184

    Re: Easy fix for gtk-RecordMyDesktop sound

    I have it working now. Thank you very much for your assistance!

    There are several other problems that 10.10 users might run into that I'd like to add here to your informational post:

    #1: gtk-recordmydesktop is currently broken. I ran into bug 591995, and cannot get the program to start, even though it started fine in 10.04.

    Workaround: Use RecordItNow instead. It calls the same recordmydesktop back-end. Use the Configure|plugins|RecordMyDesktop options to set your sound to pulse as described above.

    #2: The libTheora in Maverick causes major degradation in recording performance. This is bug 578397. The problem is actually with the recordmydesktop package, which sets way too low of a bitrate. The new libTheora will cut the framerate back to fit the bitrate, no matter how high you set the FPS.

    I originally attempted to fix this by compiling a new version of recordmydesktop that used sane defaults (as provided by one of the Fedora devs). But, even with the new version, I found that it still performed poorly.

    Workaround: Add the karmic repos to your apt sources, force the version of libtheora0 down to the karmic version, then lock it to that version.

    Also, you will need to increase the bitrate setting in the RecordItNow options to a sane level, or you'll end up creating videos where VLC won't play them (or will only play a few seconds of audio) and Dragon player will play the video at a horrible FPS and have no audio.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •