Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: smplayer with vdpau has hiccups

  1. #1
    Join Date
    May 2008
    Location
    Adelaide, Australia
    Beans
    57
    Distro
    Xubuntu 10.04 Lucid Lynx

    smplayer with vdpau has hiccups

    I'm using Ubuntu 10.04 and have it hooked up to my HDTV. My GPU is an 8600 GT and I am using the current nvidia driver. Mother board is GIGABYTE GA-MA78GM-S2H, CPU is AMD 4850e, using 2x1G ram 800MHz.

    Everything I have installed on it comes straight through Synaptic. Smplayer seems to work fine with the VDPAU selected (cpu usage is nice and low during HD playback), but there is a slight problem that really annoys.

    Every 2-3 seconds the picture seems to have the hiccups, its as though it gets stuck on one frame for a split second and then jumps to the next.

    I'm looking for some suggestions to try and fix this.

  2. #2
    Join Date
    Nov 2009
    Beans
    1,879
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    Re: smplayer with vdpau has hiccups

    Do you have any desktop effects enabled? Try turning them off if so.

  3. #3
    Join Date
    Dec 2009
    Beans
    Hidden!
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: smplayer with vdpau has hiccups

    Did you install smplayer and mplayer from the ppa?
    The finding of unity in variety is really what we call knowledge..... Vivekananda.

  4. #4
    Join Date
    May 2008
    Location
    Adelaide, Australia
    Beans
    57
    Distro
    Xubuntu 10.04 Lucid Lynx

    Re: smplayer with vdpau has hiccups

    Quote Originally Posted by cchhrriiss121212 View Post
    Do you have any desktop effects enabled? Try turning them off if so.
    I've tried to enable/disable vsync already through compiz. I need vsync enabled, otherwise there is tearing.

  5. #5
    Join Date
    May 2008
    Location
    Adelaide, Australia
    Beans
    57
    Distro
    Xubuntu 10.04 Lucid Lynx

    Re: smplayer with vdpau has hiccups

    Quote Originally Posted by Linuxforall View Post
    Did you install smplayer and mplayer from the ppa?
    No, both of these through Synaptic.

  6. #6
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    8,914
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: smplayer with vdpau has hiccups

    Do you have the same problems viewing the videos with mplayer alone?

    If you have experience compiling software from source, I'd recommend building an mplayer binary from one of the daily source code releases at http://www.mplayerhq.hu/. In Ubuntu, you'll need to run "sudo apt-get install build-essential" and "sudo apt-get build-dep mplayer" to get the necessary tools and libraries.

    Another option is to add rvm's repositories and use his versions of mplayer and smplayer. (rvm is the author of SMPlayer.)
    Last edited by SeijiSensei; September 29th, 2010 at 09:57 PM. Reason: mplayer-nogui no longer exists; use "build-dep mplayer"

  7. #7
    Join Date
    Nov 2009
    Beans
    1,879
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    Re: smplayer with vdpau has hiccups

    Quote Originally Posted by misterspider View Post
    I've tried to enable/disable vsync already through compiz. I need vsync enabled, otherwise there is tearing.
    Try to actually turn them off, switch to metacity using CSM or go to preferences>appereance and select "none" in the effects tab.

  8. #8
    Join Date
    May 2008
    Location
    Adelaide, Australia
    Beans
    57
    Distro
    Xubuntu 10.04 Lucid Lynx

    Re: smplayer with vdpau has hiccups

    Thanks, I will try these options and report back.

  9. #9
    Join Date
    Dec 2006
    Beans
    6,977

    Re: smplayer with vdpau has hiccups

    There is another option:

    Howto: Build the svn MPlayer under the latest release version of Ubuntu
    http://ubuntuforums.org/showthread.php?t=1542240

    The writer of that guide is usually fairly approachable too .

    Andrew
    You think that's air you're breathing now?

  10. #10
    Join Date
    May 2008
    Location
    Adelaide, Australia
    Beans
    57
    Distro
    Xubuntu 10.04 Lucid Lynx

    Re: smplayer with vdpau has hiccups

    I'll give that a try too.
    Turning off desktop effects didn't solve it.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •