Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: pppd issue with sakis3g

  1. #11
    Join Date
    Oct 2009
    Location
    A world without windows
    Beans
    Hidden!

    Re: pppd issue with sakis3g

    Quote Originally Posted by ilhami View Post
    echo -e "AT+COPS?\r" > /dev/ttyUSB0
    +COPS: 0,0,"T-Mobile Austria",2

    echo -e "
    AT+COPS=?\r" > /dev/ttyUSB0
    +COPS: (2,"T-Mobile Austria","TMA","23203",2),(1,"3 AT","3 AT","23210",2),(3,"A1","A1","23201",2),(1,"T-Mobile Austria","TMA","23203",0),(3,"one","one","23205",0 ),(3,"A1","A1","23201",0),(3,"one","one","23205",2 ),,(0,1,2,3,4),(0,1,2)

    echo -e "AT+CGDCONT?\r" > /dev/ttyUSB0
    +CGDCONT: 1,"IP","gprsinternet","",0,0
    +CGDCONT: 2,"IP","business.gprsinternet","",0,0


    from the info

    +COPS: 0,0,"T-Mobile Austria",2 ( T-Mobile Austria is the registered provider )

    +COPS: (2,"T-Mobile Austria","TMA","23203",2),(1,"3 AT","3 AT","23210",2),(3,"A1","A1","23201",2),(1,"T-Mobile Austria","TMA","23203",0),(3,"one","one","23205",0 ),(3,"A1","A1","23201",0),(3,"one","one","23205",2 ),,(0,1,2,3,4),(0,1,2)

    the above shows T-Mobile have two connections available

    +CGDCONT: 1,"IP","gprsinternet","",0,0
    +CGDCONT: 2,"IP","business.gprsinternet","",0,0

    the above shows two APN's on the device ("gprsinternet" and "business.gprsinternet")

    The two plans may have different billing so from here it is important to select the correct APN , as
    you could pay more or denied a connection if the wrong APN is selected , and also some plans have what is called
    priority connections " I am assuming if your plan is "Business" then you may have special "Priorities",
    one of those could be, when, trying to get a connection then you may have a higher priority over someone
    who does not have special priorities,IE someone on a lesser plan may get bumped to give you the connection, since you
    have a Business plan , notable at times of heavy traffic on the Internet(on specific servers)

    one data-base of serviceproviders used by NM shows the below
    so did you have to manualy set the APN

    <name>T-Mobile</name>

    <gsm>
    <network-id mcc="232" mnc="07"/>
    <network-id mcc="232" mnc="03"/>

    <apn value="gprsinternet">
    <username>t-mobile</username>
    <password>tm</password>
    </apn>

    <apn value="web">
    <name>T-Mobile (formerly tele.ring)</name>
    <username>web@telering.at</username>
    <password>web</password>
    <dns>212.95.31.167</dns>
    <dns>212.95.31.168</dns>

    from the another data-base, info shows

    APN "gprsinternet" = Plan "internet" and "Username = t-mobile , Password = tm "
    APN "business.gprsinternet" = Plan "Buisiness Internet" and "Username = t-mobile , Password = tm "

    So on to the connection

    device dialing <cid> = "*99# = default *99***1#" = +CGDCONT: 1,"IP","gprsinternet","",0,0
    which is not your plan
    could indicate wrong APN may have been used at some stage "see details from first data-base"

    other device dialing <cid> = "*99***2#" = +CGDCONT: 2,"IP","business.gprsinternet","",0,0
    which is correct for your plan

    open up the first terminal and enter this code

    Code:

    tr -s "\n" < /dev/ttyUSB0

    open up second terminal and enter the following codes

    Codes:

    echo -e "ATZ\r" > /dev/ttyUSB0

    echo -e "AT+CGDCONT=1,\"IP\" \"business.gprsinternet\"\r" > /dev/ttyUSB0

    echo -e "ATDT*99#\r" > /dev/ttyUSB0


    wait a second to ensure the "No carrier" message does not appear , if it does redial the number
    at this point you may see in the first terminal "Connect" or "Connect <number>"

    also note it is possible to dial the <cid> with this command " ATDT*99***2# " and avoid loading the CGDCONT=1 IE :the Line could be omitted

    assuming there is a "Connect" message

    enter this code in the second terminal

    Code:

    sudo pppd ttyUSB0 115200 nodetach defaultroute noipdefault noauth lock usepeerdns

    enter your system password

    what does the terminal show

    to exit the pppd ,focus on the terminal window ,type Ctrl + C

    regards

    alexfish
    Last edited by alexfish; September 28th, 2010 at 05:57 PM. Reason: typo "sudo pppd ttyUSB0"
    Two tin cans are better than an iphone

    http://www.ehow.co.uk/how_2067160_ma...hone.html?cr=1

  2. #12
    Join Date
    Sep 2010
    Beans
    7

    Re: pppd issue with sakis3g

    thank you,

    I got the right IP address as 213.162.84.2
    that means, Sakis3g doesn't send the right commands to connect?

    pppd log:
    Code:
    pppd options in effect:
    debug        # (from /etc/ppp/options)
    nodetach        # (from command line)
    dump        # (from /etc/ppp/options)
    noauth        # (from command line)
    /dev/ttyUSB0        # (from command line)
    115200        # (from command line)
    lock        # (from command line)
    crtscts        # (from /etc/ppp/options)
    modem        # (from /etc/ppp/options)
    asyncmap 0        # (from /etc/ppp/options)
    lcp-echo-failure 0        # (from /etc/ppp/options)
    lcp-echo-interval 0        # (from /etc/ppp/options)
    hide-password        # (from /etc/ppp/options)
    ipcp-accept-local        # (from /etc/ppp/options)
    ipcp-accept-remote        # (from /etc/ppp/options)
    noipdefault        # (from command line)
    defaultroute        # (from command line)
    proxyarp        # (from /etc/ppp/options)
    usepeerdns        # (from command line)
    noipx        # (from /etc/ppp/options)
    using channel 2
    Using interface ppp0
    Connect: ppp0 <--> /dev/ttyUSB0
    sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x4f99412e> <pcomp> <accomp>]
    rcvd [LCP ConfReq id=0x1 <accomp> <pcomp> <asyncmap 0x0> <mru 1500> <magic 0x543> <auth chap MD5>]
    sent [LCP ConfNak id=0x1 <auth pap>]
    rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x4f99412e> <pcomp> <accomp>]
    rcvd [LCP ConfReq id=0x2 <accomp> <pcomp> <asyncmap 0x0> <mru 1500> <magic 0x543> <auth pap>]
    sent [LCP ConfAck id=0x2 <accomp> <pcomp> <asyncmap 0x0> <mru 1500> <magic 0x543> <auth pap>]
    sent [PAP AuthReq id=0x1 user="citypan-player" password=<hidden>]
    rcvd [PAP AuthAck id=0x1 "Greetings!!"]
    Remote message: Greetings!!
    PAP authentication succeeded
    sent [CCP ConfReq id=0x1 <deflate 15> <deflate(old#) 15> <bsd v1 15>]
    sent [IPCP ConfReq id=0x1 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
    rcvd [IPCP ConfReq id=0x1]
    sent [IPCP ConfNak id=0x1 <addr 0.0.0.0>]
    rcvd [LCP ProtRej id=0x3 80 fd 01 01 00 0f 1a 04 78 00 18 04 78 00 15 03 2f]
    Protocol-Reject for 'Compression Control Protocol' (0x80fd) received
    rcvd [IPCP ConfNak id=0x1 <compress VJ 0f 01> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
    sent [IPCP ConfReq id=0x2 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
    rcvd [IPCP ConfReq id=0x2]
    sent [IPCP ConfAck id=0x2]
    rcvd [IPCP ConfNak id=0x2 <compress VJ 0f 01> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
    sent [IPCP ConfReq id=0x3 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
    rcvd [IPCP ConfRej id=0x3 <compress VJ 0f 01>]
    sent [IPCP ConfReq id=0x4 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
    rcvd [IPCP ConfNak id=0x4 <addr 213.162.84.2> <ms-dns1 213.162.69.169> <ms-dns2 213.162.65.1>]
    sent [IPCP ConfReq id=0x5 <addr 213.162.84.2> <ms-dns1 213.162.69.169> <ms-dns2 213.162.65.1>]
    rcvd [IPCP ConfAck id=0x5 <addr 213.162.84.2> <ms-dns1 213.162.69.169> <ms-dns2 213.162.65.1>]
    Could not determine remote IP address: defaulting to 10.64.64.64
    Cannot determine ethernet address for proxy ARP
    local  IP address 213.162.84.2
    remote IP address 10.64.64.64
    primary   DNS address 213.162.69.169
    secondary DNS address 213.162.65.1
    Script /etc/ppp/ip-up started (pid 1599)
    Script /etc/ppp/ip-up finished (pid 1599), status = 0x0

  3. #13
    Join Date
    Oct 2009
    Location
    A world without windows
    Beans
    Hidden!

    Re: pppd issue with sakis3g

    wrong assumption about sakis3g I have checked through all the log info in the posts , and pastebin

    From the connection we have basically followed the Sakis3g connection method, with
    exception of optimising pppd for a 3g connection

    in all cases the NM, Sakis3g and the self-made connection is using the correct APN,

    as I said Previously the "local IP address" changes , may show up listed as "IP ADDRESS"

    Here are the listings of the connection logs for all three

    Network Manager log
    rcvd [IPCP ConfAck id=0x4 <addr 78.132.30.74> <ms-dns1 213.162.69.169> <ms-dns2 213.162.65.1>]
    Could not determine remote IP address: defaulting to 10.64.64.64
    Cannot determine ethernet address for proxy ARP
    local IP address 78.132.30.74
    remote IP address 10.64.64.64
    primary DNS address 213.162.69.169
    secondary DNS address 213.162.65.1

    sakis3g log
    rcvd [IPCP ConfAck id=0x4 <addr 10.106.48.227> <ms-dns1 213.162.69.170> <ms-dns2 213.162.65.2>]
    Could not determine remote IP address: defaulting to 10.64.64.64
    Cannot determine ethernet address for proxy ARP
    local IP address 10.106.48.227
    remote IP address 10.64.64.64
    primary DNS address 213.162.69.170
    secondary DNS address 213.162.65.2

    selfmade connection log
    rcvd [IPCP ConfAck id=0x5 <addr 213.162.84.2> <ms-dns1 213.162.69.169> <ms-dns2 213.162.65.1>]
    Could not determine remote IP address: defaulting to 10.64.64.64
    Cannot determine ethernet address for proxy ARP
    local IP address 213.162.84.2
    remote IP address 10.64.64.64
    primary DNS address 213.162.69.169
    secondary DNS address 213.162.65.1

    also noted in Sakis3g ,good optimisation of the pppd options

    hope this clarifies

    regards

    alexfish
    Two tin cans are better than an iphone

    http://www.ehow.co.uk/how_2067160_ma...hone.html?cr=1

  4. #14
    Join Date
    Sep 2010
    Beans
    7

    Re: pppd issue with sakis3g

    Hi,

    It works now perfectly with following Sakis3g configuration,

    Code:
    -console
    --nostorage
    --sudo
    --pppd
    SIM_PIN=6506
    FORCE_APN="business.gprsinternet"
    APN_USER="t-mobile"
    APN_PASS="tm"
    DIAL=*99#
    BAUD=115200
    gruplug
    PPPD_OPTIONS="modem crtscts -detach defaultroute dump noipdefault usepeerdns usehostname ktune logfd 2 noauth lock maxfail 3 ipcp-accept-local ipcp-accept-remote noaccomp nobsdcomp noccp nopcomp novj novjccomp debug"

  5. #15
    Join Date
    Oct 2009
    Location
    A world without windows
    Beans
    Hidden!

    Re: pppd issue with sakis3g

    hi

    good news

    I think Sakis would appreciate a posting on the Sakis3g forum/ Working Setups

    Regards

    alexfish
    Two tin cans are better than an iphone

    http://www.ehow.co.uk/how_2067160_ma...hone.html?cr=1

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •