Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Metadata stopped grabbing coverart - possible update issue

  1. #1
    Join Date
    Aug 2007
    Location
    Pittsburgh, PA
    Beans
    449
    Distro
    Ubuntu 12.04 Precise Pangolin

    Metadata stopped grabbing coverart - possible update issue

    Hey, all. I posted a question on the main Mythtv forums, but haven't been able to nail down a solution yet.

    I recently upgraded my system to Mythbuntu 10.04, and with it, the included new version Myth. I have been going through my library updating the metadata. I love the new grabber, however, it stopped pulling coverart and I'm not sure why. At first, I thought that there just might not be a file available for it, until I realized two things:

    1.) It stopped all at once. By sheer law of averages, with hundreds of files, there would have to be one or two that would have coverart available.
    2.) There was nothing available for pretty popular files, such as movies like Tron and Twelve Monkeys, and TV shows like Dexter, Burn Notice and Breaking Bad (there were some for BB, but it stopped pulling while going through this series.)

    For the most part, it is still pulling running times, release year, actors, plot info, etc - just not the cover files or fan art any longer. A possible fix that was suggested was to "enable the -fixes packages," but the person did not know how to do this in Ubuntu.

    Does anyone have any idea if this would solve my problem, and how I would go about doing it? Also, is Myth not getting any updates when I don't have this option enabled?

    Thanks in advance for the help, and more than likely, apologies to Newlinux for bothering him with another silly question.
    AMD Athlon 64 X2 4400+ 2.3GHz Dual Core, ASUS ATX AMD Motherboard, CORSAIR 4GB RAM, EVGA 512MB GeForce 9500 GT, 1.5TB mirrored RAID, 30GB primary drive, pcHDTV and Hauppauge 1600 tuners. Yeah, this hasn't been accurate for a long time.

  2. #2
    Join Date
    Apr 2008
    Beans
    27

    Re: Metadata stopped grabbing coverart - possible update issue

    Yup - I can confirm that updating to -fixes will definitely solve that problem, as it did for our Myth network.

    I would move to .23.1 when the update installer offers the choice, but ensure you update all networked Myth machines simultaneously.

    Edit: Oops. Shouldn't answer questions before finishing first cup of tea - too many questions *fail* to get answered like that

    You can move to -fixes by visiting http://www.mythbuntu.org/auto-builds - click on Activate auto builds, then on the big Activate icon that appears. When asked by FireFox (which I'll obnoxiously presume you're using), say to open the file with Debi (a package manager) and the rest should be self-evident. Have an appropriate amount of fun

    Cheers,
    Mattt.
    Last edited by pu15e; September 20th, 2010 at 10:23 PM.

  3. #3
    Join Date
    Aug 2007
    Location
    Pittsburgh, PA
    Beans
    449
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Metadata stopped grabbing coverart - possible update issue

    Quote Originally Posted by pu15e View Post
    Yup - I can confirm that updating to -fixes will definitely solve that problem, as it did for our Myth network.

    I would move to .23.1 when the update installer offers the choice, but ensure you update all networked Myth machines simultaneously.

    Edit: Oops. Shouldn't answer questions before finishing first cup of tea - too many questions *fail* to get answered like that

    You can move to -fixes by visiting http://www.mythbuntu.org/auto-builds - click on Activate auto builds, then on the big Activate icon that appears. When asked by FireFox (which I'll obnoxiously presume you're using), say to open the file with Debi (a package manager) and the rest should be self-evident.
    Thanks - install was as easy as you said, and it DL'd a crapload of updates...however, coverart is still not pulling in. Any other ideas?

    Have an appropriate amount of fun
    I shall attempt to control myself.
    AMD Athlon 64 X2 4400+ 2.3GHz Dual Core, ASUS ATX AMD Motherboard, CORSAIR 4GB RAM, EVGA 512MB GeForce 9500 GT, 1.5TB mirrored RAID, 30GB primary drive, pcHDTV and Hauppauge 1600 tuners. Yeah, this hasn't been accurate for a long time.

  4. #4
    Join Date
    Apr 2008
    Beans
    27

    Re: Metadata stopped grabbing coverart - possible update issue

    Hhhmmm...

    Are you highlighting the relevant movie files in myth and pressing w (or whatever you have zoom (i think it is) set to)? That's meant to (and, for us, does) auto-pull the metadata and display it, sometimes asking you to identify which of several possible matches you're looking for.

    That definitely does it for us. Particularly on remote fe's, we do find it takes quite a few seconds for the artwork to show up...

    Also, as a precaution, have you rebooted affected machines to ensure all latest code is running? We've found recently that the be's will bounce during update installs but fe's don't.

    Cheers,
    Mattt.

  5. #5
    Join Date
    Aug 2007
    Location
    Pittsburgh, PA
    Beans
    449
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Metadata stopped grabbing coverart - possible update issue

    Yep, rebooted and everything. As stated in the original post, I'm able to pull in all info except the cover art (using your method.) It just stopped pulling it in at one point. Just for giggles, I also reset the meta data on a few and grabbed it over again. Once again, it just pulled in the text info, no pictures.

    I have a knack for finding the weird ones.
    AMD Athlon 64 X2 4400+ 2.3GHz Dual Core, ASUS ATX AMD Motherboard, CORSAIR 4GB RAM, EVGA 512MB GeForce 9500 GT, 1.5TB mirrored RAID, 30GB primary drive, pcHDTV and Hauppauge 1600 tuners. Yeah, this hasn't been accurate for a long time.

  6. #6
    Join Date
    Apr 2008
    Beans
    27

    Re: Metadata stopped grabbing coverart - possible update issue

    Hhhmm... Yup, that's weird. Only other thing I can think of that I haven't specifically asked yet is did you upgrade to the .23.1 branch (noting the .1)? I'm not sure, but perhaps the patch is only applied to that branch...

    Cheers,
    Mattt.

  7. #7
    Join Date
    Aug 2007
    Location
    Pittsburgh, PA
    Beans
    449
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Metadata stopped grabbing coverart - possible update issue

    Since the installer for the fixes only allowed for 23, I'm guessing not. A.) how do I look up the version, and B.) if it is not, how do I upgrade it?
    AMD Athlon 64 X2 4400+ 2.3GHz Dual Core, ASUS ATX AMD Motherboard, CORSAIR 4GB RAM, EVGA 512MB GeForce 9500 GT, 1.5TB mirrored RAID, 30GB primary drive, pcHDTV and Hauppauge 1600 tuners. Yeah, this hasn't been accurate for a long time.

  8. #8
    Join Date
    Nov 2006
    Location
    Oregon
    Beans
    4,414
    Distro
    Ubuntu Development Release

    Re: Metadata stopped grabbing coverart - possible update issue

    Quote Originally Posted by Weidbrewer View Post
    Since the installer for the fixes only allowed for 23, I'm guessing not. A.) how do I look up the version, and B.) if it is not, how do I upgrade it?
    What version of mythbuntu-repos do you have installed?

  9. #9
    Join Date
    Aug 2007
    Location
    Pittsburgh, PA
    Beans
    449
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Metadata stopped grabbing coverart - possible update issue

    Again, not sure how to tell.

    Everything is installed straight from the Mythbuntu install cd, plus the -fixes mentioned above, patched up to current.
    AMD Athlon 64 X2 4400+ 2.3GHz Dual Core, ASUS ATX AMD Motherboard, CORSAIR 4GB RAM, EVGA 512MB GeForce 9500 GT, 1.5TB mirrored RAID, 30GB primary drive, pcHDTV and Hauppauge 1600 tuners. Yeah, this hasn't been accurate for a long time.

  10. #10
    Join Date
    Nov 2006
    Location
    Oregon
    Beans
    4,414
    Distro
    Ubuntu Development Release

    Re: Metadata stopped grabbing coverart - possible update issue

    Do this in a terminal and paste the output here

    Code:
    dpkg -l mythbuntu-repos
    Then do this and tell me if 0.23.1 is listed

    Code:
    dpkg-reconfigure mythbuntu-repos

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •