Results 1 to 4 of 4

Thread: Unable to install numpy

  1. #1
    Join Date
    Jan 2010
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Question Installation of numpy, matplotlib?

    I am running Ubuntu 10.04 (64-bit) with python 2.6 and have had great difficulties with the installation of numpy and matplotlib (matplotlib needs numpy).

    I have tried several different approaches --- but unsuccessful still.

    I have downloaded the following:

    * python-numpy_1.4.1-4_amd64.deb
    * python-numpy_1.5.0-1ppa1_amd64.deb
    * numpy-1.5.0.tar.gz

    and,

    * matplotlib_0.99.3-1ubuntu1.debian.tar.gz
    * matplotlib_0.99.3.orig.tar.gz
    * matplotlib-1.0.0.tar.gz

    (I gave up on matplotlib 1.0.0)

    How can I install numpy with matplotlib? I have attached a python script to test the installation.

    Help would be appreciated, greatly.
    Attached Files Attached Files
    Last edited by virsto; September 13th, 2010 at 10:25 PM. Reason: new information, left out something

  2. #2
    Join Date
    Jan 2010
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Unable to install numpy

    Ok,
    I now have the latest numpy and matplotlib up and running on my Ubuntu 10.04 64-bit system. Some preliminary testing indicates things are working as they should. I am now summarizing what Eric Firing posted to the matplotlib user group on this, so that others might benefit from his expertise (as I have):

    # Thanks to Eric Firing (efiring@hawaii.edu) who is a member
    # the matplotlib user group for this clever use of Linux commands
    # to solve my problem
    #
    # Lets "clean the slate" before a reinstallation (if you believe older
    # versions are present)
    Code:
    sudo rm -rf /usr/local/lib/python2.6/dist-packages/matplotlib*
    sudo rm -rf /usr/local/lib/python2.6/dist-packages/pylab*
    sudo rm -rf /usr/local/lib/python2.6/dist-packages/mpl_toolkits/mplot3d
    sudo rm -rf /usr/local/lib/python2.6/dist-packages/mpl_toolkits/axes_grid
    sudo rm -rf /usr/local/lib/python2.6/dist-packages/mpl_toolkits/axes_grid1
    sudo rm -rf /usr/local/lib/python2.6/dist-packages/mpl_toolkits/axisartist
    sudo rm  /usr/local/lib/python2.6/dist-packages/mpl_toolkits/*.py
    # Install all the dependencies (installs an old version of numpy)
    Code:
    sudo apt-get build-dep python-matplotlib
    # Now to get rid of the old version of numpy
    Code:
    sudo apt-get remove python-numpy
    # Download the latest numpy tar, untar it, then navigate to
    # where setup.py for numpy is located and give the following commands
    Code:
    python setup.py build
    python setup.py install
    # Repeat the previous for matplotlib (download tar, untar it, etc.)
    Code:
    python setup.py build
    python setup.py install
    and th-th-tha-that-that's all folks!

    --V

  3. #3
    Join Date
    Aug 2005
    Location
    Newcastle upon Tyne,UK
    Beans
    53
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Unable to install numpy

    Well, early 12 months later, a reply.

    Thanks for that, I found it really useful!

    J

  4. #4
    Join Date
    Jun 2011
    Beans
    4

    Re: Unable to install numpy

    Worked 1st time. Much appreciated.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •