Results 1 to 9 of 9

Thread: No sound via HDMI, Asus UL80Vt

  1. #1
    Join Date
    Sep 2010
    Beans
    7
    Distro
    Ubuntu 10.04 Lucid Lynx

    No sound via HDMI, Asus UL80Vt

    Hi,
    I know that topic were mentioned several times, but I cant find solution anywhere.

    My notebook is Asus UL80Vt
    Ubuntu 10.04 64bit
    Nvidia GeForce G210 M(Drivers v 256.53)
    Intel Graphic Card is disabled
    Sound Card: Realtek ALC269 @ Intel 82801IB
    Alsa v 1.0.23

    aplay -l
    Code:
    karta 0: Intel [HDA Intel], urządzenie 0: ALC269 Analog [ALC269 Analog]
      Urządzenia podrzędne: 1/1
      Urządzenie podrzędne #0: subdevice #0
    karta 1: NVidia [HDA NVidia], urządzenie 3: NVIDIA HDMI [NVIDIA HDMI]
      Urządzenia podrzędne: 1/1
      Urządzenie podrzędne #0: subdevice #0
    karta 1: NVidia [HDA NVidia], urządzenie 7: NVIDIA HDMI [NVIDIA HDMI]
      Urządzenia podrzędne: 1/1
      Urządzenie podrzędne #0: subdevice #0
    karta 1: NVidia [HDA NVidia], urządzenie 8: NVIDIA HDMI [NVIDIA HDMI]
      Urządzenia podrzędne: 1/1
      Urządzenie podrzędne #0: subdevice #0
    karta 1: NVidia [HDA NVidia], urządzenie 9: NVIDIA HDMI [NVIDIA HDMI]
      Urządzenia podrzędne: 1/1
      Urządzenie podrzędne #0: subdevice #0
    hope it doesnt need translation

    It's my first time with linux, so I really dont know if I should post here more pieces of information.
    Ive already tried editing alsa-base.conf, however there weren't line with "options snd-hda-intel index=-2", which, accroding to topic with Alsa Upgrade Script, should have been included.

    In Windows 7 everything works fine.

    What should I do?
    Last edited by Eithrial; September 6th, 2010 at 10:10 PM. Reason: spelling error

  2. #2
    Join Date
    Aug 2009
    Location
    Philippines
    Beans
    89
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: No sound via HDMI, Asus UL80Vt

    I don't think there's anything that has to do with hardware selection regarding this. I was almost going to post a similar topic asking for help but I found my solution -- it really very simple. Try if it works for you:

    Click on the 'sound' button on the tray. Go to "Sound Preferences..." Go to the "Hardware" tab, and under "Profile" choose "HDMI output..." That's it!

    I hope this works for you as it did for me. The thing is, it just didn't change automatically.

    You say you're new to Linux so I say "welcome!"

  3. #3
    Join Date
    Sep 2010
    Beans
    7
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: No sound via HDMI, Asus UL80Vt

    Thanks for answer, but everything in sound settings seem to be set correctly.

  4. #4
    Join Date
    Aug 2009
    Location
    Philippines
    Beans
    89
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: No sound via HDMI, Asus UL80Vt

    Do you not have an HDMI option on the "Profiles" under the "Hardware" tab?

  5. #5
    Join Date
    Sep 2010
    Beans
    7
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: No sound via HDMI, Asus UL80Vt

    I have it and is set correctly.

  6. #6
    Join Date
    Aug 2009
    Location
    Philippines
    Beans
    89
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: No sound via HDMI, Asus UL80Vt

    Oh, okay.

    I'm sure someone else has had that and already found a solution... somewhere.

    Cheers.

  7. #7
    Join Date
    Jun 2007
    Beans
    11,064

    Re: No sound via HDMI, Asus UL80Vt


  8. #8
    Join Date
    Dec 2010
    Beans
    1

    Re: No sound via HDMI, Asus UL80Vt

    Please, how did you deactivate your intel graphics card? I can't get that to work

  9. #9
    Join Date
    May 2010
    Beans
    4

    Re: No sound via HDMI, Asus UL80Vt

    Eithrial,

    I am using UL80Vt, after installing ubuntu 10.04.1 64 bit, and installing the repo Nvidia driver,
    I managed to get the HDMI audio to work by first installing Alsa v 1.0.23 using the following guide

    http://monespaceperso.org/blog-en/20...id-lynx-10-04/

    then i refer to the link given by Temüjin

    http://wiki.xbmc.org/index.php?title...T220,_or_GT240

    and the changes i made is

    If using PulseAudio, add the following line to /etc/pulse/default.pa:
    load-module module-alsa-sink device=hw:1,7
    Change the device to hw:1,7 instead of hw:1,3

    In addition, i add myself to the audio group as the guide suggested and reboot.
    Start the alsamixer, press F6 to select the HDA nvidia, and press m to unmute S/PDIF 1 and voila ! My speakers are pumping the sound of joy!
    Last edited by Teodore; December 12th, 2010 at 11:51 AM. Reason: Added the steps for the alsamixer

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •