Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: WoW, Wine, ATI mobility and opengl = argh!

  1. #1
    Join Date
    Nov 2004
    Location
    Philadelphia, PA
    Beans
    48
    Distro
    Ubuntu 13.04 Raring Ringtail

    WoW, Wine, ATI mobility and opengl = argh!

    Hello! I've been trying to get World of Warcraft working on my laptop for about a month now. I'm currently running wine 0.9.11 with the patch from winehq. I've got WoW patched to the latest version, too. I can usually get WoW running in d3d mode at a lousy framerate. It's not great but it's pretty reliable and I can change my graphical settings without crashing. But whenever I try to run in opengl mode, it's a crap shoot. Sometimes it works fantastic for about twenty minutes. But most of the time when I use opengl, the game freezes immediately after the world loads and all the characters are drawn after I log in. When the freeze happens, there's no crash so I never get any debug messages or anything else that could help me out.
    My big question is: Anyone else running WoW under wine on an ATI mobility Radeon X300? I have a Dell Inspiron 9300. I've got fglrxgears running with direct hardware rendering. I've tried ATI's driver versions 8.23.7 (current), 8.22.5 and 8.21.7. I use ATI's drivers to build the breezy package and install from there. I've tried every version of wine since 0.9.6 and I've always had the same problem.
    I'm about to give up and just say, oh well, ATI's drivers won't cut it with this particular setup. I've run Gentoo/fluxbox on the same laptop and had similar results so I don't think I can blame it on Ubuntu or Gnome. But before I give up, I've got to know if anyone else is running this card.
    Thanks for reading!

  2. #2
    Join Date
    Mar 2006
    Location
    Maine
    Beans
    360

    Re: WoW, Wine, ATI mobility and opengl = argh!

    try adding:
    tmpfs /dev/shm tmpfs defaults 0 0

    To your fstab... I was having a problem like that too but the ATI site recommends this and for me its working =D

    sudo gedit /etc/fstab to open it.

    Then restart and enter:
    mount | grep "shm"

    It should return something saying it's mounted... try again and all should be well!

  3. #3
    Join Date
    Nov 2004
    Location
    Philadelphia, PA
    Beans
    48
    Distro
    Ubuntu 13.04 Raring Ringtail

    Talking Re: WoW, Wine, ATI mobility and opengl = argh!

    Quote Originally Posted by Toxicity999
    try adding:
    tmpfs /dev/shm tmpfs defaults 0 0

    To your fstab... I was having a problem like that too but the ATI site recommends this and for me its working =D

    sudo gedit /etc/fstab to open it.

    Then restart and enter:
    mount | grep "shm"

    It should return something saying it's mounted... try again and all should be well!
    Seems to be working so far. I don't believe I missed that in the release notes. WoW looks good with the 8.23.7 drivers in OpenGL. I'm running WoW with all the settings at the lowest level but the framerate is nice and smooth.

    Thanks for your help, Toxicity!

  4. #4
    Join Date
    Nov 2004
    Location
    Philadelphia, PA
    Beans
    48
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: WoW, Wine, ATI mobility and opengl = argh!

    Oops, looks as if it was just another one of those instances where it worked great for a while. I booted up today and everything froze again right after logging in with OpenGL mode.
    Ah well, I'm buying a new laptop with an nVidia card anyway.

  5. #5
    Join Date
    Apr 2006
    Beans
    1

    Re: WoW, Wine, ATI mobility and opengl = argh!

    I'm having the same problem on both Ubuntu and Gentoo, which has shm mounted by default, so I don't think that's the cause. Does anybody else have an idea as to what could be causing this? I have messed with virtually every xorg.conf and Config.wtf option that commonly cause problems and have yet to solve this problem...

    I really have little faith in ATI after my week long (and counting) debacle trying to get WoW to work...

    -rylz

  6. #6
    Join Date
    Apr 2006
    Beans
    2

    Re: WoW, Wine, ATI mobility and opengl = argh!

    Use Cedega it should work I have same setup

  7. #7
    Join Date
    Oct 2005
    Location
    Ohio
    Beans
    336

    Re: WoW, Wine, ATI mobility and opengl = argh!

    I have inspiron 6000 with x300 128 , and 1gig of system memory, I have found that if i play WoW under linux it sucks... I have to boot to windows...


    The way you get around the freeze on bootup is one 1) look for a utility called RovClock, its a overclocker for the x300 under linux, simple command to run. 2) dont move or do anything on login, if you do it freezes, i was able to run around in Orgrimmar just fine, not alot of lag, but more then windows gets, ( in windows WoW is flawless, hardly a laggy spot anywhere ) and i hate windows.. so thats saying alot..
    __________________________________________________ _______

    It's a theme, and this is linux, change it if you don't like it.

  8. #8
    Join Date
    Sep 2006
    Beans
    178

    Re: WoW, Wine, ATI mobility and opengl = argh!

    I had the same problem you did, no matter what I tried or installed. WoW loads, I select my character, enter a world and BAMMMM locks up tighter than a young lady on prom night.

    After about a month of trying everything under the sun, I was about to give up, and install TinyXP or some other flavor of small windows, maybe parellels then windows. Though I didn't want to have to deal with the evil "Billyware(tm)" again.

    Today, while at work while my boss was away, I started my quest again, this time for very low XP, as I've been working on it for a month. But, at lunchtime, I think I finished the quest, and got WoW working with my ATI Radeon x1600 512 megs and AMD64 CPU. I am using the latest ATI drivers as of 10/10/2006.

    So, what I am saying, in this longer than needed email, I can finally play WoW under Ubuntu 6.06!!! I found the help I needed.




    And unlike most people who say they found the answer to their own question, I am going to post mine, even though I don't understand it, I know I was able to play WoW 150 times longer than I could before.

    Open up Xorg.conf and change the following to this:


    Section "Device"
    Identifier "aticonfig-Device[0]"
    Driver "fglrx"
    Option "Capabilities" "0x00000800"
    Option "UseFastTLS" "off"
    Option "KernelModuleParm" "locked-userpages=0"
    EndSection

    Actually, I just added the 3 option lines to mine, restarted X and viola, it worked.

    AGain, I have no clue why it works, just know it does. And I'm also wondering why my Driver line has "fglrx" when I installed the drivers from ATI's site.

    BTW, I found the answer to this on Transgaming's forums, even though I'm running Wine and not Cedega, it worked.

  9. #9
    Join Date
    May 2006
    Location
    USA
    Beans
    2
    Distro
    Ubuntu 6.10 Edgy

    Thumbs down Re: WoW, Wine, ATI mobility and opengl = argh!

    Wow, your fix worked wonders for me. Every time I ran WoW it would freeze after about 10 seconds of being in the game. I am going to try and investigate this stuff more in-depth to try to find better fixes, but for now this is amazing.

    For a FPS speed up, which I will post here as well:

    http://appdb.winehq.org/appview.php?iVersionId=5606
    Corrupt or Missing Text in 0.9.25 and 0.9.26 - here's the fix for ATI cards

    Open a terminal window, (konsole/terminal/x terminal etc..) and type regedit. This will start the wine server
    and the wine equivalent of the windows registry editor will be displayed. If your familiar with using the registry
    editor under windows then this is pretty much the same.

    Find HKEY_CURRENT_USER\Software\Wine\

    Highlight the wine folder in the left hand pane by clicking left on it. The icon should change to an open folder

    Click right on the wine folder and select [NEW] then [KEY]

    Replace the text "New Key #1" with OpenGL

    Click right in the right hand pane and select [NEW] then [String Value]

    Replace "New Value #1" with "DisabledExtensions"
    (Notice it's case sensitive)

    Then double click anywhere on the line, a dialog box will open.
    In the value field type "GL_ARB_vertex_buffer_object" (without the quotes).
    My final task is to get the minimap working perfectly. My minimap goes white whenever I go into a building. Oh well, can't have everything I guess. I have heard this might require a patch to Wine though.

    I am running Wine 0.9.26 - a binary, I didn't build.

  10. #10
    Join Date
    Jul 2006
    Location
    Stockholm, Sweden
    Beans
    342
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: WoW, Wine, ATI mobility and opengl = argh!

    It crashes for me too. I have a laptop with ATi x600
    Sometimes I can play for a long time, but sometimes it just crashes on every attempt.

    here is my xorg.conf

    Code:
    # /etc/X11/xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf(5) manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "ServerLayout"
    	Identifier     "Default Layout"
    	Screen      0  "aticonfig-Screen[0]" 0 0
    	InputDevice    "Generic Keyboard"
    	InputDevice    "Configured Mouse"
    	InputDevice    "stylus" "SendCoreEvents"
    	InputDevice    "cursor" "SendCoreEvents"
    	InputDevice    "eraser" "SendCoreEvents"
    	InputDevice    "Synaptics Touchpad"
    EndSection
    
    Section "Files"
    
    	# path to defoma fonts
    	FontPath     "/usr/share/fonts/X11/misc"
    	FontPath     "/usr/share/fonts/X11/cyrillic"
    	FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
    	FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
    	FontPath     "/usr/share/fonts/X11/Type1"
    	FontPath     "/usr/share/fonts/X11/100dpi"
    	FontPath     "/usr/share/fonts/X11/75dpi"
    	FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    EndSection
    
    Section "Module"
    	Load  "i2c"
    	Load  "bitmap"
    	Load  "ddc"
    	Load  "dri"
    	Load  "extmod"
    	Load  "freetype"
    	Load  "glx"
    	Load  "int10"
    	Load  "vbe"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Generic Keyboard"
    	Driver      "kbd"
    	Option	    "CoreKeyboard"
    	Option	    "XkbRules" "xorg"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "se"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Configured Mouse"
    	Driver      "mouse"
    	Option	    "CorePointer"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "Protocol" "ImPS/2"
    	Option	    "ZAxisMapping" "4 5"
    	Option	    "Emulate3Buttons" "true"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Synaptics Touchpad"
    	Driver      "synaptics"
    	Option	    "SendCoreEvents" "true"
    	Option	    "Device" "/dev/psaux"
    	Option	    "Protocol" "auto-dev"
    	Option	    "HorizScrollDelta" "0"
    EndSection
    
    Section "InputDevice"
    	Identifier  "stylus"
    	Driver      "wacom"
    	Option	    "Device" "/dev/input/wacom"
    	Option	    "Type" "stylus"
    	Option	    "ForceDevice" "ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Identifier  "eraser"
    	Driver      "wacom"
    	Option	    "Device" "/dev/input/wacom"
    	Option	    "Type" "eraser"
    	Option	    "ForceDevice" "ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Identifier  "cursor"
    	Driver      "wacom"
    	Option	    "Device" "/dev/input/wacom"
    	Option	    "Type" "cursor"
    	Option	    "ForceDevice" "ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "Monitor"
    	Identifier   "Generic Monitor"
    	Option	    "DPMS"
    EndSection
    
    Section "Monitor"
    	Identifier   "aticonfig-Monitor[0]"
    	Option	    "VendorName" "ATI Proprietary Driver"
    	Option	    "ModelName" "Generic Autodetecting Monitor"
    	Option	    "DPMS" "true"
    EndSection
    
    Section "Device"
    	Identifier  "ATI Technologies Inc M24 1P [Radeon Mobility X600]"
    	Driver      "fglrx"
    	Option	    "UseFastTLS" "off"
    	Option 	    "Capabilities" "0x00000800"
    	Option 	    "KernelModuleParm" "locked-userpages=0"
    	BusID       "PCI:1:0:0"
    EndSection
    
    Section "Device"
    	Identifier  "aticonfig-Device[0]"
    	Driver      "fglrx"
    	Option	    "VideoOverlay" "on"
    	Option	    "OpenGLOverlay" "off"
    	
    EndSection
    
    Section "Screen"
    	Identifier "Default Screen"
    	Device     "ATI Technologies Inc M24 1P [Radeon Mobility X600]"
    	Monitor    "Generic Monitor"
    	DefaultDepth     24
    	SubSection "Display"
    		Depth     1
    		Modes    "1680x1050"
    	EndSubSection
    	SubSection "Display"
    		Depth     4
    		Modes    "1680x1050"
    	EndSubSection
    	SubSection "Display"
    		Depth     8
    		Modes    "1680x1050"
    	EndSubSection
    	SubSection "Display"
    		Depth     15
    		Modes    "1680x1050"
    	EndSubSection
    	SubSection "Display"
    		Depth     16
    		Modes    "1680x1050"
    	EndSubSection
    	SubSection "Display"
    		Depth     24
    		Modes    "1680x1050"
    	EndSubSection
    EndSection
    
    Section "Screen"
    	Identifier "aticonfig-Screen[0]"
    	Device     "aticonfig-Device[0]"
    	Monitor    "aticonfig-Monitor[0]"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    
    Section "DRI"
    	Mode         0666
    EndSection
    
    Section "Extensions"
    	Option	    "Composite" "Disable"
    EndSection
    and here is my Config.wtf

    Code:
    SET gxColorBits "24"
    SET gxDepthBits "24"
    SET gxResolution "1280x1024"
    SET gxRefresh "60"
    SET hwDetect "0"
    SET fullAlpha "1"
    SET lodDist "100.000000"
    SET SmallCull "0.040000"
    SET DistCull "500.000000"
    SET trilinear "1"
    SET frillDensity "32"
    SET farclip "477"
    SET specular "1"
    SET pixelShaders "1"
    SET particleDensity "1.000000"
    SET unitDrawDist "300.000000"
    SET movie "0"
    SET readTOS "1"
    SET realmList "eu.logon.worldofwarcraft.com"
    SET readEULA "1"
    SET readScanning "-1"
    SET readContest "-1"
    SET gxMultisampleQuality "0.000000"
    SET gxFixLag "0"
    SET locale "enGB"
    SET mouseSpeed "1"
    SET MusicVolume "0.40000000596046"
    SET SoundVolume "1"
    SET MasterVolume "1"
    SET realmName "Draenor"
    SET mouseInvertPitch "1"
    SET cameraYawMoveSpeed "180"
    SET cameraYawSmoothSpeed "180"
    SET cameraDistanceMaxFactor "1"
    SET gameTip "66"
    SET AmbienceVolume "0.60000002384186"
    SET ShowTargetCastbar "1"
    SET expansionMovie "0"
    SET minimapZoom "0"
    SET Gamma "1.000000"
    SET minimapInsideZoom "0"
    SET uiScale "1"
    SET gxApi "OpenGL"
    SET ffxDeath "0"
    SET ffxGlow "0"
    SET SoundOutputSystem "1"
    SET SoundBufferSize "160"
    SET timingTestError "3"
    any tips on why it crashes?
    - Jaxilian -

    ||embrace the inevitable||

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •