Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: No sound SB Audigy Ubuntu 10.04

  1. #1
    Join Date
    Jun 2006
    Beans
    81

    [STILL!] No sound SB ca0106 Ubuntu 10.04

    I recently upgraded to 10.04 on my homebuilt computer. I have Soundblaster Audigy as a soundcard. What little sound I get is horribly scratchy with about 3/4 scratchy, 1/4 sound.

    I have checked to see that the speakers work by testing them on another machine. About halfway through this process, noted below, I bought a new Soundblaster Audigy card and installed that.

    aplay -l gives me:

    Code:
    ** (gnome-alsamixer:2001): WARNING **: gam_toggle_get_state (). No idea what to do for mixer element "Analog Source"!
    
    ** (gnome-alsamixer:2001): WARNING **: gam_toggle_get_state (). No idea what to do for mixer element "Digital Source"!
    
    ** (gnome-alsamixer:2001): WARNING **: gam_toggle_get_state (). No idea what to do for mixer element "Shared Mic/Line in"!
    dennis@tilda:~$ gnome-alsamixer
    
    ** (gnome-alsamixer:2008): WARNING **: gam_toggle_get_state (). No idea what to do for mixer element "Analog Source"!
    
    ** (gnome-alsamixer:2008): WARNING **: gam_toggle_get_state (). No idea what to do for mixer element "Digital Source"!
    
    ** (gnome-alsamixer:2008): WARNING **: gam_toggle_get_state (). No idea what to do for mixer element "Shared Mic/Line in"!
    dennis@tilda:~$ gnome-alsamixer
    
    ** (gnome-alsamixer:2014): WARNING **: gam_toggle_get_state (). No idea what to do for mixer element "Analog Source"!
    
    ** (gnome-alsamixer:2014): WARNING **: gam_toggle_get_state (). No idea what to do for mixer element "Digital Source"!
    
    ** (gnome-alsamixer:2014): WARNING **: gam_toggle_get_state (). No idea what to do for mixer element "Shared Mic/Line in"!
    dennis@tilda:~$ gnome-alsamixer
    
    ** (gnome-alsamixer:2026): WARNING **: gam_toggle_get_state (). No idea what to do for mixer element "Analog Source"!
    
    ** (gnome-alsamixer:2026): WARNING **: gam_toggle_get_state (). No idea what to do for mixer element "Digital Source"!
    
    ** (gnome-alsamixer:2026): WARNING **: gam_toggle_get_state (). No idea what to do for mixer element "Shared Mic/Line in"!
    dennis@tilda:~$ aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: CA0106 [CA0106], device 0: ca0106 [CA0106]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: CA0106 [CA0106], device 1: ca0106 [CA0106]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: CA0106 [CA0106], device 2: ca0106 [CA0106]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: CA0106 [CA0106], device 3: ca0106 [CA0106]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    lspci -v (sound segment) gives me:

    Code:
    01:07.0 Multimedia audio controller: Creative Labs CA0106 Soundblaster
    	Subsystem: Creative Labs Device 100a
    	Flags: bus master, medium devsel, latency 32, IRQ 17
    	I/O ports at ac00 [size=32]
    	Capabilities: <access denied>
    	Kernel driver in use: CA0106
    	Kernel modules: snd-ca0106
    so I know that my module is: snd-ca0106

    I have played with the settings under System > Preferences > Sound Preferences and uninstalled and reinstalled gnome-alsamixer. From there, I bought an installed a new Soundblaster Audigy card. Then, I reinstalled the entire OS, hoping for a miracle. No dice. I keep going round and round. Any help?
    Last edited by Priswell; February 6th, 2011 at 07:09 PM. Reason: sum total of changes over time

  2. #2
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 15.04 Vivid Vervet

    Re: No sound SB Audigy Ubuntu 10.04

    Audigy
    If your Creative Audigy card is not giving you any sound, make sure the analog/digital check box in your sound mixer is unchecked. Updates seem to reset this switch regularly so keep this in mind.

  3. #3
    Join Date
    Jun 2006
    Beans
    81

    Re: No sound SB Audigy Ubuntu 10.04

    make sure the analog/digital check box in your sound mixer is unchecked. Updates seem to reset this switch regularly so keep this in mind.

    Thank you for responding. The analog/digital check box is unchecked. Any other ideas?

  4. #4
    Join Date
    Jun 2006
    Beans
    81

    Re: No sound SB ca0106 Ubuntu 10.04

    Can anybody offer any additional help? Here's my lspci -v for my sound:

    01:07.0 Multimedia audio controller: Creative Labs CA0106 Soundblaster
    Subsystem: Creative Labs Device 1006
    Flags: bus master, medium devsel, latency 32, IRQ 17
    I/O ports at ac00 [size=32]
    Capabilities: <access denied>
    Kernel driver in use: CA0106
    Kernel modules: snd-ca0106

    Is there any other information I can give you to help me?
    Last edited by Priswell; September 30th, 2010 at 05:30 AM. Reason: additional info

  5. #5
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 15.04 Vivid Vervet

    Re: No sound SB Audigy Ubuntu 10.04

    Use the alsa-info-script to provide detailed information.
    Run this command in a terminal:
    Code:
    wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
    Choose the upload option and provide a link for the output.

  6. #6
    Join Date
    Jun 2006
    Beans
    81

    Re: No sound SB Audigy Ubuntu 10.04

    The link you gave me generated this link:

    http://www.alsa-project.org/db/?f=60...67ea62a1e837ad

    What do I do next?

  7. #7
    Join Date
    Sep 2008
    Location
    Scotland
    Beans
    37
    Distro
    Xubuntu 8.04 Hardy Heron

    Re: No sound SB Audigy Ubuntu 10.04

    I took the liberty of using your data gathering script and generating this link to my system data as well .

    I have no sound what so ever On a fresh 10.04 install
    An pointers would be greatly appreciated

    AD

    http://www.alsa-project.org/db/?f=8e...4e2fc55ecd5879

  8. #8
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 15.04 Vivid Vervet

    Re: No sound SB Audigy Ubuntu 10.04

    Quote Originally Posted by AnxietyDrive View Post
    I took the liberty of using your data gathering script and generating this link to my system data as well .

    I have no sound what so ever On a fresh 10.04 install
    An pointers would be greatly appreciated

    AD

    http://www.alsa-project.org/db/?f=8e...4e2fc55ecd5879
    Firstly, your code is an AC'97 driver , not hda-intel. More specifically snd-intel8x0, so remove any lines you added to alsa-base.conf and update your alsa install via the link in my sig.

  9. #9
    Join Date
    Sep 2008
    Location
    Scotland
    Beans
    37
    Distro
    Xubuntu 8.04 Hardy Heron

    Re: No sound SB Audigy Ubuntu 10.04

    Hi Lidex

    Couldn't recall the changes made to alsa-base.cfg if any so I decided to put a fresh 10.04 install in and send you a new link.

    So apart from the Ubuntu updates after installation this is vanilla.

    If you need any further info just let me know.

    http://www.alsa-project.org/db/?f=ca...8c812c114f6665
    Last edited by AnxietyDrive; December 9th, 2010 at 01:18 AM.

  10. #10
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 15.04 Vivid Vervet

    Re: No sound SB Audigy Ubuntu 10.04

    @AnxietyDrive
    OK. Let's try this first. Rather than a full upgrade to alsa try updating your alsa-driver-modules.
    Using a Terminal="Applications->Accessories->Terminal"
    Add the ubuntu-audio-dev ppa:
    Code:
    sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
    sudo apt-get update
    Now install:
    Code:
    sudo apt-get install linux-alsa-driver-modules-$(uname -r)
    Reboot
    Check your levels in alsamixer.
    Code:
     alsamixer
    Press <F6> to select the correct soundcard.
    Press <F3> to show playback levels. <F4> selects capture levels [or use <Tab>]
    Use the left/right arrow keys to select and up/down arrow keys to change levels. <M> to mute/unmute.
    Go to "System ->Preferences ->Sound" and make sure the correct soundcard is default and adjust your profile on the hardware tab.
    On the output tab choose the correct device.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •