Results 1 to 6 of 6

Thread: Nautilus "Open Terminal Here" doesn't work

  1. #1
    Join Date
    Mar 2009
    Beans
    47

    Nautilus "Open Terminal Here" doesn't work

    I installed nautilus-open-terminal, and now the option "Open in Terminal" does show up in the context menu for me in Nautilus, and clicking it does open a terminal. But it just opens to the home directory, every time, same as if I'd opened a terminal in the ordinary way.

    I've tried to look for solutions to this, but I can't find anyone that even has the same problem. Other people complaining about it all seem to be saying that a terminal doesn't even open for them, which is not the case for me.

    I'm at a loss. Ideas would be appreciated.

    Running Karmic, a brand new install.

  2. #2
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: Nautilus "Open Terminal Here" doesn't work

    Here in Lucid, it works just fine. If I open a terminal from a home Nautilus, I get the prompt:

    Code:
    coffeecat@amd4-Lucid:~$
    ... which is correct. But if I navigate to the /etc/grub.d folder in Nautilus and open a terminal, I get:

    Code:
    coffeecat@amd4-Lucid:/etc/grub.d$
    ... which is also correct.

    Perhaps there's a bug in the Karmic version. If I get time later today, I'll boot into Karmic, install the open-terminal package, and see what I get.
    Ubuntu 15.04 Desktop Guide - Ubuntu 14.04 Desktop Guide - Forum Guide to BBCode - IRC #ubuntuforums

    Member: Not Canonical Team

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

  3. #3
    Join Date
    Mar 2009
    Beans
    47

    Re: Nautilus "Open Terminal Here" doesn't work

    Well, I found the problem, but I still don't know how to fix it. The "--working-directory" option doesn't work for me in opening a terminal. That is, the command:

    Code:
    gnome-terminal --working-directory="$DIR"
    doesn't work. When I use this command, typing it myself in a terminal, it opens another terminal to the home directory. It completely ignores the option, no matter what I fill in for $DIR. I have no idea why this isn't working.

  4. #4
    Join Date
    Nov 2009
    Beans
    1,203

    Re: Nautilus "Open Terminal Here" doesn't work

    Perhaps reinstalling it might fix the issue.

    sudo aptitude purge nautilus-open-terminal && sudo aptitude install nautilus-open-terminal

  5. #5
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: Nautilus "Open Terminal Here" doesn't work

    Quote Originally Posted by Cephi View Post
    Well, I found the problem, but I still don't know how to fix it. The "--working-directory" option doesn't work for me in opening a terminal. That is, the command:

    Code:
    gnome-terminal --working-directory="$DIR"
    I'm in Karmic now. Nautilus-open-terminal is working just as it did in Lucid - which is OK. And the gnome-terminal command with the --working-directory option works for me as well. Sorry I can't be of more help.
    Ubuntu 15.04 Desktop Guide - Ubuntu 14.04 Desktop Guide - Forum Guide to BBCode - IRC #ubuntuforums

    Member: Not Canonical Team

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

  6. #6
    Join Date
    Mar 2009
    Beans
    2

    Re: Nautilus "Open Terminal Here" doesn't work

    Have you tried looking at ~/.bashrc and making sure there are no custom commands in there overriding the cd to the dir...?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •