Page 3 of 3 FirstFirst 123
Results 21 to 23 of 23

Thread: No Synaptics Touchpad

  1. #21
    Join Date
    Aug 2010
    Beans
    9

    Re: No Synaptics Touchpad

    Could you clearify what kind of functionality that you got working with this old kernel?

    The reason I ask is that my research indicate that the problem with the Alps touchpad is two-fold. At one level the touchpad is incorrectly recognized as a PS2 mouse and not as a TouchPad. On the other hand the behavior is pretty rational in those cases when the Kernel encounter a TouchPad that uses a protocol that has still not been reverse engineered.

    In the following Kernel discussion they are working to understand the protocol of new Alps TouchPads
    https://bugzilla.kernel.org/show_bug.cgi?id=14660

    There seems to be a patch developed together with Dell to get scrolling to work to some degree on at least some of the new Alps models. I am bit a hesistant to try that one since I am not very comfortable to patch the kernel. The lack of scrolling is not a big deal for me. Multitouch support would be a different thing.

    The right launchpad issue for this problem is as far as I can tell btw https://bugs.launchpad.net/ubuntu/+s...ux/+bug/606238

  2. #22
    Join Date
    Sep 2010
    Beans
    6

    Re: No Synaptics Touchpad

    I have the same Problem with Dell e6410 and ubuntu 10.10 64bit. the trackpad is just recognized as a ps2-mouse. I am so far o.k with it, but I would like to turn off the touchpad during typing. Which of the several workarounds I should try? I just need to define a Shortkey for Turn-on-off. Thanks

  3. #23
    Join Date
    Jun 2010
    Beans
    72

    Re: No Synaptics Touchpad

    Hi, sorry for the delay with answer.

    I did the following:

    (see https://bugzilla.kernel.org/show_bug.cgi?id=14660)

    I have downloaded the script and attached it to "Win+z" shortcut through the terminal (to do so just go System -> Preferences -> Keyboard shortcuts; "Win" is the windows key on the keyboard): "xterm /home/YourUsename/toggleps2.sh" and it works!!! it disables the touchpad and I can use the external mouse!!!!

    the script that i got from the above links is:

    :~$ cat ./toggleps2.sh
    #!/bin/bash

    state=`xinput --list-props "PS/2 Generic Mouse" | grep Enabled | awk '{print $4}'`
    #echo "state = "$state;

    if [ $state = '1' ]
    then
    xinput --set-prop --type=int --format=8 "PS/2 Generic Mouse" "Device Enabled" "0"
    else
    xinput --set-prop --type=int --format=8 "PS/2 Generic Mouse" "Device Enabled" "1"
    fi


    This helps with the external mouse attached.

    BUT: I ALSO WANT SOLUTION WHEN THE TOUCHPAD is properly recognised by ubuntu; this seems to be ongoing issue.

Page 3 of 3 FirstFirst 123

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •