Results 1 to 5 of 5

Thread: Two finger scrolling option disabled/grayed out

  1. #1
    Join Date
    Feb 2010
    Location
    Coimbra, Portugal
    Beans
    17
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Two finger scrolling option disabled/grayed out

    Hi all.

    I have Ubuntu 10.04 installed on my HP Pavilion dv3-2150ep and I really miss the two finger scrolling feature. I'm pretty sure I have a synaptics touchpad and I have this on Windows 7 working.

    I tried to enable this on the System > Preferences > Mouse settings but the two finger scrolling option it's disabled/grayed out.

    Any thoughts on how can I enable it or how can I check my touchpad model/information?

    Thanks in advance. Cheers.

  2. #2
    Join Date
    Aug 2010
    Beans
    4

    Re: Two finger scrolling option disabled/grayed out

    I have the same problem on a Dell Studio 15 (1558). A workaround can be found here. I set up a script with those contents and have it run at boot, and the script also includes some other touchpad settings (e.g. set two fingers to middle click instead of right click). Unfortunately there are still some times (I can't figure out when) that the GNOME mouse configuration tool overrides the settings and I lose two-finger scroll and I have to run the script again. But it works, more or less. Hopefully this will be fixed, but there hasn't been much activity on this (seemingly) related bug report.

  3. #3
    Join Date
    Jan 2011
    Location
    Ontario, Canada
    Beans
    11
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Two finger scrolling option disabled/grayed out

    After many, many hours of googling and trial and error, I found a solution that works.

    1. Open up a terminal
    2. Type the following codes in
    Code:
    synclient VertTwoFingerScroll=1
    synclient HorizTwoFingerScroll=1
    synclient EmulateTwoFingerMinW=5
    synclient EmulateTwoFingerMinZ=48
    Please note that I am using a HP-DM41050CA with a PS/2 Synaptics Touchpad. Two finger scrolling works great, horizontal and vertical. Also, unlike Windows I can go diagonally and freely in any direction, which i think is absolutely amazing.

    NOTE: This code will stop working after reboot, so open gedit and paste the code above into it. Then save the file with any name as a (.run) file in your home directory. Assuming you are using 10.04 Ubuntu, go to System>Preferences>Startup Applications and add that (.run) file to the list.

    Hope this helps! It's the only thing that works for me.

  4. #4
    Join Date
    Feb 2010
    Location
    Belgium
    Beans
    14
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Two finger scrolling option disabled/grayed out

    Installing the attachment given in reply #116 on this bug solved this problem for me (without any workarounds). After installing and rebooting, I was able to check the two-finger scrolling box. (Also, two finger tapping for a right click works automatically).
    Hope it works for you too.

  5. #5
    Join Date
    Aug 2008
    Location
    Guatemala
    Beans
    6
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Two finger scrolling option disabled/grayed out

    @Vedster worked like a charm :] I didn't know it was possible to play with synclient like that :]

    @Lebuin that one didn't work for me :S I don't really know why, but it didn't work :S

    May I suggest that if you're going to spend some time playing with the manual:

    Code:
    man synaptics
    It really helps and you get to check all the features available.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •