Results 1 to 3 of 3

Thread: X starts in tty8 instead of tty7

  1. #1
    Join Date
    Jul 2007
    Location
    Nashville TN
    Beans
    130
    Distro
    Ubuntu 14.04 Trusty Tahr

    Lightbulb X starts in tty8 instead of tty7 - NOPE, NOT SOLVED

    I don't know when this started but I noticed today that my desktop is starting in tty8 instead of the normal tty7. tty7 shows a blinking text cursor in the upper-right corner which doesn't respond to the keyboard.

    I don't guess this is serious, but I'm REALLY curious! I have installed Ubuntu Tweak, but I can't see anywhere where I may have made any changes to cause this.

    In a search for answers, what mention I could find about sessions suggest editing (with gksudo) either /etc/inittab or /etc/event.d, but these files appear no longer to be located in /etc in Lucid (or Gnome 2.30.2 , but elsewhere. So I don't want to attempt any changes. Can someone provide more current information?

    Ubuntu 10.04 Lucid
    Kernel 2.6.32-24-generic
    Gnome 2.30.2
    Session Gnome

    ADDED: I restarted and the desktop is back in tty7. I think this may have something to do with my recent experimenting with running OpenBox in place of Metacity. Anyway, if anyone knows how the number of available sessions is set, I'm still interested. Thanks!

    ADDED 09/01/2010: Restarting causes X to start in the standard tty7 but, logging off then back on consistently reproduces the "X in wrong tty" problem (if it is a problem.) This is why I thought this was related to testing an alternate window manager (OpenBox.) Actually it is connected to the logon/off process when switching wms. I am running Metacity (compositing turned off) and without Compiz, if this helps.

    A web search for "tty8" yields various inconclusive discussions about a running process that prevents tty7 from being deallocated when logging off, which makes it unavailable when logging back in.

    http://osdir.com/ml/debian-user-debi...ads.html#00662
    http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=348033
    http://comments.gmane.org/gmane.linu...an.user/374025

    If anyone is aware of potential undesirable consequences with having the X desktop running in other than tty7, please let me know. The workaround for my case (one user logging on/off,) is to select Restart at the login prompt instead of logging back on to Gnome desktop after testing an alt window manager.
    Last edited by rtimai; September 7th, 2010 at 12:50 AM. Reason: typo

  2. #2
    Join Date
    May 2008
    Location
    Rhode Island
    Beans
    17
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: X starts in tty8 instead of tty7

    Also using

    Ubuntu 10.04
    kernel 2.6.32-24-generic
    GNOME 2.30.2

    I've noticed the same phenomenon of X running in tty8 after several times logging in/out. Curious also as to the cause
    Last edited by Insperatus; September 6th, 2010 at 08:29 PM. Reason: left something out

  3. #3
    Join Date
    Jul 2007
    Location
    Burlington, NC
    Beans
    1,994
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: X starts in tty8 instead of tty7

    I think it has something to do with modern distros' "Switch User" ability.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •